External (Mediatek) WiFi adapter/dongle not working with May/June 2017 update

Doesn’t look like an 8812au, but rather a Mediatek 7610U.
We’ve never officially supported this dongle, beyond the official OSMC one.

Will look tomorrow and see if it can be resolved in next month’s update. Can you take a photo of the dongle?

Thanks

Here’s a picture of the dongle. I hope you get it figured out, I just bought 2 of them 2 days ago, lol. Should I hold out for a fix or should I return them? They worked great BTW, lol.

I’ll investigate. If it’s a missing VID/PID combo, it’s an easy fix.
But 8812au was the only driver I significantly changed, so shouldn’t be that.

The official dongle is MT7610U based and I only added support for 4.9 (tested). Didn’t change anything that would impact support for existing devices, so it needs further investigation.

Sam

An update will come later today which will resolve this issue.

Great work Sam, thanks for the extremely prompt support!

Awesome, thank you Sam!

It would be great if someone could test this kernel, which hopefully
resolves the issue.

wget "https://www.dropbox.com/s/uaimeepufmaf825/rbp2-image-4.9.29-4-osmc.deb?dl=1" -O kernel.deb
sudo dpkg -i kernel.deb
sudo reboot

Looking forward to your feedback

Sam

I can confirm this solved the issue for my OSMC WiFi Dongle (Mediatek)

An update came but still no wifi

Did you try the wget solution that @sam_nazarko posted?

Yea i did but solved nothing. After that till now i have received 2 updates by manually updating in my osmc but still no solution.
Looks like i should install osmc 16 and block updates and stay happy lol.

You don’t say what dongle you have, so how about a dmesg so your problem can be checked out?

If that works for you, go for it.
I suspect others will be happy to wait 30 minutes for an update instead :wink:

I don’t think you tried my solution in the 8192EU thread

Hi Sam,

After the update my AC dongle stopped to detect AC net’s, he only detects N.

[ 1865.964334] usb 1-1.5: new high-speed USB device number 5 using dwc_otg
[ 1866.095282] usb 1-1.5: New USB device found, idVendor=7392, idProduct=a812
[ 1866.095307] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1866.095318] usb 1-1.5: Product: Edimax AC600 USB
[ 1866.095328] usb 1-1.5: Manufacturer: Realtek

Thanks,

AC600 isn’t a MediaTek dongle. It says Realtek in your paste above

That’s a Realtek device. Start a separate thread as this thread is about Mediatek devices.

Ok

I tried this earlier and did not work

wget “https://www.dropbox.com/s/pvepk50no24t17x/rbp2-kernel-mk2.deb?dl=1” -O kernel.deb
sudo dpkg -i kernel.deb
sudo reboot
After reading your messege i searched and found this one

Can you try: wget “https://www.dropbox.com/s/pvepk50no24t17x/rbp2-kernel-mk2.deb?dl=1” -O kernel.deb sudo dpkg -i kernel.deb sudo reboot And post dmesg if still not working Thanks

And i am very happy to say that it is once again working flawlessly.
Thanks alot really appretiate it.

I tried this, and my adapter shows up again, but only for N, not AC.

I also did both the updates.

Here is the dmesg link:

https://paste.osmc.tv/boxacohiha

Means nothing to me, but I do spot some errors.

Cheers
Dave

Hello,

I have encountered a similar issue. I have Edimax wifi dongle AC450 (EW-7711ULC) and it is not working after latest updates. Output of dmesg contains following:

[ 3.387950] usb 1-1.4: new high-speed USB device number 5 using dwc_otg
[ 3.401363] fuse init (API version 7.26)
[ 3.533081] usb 1-1.4: New USB device found, idVendor=7392, idProduct=a711
[ 3.533089] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3.533094] usb 1-1.4: Product: WiFi
[ 3.533098] usb 1-1.4: Manufacturer: MediaTek
[ 3.533102] usb 1-1.4: SerialNumber: 1.0

Whole dmesg output: https://paste.osmc.tv/emudipuzel

Output of lsusb:

Bus 001 Device 005: ID 7392:a711 Edimax Technology Co., Ltd
Bus 001 Device 004: ID 0c40:7a17
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The ifconfig command shows only the internal wlan0 interface (I also tried to disable internal wifi with no luck).

Could you please help me? Thank you.