Failed update, now "no updates available"

As the title says, I tried to update via my OSMC (automatic updates still don’t seem to work). The update failed, and now my OSMC says there are no updates available.

For what it’s worth, hyperion has also stopped working.

Any ideas?

Device: raspi2
Installation media: SDcard
Connection: Wired
Power Supply Type: pihub
Peripherals: usb rc6 remote, usb keyboard
Storage Device (incl. Network Sharing Protocol): NAS drive with NFS
OSMC version: 2015.07-1
Audio/Video Output: HDMI
Overclocked: turbo


From your log, I noticed some issues with Perl. Perl is perhaps one of the largest packages on OSMC in terms of files. As such, it is most vulnerable to potential corruption.

The new OSMC kernel was the package that specifically failed, however, so far, no users have reported issue with this on Raspberry Pi. The reason that this upgrade failed is likely because it depends on a Perl script, ‘mkknlimg’.

Can you please provide some information as to how you are powering the unit? I’m not sure what ‘pihub’ is, but does it cover the necessary amperage, and give some insight as to what SD card you are using?


Apologies, I thought the pihub was more well known. It’s a 3A USB hub style charger specifically built for the raspi

And I’m using a Samsung 16GB Class 10 Grade 1 microSD

Not just mkknlimg - the entire preinst and postinst scripts in the rbp2-image package are written in perl, so anything corrupt with the perl installation is going to cause the kernel package to fail to install. I can’t think of any other system packages off hand whose preinst and postinst are written in perl so that’s why nothing else failed.

You could try doing a forced reinstall of perl, but if the underlying cause is file system corruption then it may only be a band aid fix or may actually make things worse:

sudo apt-get install perl perl-base perl-modules --reinstall

Afterwards try the following:

sudo apt-get update
sudo dkpg --configure -a
sudo apt-get -f dist-upgrade

Just tried the perl reinstall and the other commands, nothing noticeably changed. My OSMC still reports version 2015.07-1 and no available updates.

Edit: Wait, I’m confused. The sticky at the top of this forum has 2015.07-1 as the latest version, but I’m sure I’ve seen people referencing a 08-3 version. Am I being thick? or has the sticky not been updated?

I can’t speak to your version question (I’m on 2015.07-1 and have no updates either so you’re probably up to date), but a good program to run if you are worried about files being corrupted is debsums, it will go through and check all files installed from the repo and cross check md5sum’s with apts list. The only annoyance is that when I first ran it I found OSMC had deleted a lot if not all man files so until I fixed those (optional) I had quite the list to read through. I did fix them and only have it ever show four changes now but I know they’re normal to be changed

After install just run “sudo debsums -s”

2015.07-1 is what you should have.

Did you try the commands I suggested above ?

Checking for updates with the My OSMC updater won’t work because it won’t see the partially installed kernel package as something that needs re-installing.

Yes I did. The perl reinstall executes okay, then the first and last of the next three execute fine, but the second one says

osmc@osmc:~$ sudo dkpg --configure -a
sudo: dkpg: command not found

It was a typo, should be dpkg.