Failed update then black screen on reboot


#1

Hi

I turned on my TV today to see a message on the Vero 4k that it had an error installing an update (or words to that effect). The system seemed to be working ok, apart from a lack of internet acces despite the settings telling me it was connected. So, I went to the main screen and used the power icon to do a restart.

The system started to reboot and the TV tells me that it will switch to CEC etc so my remote will control the Vero 4k. The LED on the front of the Vero 4k is blue as normal, however I get nothing on my TV. I have not moved or changed the TV or the Vero 4k or the HDMI. I just get this black screen with nothing displayed.

I can FTP and SSH to the device though so I know it has booted at least that far.

Any advice on getting this back to running with a GUI??

Thanks

Ben


#2

Upload logs with grab-logs -A


#3

Sorry, here they are: https://paste.osmc.tv/iyuwowesit


#4

I’m also getting ocasional blank screen. Not sure if it is related.
Log attached: https://paste.osmc.tv/aholomecug

18:07:20>> TV Off
18:14:10 >> TV On
18:14:20 >> AVR on
18:14:30 >> AVR switchs from the Vero4k output to the AVR home page
Vero video goes blank and subsequent operations were not able to return Vero 4k Dislapy.

logs generated from command SSL terminal.


#5

Once I had the black screen and left it for some minutes to see if it would come to life, I tried unplugging the Vero 4k and plugging it back in again. The same thing happened, I got nothing on the TV. No OSMC logo, nothing, just black apart from the TV produced messages about the CEC.

I then left it like this and carried on doing some food and getting the kids to bed etc. I turned the TV on a coulple of hours later and the main OSMC screen was showing like it should be ?!?!? I found another forum post where someone left it with a black screen for some hours and theirs came back to life, and this is what mine has done.

I have checked now and I am on v17.6 from 31 Dec 2018 OSMC 2018 12-1.

Any thought as to why it would not boot the GUI initially and took a LONG time for this to then come up? Anything show up in the logs?

Many thanks


#6

Did you publish some logs regarding this?

@mosmos seems to report different symptoms to you

Cheers

Sam


#8

Hi Sam. Yes I did publish the logs, link here: https://paste.osmc.tv/iyuwowesit
Thanks


#9

Morning Sam. Did the logs reveal anything as to the cause for no GUI after the failed update? It is a bit concerning at the moment that an automatic update caused the box to effectively become useless until it suddenly showed the GUI later in the day. Thanks for your ongoing assistance


#10

When you performed the update; had you powered Vero on before your TV? If you go to Power -> Exit, do you see the OSMC splash screen?

It’s possible that for some reason the framebuffer’s scaling parameters weren’t configured as expected.

Sam


#11

Your log doesn’t show anything obvious, can you try enable debug logging?
Does every reboot cause a hang?

If so: make sure Wait for Network isn’t enabled under My OSMC -> Network.
Are you using a MySQL database?


#12

Ok thanks Sam. I will check out the enable debug logging if I can recreate this. To be honest I havent wanted to reboot it now it was back up again; I will check though so we know.

For info I am not using any MySQL dbs and the Wait for Network isnt enabled. This is basically a very standard set up. All I have done with it is connect to the internet and plug in the USB hard drive with the media on it.

Other than that I dont think I have changed any settings.


#13

The debug log will likely let us see what’s going on.
If your installation isn’t too complex, you could just reinstall OSMC.

Sam


#14

Hi Sam

I did a reboot of the system and again it black screened for me. When it rebooted I didnt see any loading logo etc, just a black screen that stayed black. I watched the screen for perhaps 15-20 minutes and it never changed. I then went and did something else and cam back an hour later and the screen GUI was loaded. Wierd.

I have gone thorugh the GUI and said to submit all logs, the URL is here: https://paste.osmc.tv/kozepaseko

Does this give you enough info to look in to this?

Could this be having any impact on the other forum post from me (Best / fastest connection between 2 Vero 4k boxes) ? Just thought I would mention this as that post is regarding very slow initial access of media from this box that doesnt like starting up from my other Vero 4k box, and this start up is either extremely slow or something is failing.

Kind regards


#15

Kodi debug logging isn’t enabled; so we may be missing some points.
The log looks OK.

If there’s a performance problem – it may cause issues with playback.
I would suggest re-installing OSMC. See https://osmc.tv/wiki/vero-4k/reinstalling-osmc/.

Sam


#16

Thanks Sam. I will try enabling the debug logging then rebooting and assuming the same black screen issue upload the logs. I will also try re-installing OSMC and let you know the results. Have a great day.


#19

Your log shows a log of HDMI plugin/plugout events.
You could try another HDMI cable.

Sam


#20

Cool, will do. I used the one that came with the Vero box, but I am sure I have another one I can swap it with.


#21

Morning Sam. On checking, this Vero 4k box didnt have the HDMI cable that came with it; I had used a Sky one. I swapped that for the original one that came with the Vero 4k box. I hadnt noticed any disconnecting / reconnecting by way of the picture flicking in and out though.

After that I enabled the debug logging and then did a restart of the box. Oh no! It looked to have shut down cleanly with the small white text on the top lef tof the screen, however on reboot I still get nothing, no logos, no backgrounds, no messages and no GUI.

I kept an eye on it for 40 odd minutes and this didnt change. I then checked again before bed and nothing so I pulled the power lead out of the back, waited a couple of seconds and then plugged it back in. I watched it for a few minutes but I still got nothing, no logos, no backgrounds, no messages and no GUI. I then went to bed.

I checked it this morning and the GUI had loaded and was showing the debug logging text overlay. I have uploaded the logs here: https://paste.osmc.tv/nubunegeya

I havent tried reinstalling the system yet. I hope the debug logs give you some insight as to whats going on. Thanks Sam


#23

Try enabling Lock HPD
Your log shows HDMI plug-outs


#24

Evening Sam. Sorry for the late reply; its been the first night I could try your suggestion. I locked HPD via the Kodi settings and rebooted the Vero 4k. Basically no difference as far as I can see. The TV is a new 4k Toshiba LED if that helps in any way? I have noticed that although I get only a black screen when the Vero 4k reboots I do get a message from the Toshiba after a few seconds notifying me that that CEC is now working and the TV remote will control the Vero 4k via the HDMI. This would look to mean that the Vero 4k has rebooted, albeit I have no GUI for a LONG time. Any further thoughts or shall I try the re-installation? Thanks