FATAL: Module sg not found in directory

On Vero4k I cant seem to enable the SCSI Generic module:

sudo modprobe sg

FATAL: Module sg not found in directory /lib/modules/4.9.113-64-osmc

This is required to use makemkvcon for Bluray Decryption as it only appears to now work with a /dev/sgX (scsi generic) interface and will not work with only /dev/sr0

But as far as I can tell if OSMC is not compiled with SG enabled I can’t just add it back manually?

Anyone know about enabling the Scsi Generic module in Vero/OSMC?

Hi @henryjfry

Since we entered the Bullseye testing period I’ve made a number of kernel configuration changes. I’m currently travelling so can’t check changes trivially for a few days, but I’d advise you check out the testing thread and upgrade. If the needed module is still missing, I’m happy to get it included, and would appreciate your testing before it gets out to general release.




Thanks for getting back to me, I’ll check out the testing version when I get a chance.

Hopefully its already there, if not I don’t think it a massive change with respect to the kernel, I think it just needs something like

# CONFIG_CHR_DEV_SG is not set

Saw some info here about kernel/scsi stuff:


Ok so I just tried updating to the test brach and when I run:

sudo modprobe sg

FATAL: Module sg not found in directory /lib/modules/4.9.269-2-osmc

So no change on the June test branch from “bullseye-devel”

I’ll look at adding support for this shortly and let you know when I have an update.


Ok cheers man, I’ll be happy to test it when you get a chance to add it in.

But it’s not something I’m desperate to see implemented, if a Blu-ray doesn’t work I’ll just use an actual Blu-ray player.

But it would be nice if I could just use kodi. I’m sure eventually it will properly be able to play blurays (like Kodi v69 on the Vero 8k++ holo cube or whatever).
But till then it would be nice to know that I can watch my movies within kodi.

We don’t plan to distribute any encryption keys out of the box for the forseeable future – so there will always be an element of a manual step.

Well yes but without having to compile stuff.

I’ve made this available now with the following change. This should be received as an update to the Debian Bullseye testing thread.



Ok cheers, it’ll probably be tomorrow before I’m able to give it a go but I’ll let you know if it works and works with makemkv.

1 Like

Ok so I can confirm that the SG module has been enabled and can be started:

sudo modprobe sg

And I have also tested makemkv and it also appears to now work if you follow the instructions:


Thanks for confirming.

Yeah I managed to get some stuff to play on Blu-ray that previously was being reported as encrypted.

Although one of my test discs isn’t working, I may have possibly locked it out on my drive.
Can’t tell if its using libre drive or direct access. Libre drive is apparently immune from aacs lockout so I suspect not.

Which is a shame as apparently it’s needed for UHD discs.

But it seems like UHD support should be theoretically possible on the Vero 4k