Feedback on a Vero 4K I bought this week

Some feedback on the Vero 4K, which I bought last week and installed yesterday:

I used an Amazon Fire TV 1 in the living room connected to my Synology NAS. Everything was running smooth. But there were a couple of things that of course didn’t work.

a) Refresh Rate Changer
b) Proper Passthru
c) Kodi 17.x had some cosmetic issues on the AFTV 1
d) Annoying to start Kodi manually from the Launcher

So I was looking for simple drop in replacement as I didn’t watch to spent too much time setting it up and switch the boxes easily.

Setup was pretty smooth but there was an issue with the identifying my MySQL setup. Also setup addon is quite laggy. Probably because it runs some scripts that wait for results. Not very responsive, but does the job. The circle though for selecting the options is not a good UI choice. But well, it is not like will be often there.

The setup didn’t find the existing tables because naturally they are called MyVideos99 and MyMusic56 by default (note the version suffix). So I added the version number and the setup continued as tables could be located.

Kodi wants the table names without the version suffix, but the setup looks if they actually exist by the exact name. You might want to fix this in a future update.

Naturally Kodi didn’t use the tables. It would look for MyVideos9999 (adding the version number again to the name of the table), As it didn’t find the table it created an empty MyVideos99107 for me. So I just removed the table names from the advancedconfig.xml and restart the device and also dropped the table that was created earlier.

And see and behold Kodi properly found the database and upgraded it. It should have been like this right away.

Minor annoyance, and should be fixed in a future update.

Afterwards ran the update for the system without any hickups. Though for new users it might be a bit confusing when updating the repositories that show as an updates and then reports no update can be found. For new users it would look like not all updates were downloaded and installed. Just a cosmetic thing though.

Well, went on installing my preferred skin, adding the addons I use, going over all configuration options and move some files over (e.g. custom library paths, playlists and so on).

For SSH no UTF8 support was auto installed. Well no biggie again, people who can use the command line should be able to fix that easily anyway.

Strangely the DPMS option showed up, even though to my understanding that is not supported by the Vero. Could be a Kodi thing though, not sure.

I had some stuttering in playback. Found out that the buffering settings were renamed in Kodi 17 and adjusted them. Still had issues and had to switch my 5GHz WLAN channel. The ATV1 never had issues with the “normal” 2.4GHZ WLAN for which I have a stronger signal in the living room. Well, no biggie, just my setup for which I cannot easily run a cable.

I played with setting up an fstab, but there is no real difference in performance on network access at all for me - in fact it stutters way more on the 2.4GHz channel and I get an annoying long shutdown as it tries to unmount the shares (need to find out how to prevent this in case I need to restart the unit). Well general Linux thing. Probably removing the recommended fstab approach I found here on the forums as - for me - it doesn’t bring anything to the table beside one more annoyance.

So everything was working nice. Paring of another BlueTooth and CEC also worked.

But there ARE some issues with CEC. First the Vero never turns off. I know it is an “always on” device. But it should mimmick a standby like the ATV1. That means turning off that way too bright LED and disabling the video output like it would be off. That would go a long way in usability (or switch to the red LED in that case when it is in fake standby). In any case a less bright LED should be used in future hardware revisions. It is really annoyingly bright.

CEC is quite an issue overall when the unit it is always on. For example I setup a screen saver and it forced my TV to switch Kodi instead of staying on the TV. Also when turning on my TV/receiver sometimes the receiver stays the wrong input. Well, I need to play with the setup here a bit and see what can be done about it. The ATV1 with the limited CEC never had these issues. Might need to turn CEC completely off in the end.

Pro on CEC is that the remote of my TV worked out of the box, but disabled the RF remove that came with it until I remove the dongle and re-inserted it. The ATV1 remote also paired - though the process was a bit strange as it only showed up after I left the setup for bluetooth and returned to it again right away (like the right pane was not updated). Also showed it by the BT address and not by name (could be standard with that remote though)

Anyway, I plan to use the RF remove as it feels better in hand with the bigger buttons personally.

The bright LED that cannot be turned off is quite annoying. Also I do not see the reason for making it red when the unit is shutdown. In that case it should be completely off as the device cannot be woken up anyway (red LED would mean standby, but no way you can wake it up beside pulling the plug). That design error should fixed in the next Vero version. Well, I put it behind the TV and put tape over the LED.

One issue remains, sometimes it looks like Kodi ended and there is just a black screen when I return to the TV after it was shutdown. Need to investigate with the logs why and OSMC and didn’t restart automatically by the watchdog.

The later would bring up another CEC issues as even though disabled in Kodi it turns the TV on - but input is not switched to Kodi. Yeah, I probably disable all the CEC stuff. Not worth the hassle.

So all in all I am very very happy. Easy replacement, all features I want work out of the box. Perfect passthru, refresh rate changer, latest Kodi working properly and getting the benefit of ongoing support - that goes a LONG way for ease of use.

Only issues are on the software side:

  • MySQL setup procedure if you have an existing DB setup
  • CEC annoyances (well, probably Kodi to blame here mostly)
  • Setting up additional BT remote was a bit odd
  • No Fake Standby, for which you could leverage the CEC settings.
  • Annoying bright blue LED that is always on

I can highly recommend the unit for those looking for new Kodi box with good support and a high WAF. Would buy it any time again and for future updates or additional boxes I will look directly as OSMC without any doubt.

The minor software issues can for sure be addressed in future updates and probably will.

Does the Vero 4K support true 24p (23.976) properly? Where can it be purchased in Canada?


Thanks for your post and feedback. Some comments:

Do you mean the walkthrough, or My OSMC?

Can you elaborate on this? We usually just ask for the DB name. Our MySQL setup however is a bit experimental (via GUI) and we recommend advancedsettings.xml for those using different table names or multiple versions of Kodi.

Can you elaborate on this? We match the locale of the connecting system; if supported.

The AppleTV doesn’t have standby support; at least not with OSMC.

The AppleTV doesn’t support CEC at all; unless you’re using a USB adapter. Again, can you clarify this?

CEC and the OSMC dongle are not mutually exclusive. They can both be operated in tandem. If you find this isn’t the case; let me know and we’ll look in to what might be causing this issue for you further.

The AppleTV 1 remote is not Bluetooth. It is infrared. You go to My OSMC -> Remotes; select the AppleTV remote and it will work out of the box. Again: can you clarify what makes you think is a Bluetooth remote or even take a photo of it?

Not yet – it’s being worked on.

If you select Shut Down, then the system will halt and Kodi won’t start up again.

As you say – there are a few software snags, and we will certainly iron these out. I appreciate your honest feedback and I’m sure it will guide and reassure many others in to getting themselves a Vero 4K

I’ve just realised you’ve abbreviated AFTV to ATV1 – on the OSMC forum ATV1 often means Apple TV (1st Generation) which is quite an old machine

Yes – it would make a pretty bad device if it didn’t!

We don’t have a Canadian reseller right now; but you can get it in the USA; or you can order from us. We offer free, international shipping.

Sure, can provide some more details:

  1. MySQL Setup

I mean the MySQL setup over the Kodi GUI. Can elaborate a bit more on it.

The tool complained that it couldn’t find the MySQL server as it couldn’t verify my settings.

The reason for this was the name of the table. I use the default names (MyVideos). The tool supplied the same out of the box.

Kodi itself appends the DB version number to the name of the table. But the GUI setup does a check for the exact name as it seems. Therefore when entering the correct name “MyVideos” (which is the default name and was filled out for me) the GUI setup (or the script it fires underneath) checks if the table called “MyVideos” exist. Naturally it can’t find it as Kodi used versioned names per default (e.g. MyVideosXX, where XX is the version number).

Therefore I had to enter MyVideos99 (I had a Kodi 16 database at the time of the setup) to complete the setup that creates the entries in the advancedsettings.xml to continue here. Naturally this is the wrong name.

So Kodi created a new DB called “MyVideos99107” - note how it added the version number of 107 to the provided DB name of “MyVideos99” in advancedsettings.xml created by graphical setup tool.

To solve this you should mimic it the way Kodi does it. Just check for the supported versions, and probably some sanity checks.

But yeah, I understand it is experimental. And it is very nice to have some setup options from inside Kodi for people not comfy with editing the files. I am sure it will grow over time. It is already big plus that you offer such a feature.

As said, was an easy fix to edit the Xml here and I would have usually copied over my current one. But I was keen trying out the GUI setup tool here how it works.

  1. UFT8

I logged in over SSH and noticed that special characters from movie names were not properly displayed. So I had to reconfigure my locales. That’s all. The SSH client I use is MobaTerm. Again not a biggie. But would have been nice if it uses some UTF8 locale as a default if it cannot detect the right one for whatever reasons.

  1. ATV1

I mean AFTV1. Sorry was not aware of the naming conventions used here.

  1. CEC

I will investigate a bit more here how to set stuff up or what problems I might encounter. Probably mostly Kodi related. Also need to test more with the CEC dongle I have as well.

  1. “Fake” Standby.

Oh nice that you are working on implementing such a feature in a future version. Appreciate the ongoing work into OSMC. Reason why I choose to by an OSMC box, so I don’t have to built everything myself.

And yeah, I can recommend the Vero 4K to anyone who wants an easy well maintained box for Kodi. I am very happy with my purchase and as mentioned would buy it again and if I need an additional box or an hardware upgrade in the future I will check OSMC out first before looking anywhere else.

And all the stuff like 23.976 playback, DTS-HD pass through, 1080p streaming from my NAS everything works like it should. I am really happy with it.

Big endorsement. Why did I ever waste time with Android boxes? Silly me…


Kodi keeps the schema version in the table name. Therefor you should have entered MyVideos in stead of MyVideos99 (99 being the schema version for your old Kodi 16.x).
At launch, Kodi will start looking for MyVideosXX DB’s downwards IIRC. So if you are running 17.x and the schema version of is 107 it will look for 107, 106, 105… 100, until it finds your MyVideos99. Not sure if it creates a copy of the DB and upgrades the schema or just upgrades the schema and renames the DB. I think it’s the 1st one as instances that have not been updated yet need to have access to the old DB.
In the end you will have a MyVideos107 DB that will be used by your Kodi 17.x installation. Same goes for the MyMusic DB.

I try and configure the locales when the user connects via SSH if they don’t match the client (connecting machine’s) locales. Unfortunately some clients don’t pass it through (OS X). This is how it’s done:

if [ ! -z $LANG ]
    if grep -q "# $LANG" /etc/locale.gen
        sudo sed -e "s/# $LANG/$LANG/" -i /etc/locale.gen
        sudo /usr/sbin/locale-gen ${LANG}
    export LANG=C
    export LC_ALL=C

Yup, and that is the issue. If using MyVideos the setup tool does not find the database as it checks for “MyVideos” and not “MyVideosXX”. Kodi does it correct, but the OSMC GUI setup tool not when you enter your DB settings over it. As said not a biggie, adjusted my XML manually and all was fine.

I see. Still I would suggest to default to C.UFT8 in that case. But I fully understand why you default to C here.

In any case working as intended and it’s the caused by the machine I connect from.

I’ve been running with MySQL for the last 5 years or so. I didn’t even know OSMC had a GUI to configure it. I’m a CLI guy. GUI’s are for cissies, real men don’t use mice :slight_smile:

There’s a discussion on that here: [How to] Use systemd to mount remote shares