File sharing from pc to rpi3

I had an original rpi that once ran xbmc and then osmc. I shared a folder from my windows 10 pc across my network and the rpi could pick it up and play any of the media I had. I just set up my new rpi3, ran osmc on it. The internet on the rpi3 works great, my folder is shared across my network, my homegroup is active. but when I go to settings–>file manager–>add source–>browse–>add network location from there my folder should be visible from browse or if I add its file path but my folder is nowhere to be found.

If you want to add a source you do it in the respective Media area e.g.
Videos -> Files -> Add videos -> Browse -> Windows network (SMB)

Exactly, and then at the end of that, my shared folder from my pc should be there. But it isn’t, its blank. Nothing at all. I really feel like I am missing something simple here and just overlooking it.

This could be an issue with browsing Windows 10 shares due to security protocol changes.
Either try to manually add the source to sources.xml or alternatively (better performance anyhow) add the source via fstab.

how would I go about adding via fstab?

//<IP of Server>/media /mnt/server_media cifs x-systemd.automount,noauto,iocharset=utf8,user,username=<user on server>,password=<your server password>,uid=osmc,gid=osmc,iocharset=utf8,file_mode=0770,dir_mode=0770 0 0

I’m not sure what I am supposed to do with that code. I’ve never changed anything about the pi via code before.

Because of the difficulties ‘seeing’ smb shares on Windows systems (not just Win10 - I’ve had it with XP, 7,8) I use the route of adding the source path directly like:

smb://IP-of-Win-host/share-name/any-additional-path-bits

which usually finds a valid share to add to the sources.
It is possible to use the hostname instead of the IP address, but you need a proper DNS resolution for that to work - I rely on static addresses, as that is the way I have my local network configured for 'permanent machines.
Derek

Well to be honest not that easy if you haven’t ever done something like this but check this out

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Than use sudo nano /etc/fstab to edit the file. Add the line at the end and leave via Ctrl-x.

Reboot

Be careful you can make OSMC unbootable if you break the fstab file.
Easier might be adding the source to sources.xml as @dandnsmith wrote

1 Like

Sharing from Windoze to linux can be a PITA. More so since Win7. This is not restricted to OSMC so there are lots of forum posts by noobs and experts alike. The most likely thing is the Pi doesn’t associate your server’s name with an IP address so using the IP address in the smb:// address is good advice.

i too, have recently clean built my WIndows 10 machine…I have exact same problem, I went in under smb:// < IP > and everything on my Win10 machine is accessible… APART FROM the ‘shared’ USB Drive smb:// < IP > / < USB Drive Letter > (which is where a majority of my files are).
Everything shared from win10 has full control permissions set including the USB Drive I cant connect to.

Regardless of which way round I attempt to access it on the Pi3, I get the failed connection OSMC window stating ‘Path Invalid’ iirc. Will try the FSTAB trick hopefully at some point this week but dont hold much hope.

Has anyone had or solved this particular issue with USB Drive shares, when HDD drive shares work perfectly well?

Sorry for thread hijacking but didnt see any point in starting yet another thread for an almost identical issue.

The last part here should be the share name assigned by you in Windows. Is it the same as the drive letter?

In my case, yes. Share name is drive letter.

Also OSMC error window says ‘invalid argument’ not path invalid, sorry for that mistake

Debug enabled logs would help

Will pull this tonight.

at the moment, no need for logs… turns out i cant see it on android tablet either, i think my issue is windows/linux and not OSMC/Pi3 related

As OP. I solved my issue as far as seeing my content via sharing. Changed the workgroup name to home group and now it works. Now if i could just remember my password lol.

I had to go a little deeper and manually add a regkey for my issue to be solved.

If you google IRPStackSize it should bring up what you need. Apparently there’s a way to set it to autoscale (which helps older winOS talk to win10) but that’s for another day. For now my setup is working.

Also appears to be quite common. xp and 7 seem to have an update that does it automatically… 8 and 8.1,iirc, came with the relevant registry bits. They omitted it in Win10 for some reason.

Hope this helps someone with similar issues to mine.:slightly_smiling_face: