Film Stops Playing


#1

Watched a film last night which was OK after I rebooted the Vero (the film audio kept breaking up).

Now tonight watching Blade runner 2049 and it got to 5 minutes and then stopped playing. Went from the 4K resolution to 720p HDR.
Stopped the film and resumed and it did the same thing.
Log below
https://paste.osmc.tv/ofilowumik
Now it’s started again and the audio is breaking up again. :frowning:
It’s done this in a few films before


#2

Rebooted again and the audio is fine now. Playing OK at the moment


#3

Nope it’s got the banding problem now, even though HDR auto switching is on.
Going to switch to my PC so I can watch my film


#4

Banding is visible if:

  • HDR autoswitching is not enabled in Settings OR
  • 10-bit output is not enabled

We can help you enable these settings so things work properly for you.

I think I’ll need to set up an FAQ on this as it has been covered in some detail but users are not always setting up their devce correctly. It’s a miscommunication on our part.


#5

Cheers Sam, but HDR auto switching is enabled so I’m confused as to why it’s not working.


#6

Does it only happen with one file, or all? If you have HDR autoswitching turned on, what does your /etc/rc.local look like? If you have the echo “444,10bit”… line it will conflict with the HDR setting.

Also could you share the mediainfo of files that show the problem?

Have you tried playing the file locally connected to rule out network issues? (I see that you are using fstab SMB mounts, that’s good :wink: )


#7

It happened with Dunkirk as well. I’ll have to play around with some other files to check.
I’ll also get the info from the Vero later on.
For info Blader inner played fine in Kodi on my PC. No banding, no sound faults and no stopping


#8

I’m still annoyed that it has problems playing as well, i.e. why did the film stop playing? And why am I experiencing sound drop outs that only seem to be fixed with a reboot?

From the log file it seems to happen around here.

Jul 08 18:41:08 osmc kernel: codec:hevc video changed to 3840 x 2160 23 fps clk->667MHZ
Jul 08 18:42:54 osmc kernel: [0]get NAL_UNIT_EOS, flush output
Jul 08 18:44:02 osmc systemd[1]: Starting Report anonymous OSMC install statistics...
Jul 08 18:44:08 osmc systemd[1]: Started Report anonymous OSMC install statistics.
Jul 08 18:46:26 osmc mediacenter[419]: [codec_close_cntl]video codec close return=0!
Jul 08 18:46:26 osmc kernel: codec:DisableVideoLayer()
Jul 08 18:46:26 osmc kernel: codec:VsyncDisableVideoLayer
Jul 08 18:46:26 osmc kernel: codec:AFBC off now.
Jul 08 18:46:26 osmc kernel: DI: di_receiver_event_fun , is_bypass() 1 trick_mode 0 bypass_all 0
Jul 08 18:46:26 osmc kernel: di_receiver_event_fun: vf_notify_receiver unreg
Jul 08 18:46:26 osmc kernel: DI: di_unreg_process unreg start 1.
Jul 08 18:46:26 osmc kernel: codec:DisableVideoLayer()
Jul 08 18:46:26 osmc kernel: codec:disbled keep video before free keep buffer.
Jul 08 18:46:26 osmc kernel: codec:disbled video for next before free keep buffer!
Jul 08 18:46:26 osmc kernel: codec:DisableVideoLayer()

Can anyone explain why this happened?


#9

It’s not clear from a small log snippet unfortunately

Are you streaming from a NAS or PC?

Sam


#10

Thanks for the reply Sam.

There’s a full log linked in my first post.

I’m streaming from an Ubuntu server. It worked fine streaming to my Windows PC.


#11

Thanks for the logs. They aren’t debug logs so there’s a limited amount of information, but a couple of things:

15:38:50.980 T:3479171840   ERROR: CCurlFile::Open failed with code 0 for http://download.osmc.tv/kodi/addons/krypton/addons.xml.gz.md5
15:38:50.980 T:3479171840   ERROR: Open - failed to open source <http://download.osmc.tv/kodi/addons/krypton/addons.xml.gz.md5>
15:38:50.980 T:3479171840   ERROR: CRepository: failed read 'http://download.osmc.tv/kodi/addons/krypton/addons.xml.gz.md5'

There seems to be a network issue here preventing Kodi from checking for add-on updates via the Kodi repository.

From your log, during playback there seem to be buffer issues, and also:

18:37:33.041 T:4074721872  NOTICE: VideoPlayer: OnLostDisplay received

I’d try / check your HDMI cable. If you have an AVR, try directly to the display temporarily. Supported by:

[173343.665643] vout_serve: vmode set to null
[173343.665673] vout_serve: disable HDMI PHY as soon as possible
[173343.665681] fb: current vmode=2160p24hz, cmd: 0x50000
[173343.665687] tv_vout: tv_set_current_vmode[919]fps_target_mode=59
[173343.665693] tv_vout: mode is 59,sync_duration_den=1,sync_duration_num=60
[173343.665705] tv_vout: 3Invalid video output modes.

I’d enable HPD Lock under Settings -> Display and reboot. It might help.

Sam


#12

Thanks for the advise Sam.
I’ll look at the network/update issues and try swapping the HDMi around and see how it fares.
I’ll also try the HPD lock too.
Much appreciated.


#13

I’m confused by the network issue.
I can SSH into the Vero, the Vero can see my stuff on my server, I have even manually updated a plugin from the System menu (TVDB) but when I look at the System Info - Network status it says Internet: Not connected. Check Network Settings.
What could be causing this?


#14

Who knows… You’ve given us no explanation of what your network environment even looks like.


#15

With HPD lock in still getting audio issues. The buffer doesn’t seem to be an issue as the video is playing fine and the debug info on the player suggests it’s OK with forward at 187Mb 100%

Here’s a debug log while I’m playing the video with audio breaking up
https://paste.osmc.tv/liqemuzoli


#16

Here’s a debug log when the video stops playing. This time with Guardians of the Gauzy Vol 2.
https://paste.osmc.tv/awusuwagey

I’m posting these here so I can look at them later as well on a PC, bit hard to read on my phone


#17

Hi,

INFO: CFileCache::Process - Source read didn't return any data! Hit eof(?)

Does Guardians of the Gauzy Vol 2 playback locally?

If its ubuntu have you consider using nfs rather the cifs, as normally it has better throughput.

It could be thats just a bit much for the FastEthernet port, have you tried with AC wifi or may have consider getting a usb gigabit ethernet adapter.

Thanks Tom.


#18

Thanks for looking at the logs, I’ve not had chance yet.
Yeah and I’ve played it OK on the Vero before too.
I’ve not tried NFS bit it’s been fine before so I’m not sure why it’s started playing up.
My router is only g so WiFi isn’t really an option.
I’d be surprised if the network card isn’t fast enough, it used to be fine, bit more I’m looking at this more it seems to be really struggling to buffer. Lucy is one of the higher but rate films I own and that used to be solid, but now that’s struggling too. I’ll check my server and probably reboot it.

Edit: although my PC which is connected with an equivalent root to the server has no issues playing back the files, although that does have a faster network card


#19

Sorry, missed the reply. All hard wired.
Vero to router, router to switch, switch to Fujitsu server running Ubuntu.
PC with Kodi also hard wired to router


#20

Hi,

I would do an Iperf test between the ubuntu server and the vero4k, this will give you an idea of the available bandwidth between the 2.

Is it the same kit or are you saying it connects to your router via another switch?

Thanks Tom.