Fix distorted splash image

If for some reason your splash image became like this:

there is a way to fix it. ssh to your pi or user winSCP or whatever tool you use to connect to it and edit /boot/config.txt file.
At the bottom add


save file and reboot.
These 2 lines will determine the console’s resolution. You can set them to whatever resolution your monitor/tv can support. For example for a 3.2’’ monitor you can set them to : framebuffer_width=320 framebuffer_height=240.
Anyways, this will fix any broken splash / sad face image problems you might have.

edit: Can someone move this to the HowTo thread…i dont know why it showed up here.

1 Like

Ideally the splash screen should work with any resolution. Can you post your edid (tvservice -d edid.dat) as an attachment?

the tv is currently switched off…does it need to be on for that to work…i cant access it now, noone is at home, but running the command via remote ssh gives:

root@osmc:~# tvservice -d edid.dat
Nothing written!

root@osmc:~# tvservice -s
state 0x12000a [HDMI CEA (4) RGB lim 16:9], 1280x720 @ 60.00Hz, progressive

Yes TV needs to be on for this to work. The file written is usually 256 bytes.

This is not a real fix. Seeing the EDID will help here. Please also confirm you are up to date with the latest splash:

dpkg -l | grep splash-osmc


root@osmc:~# dpkg -l | grep splash-osmc
ii  armv7-splash-osmc     1.2.2     armhf    Splash screen implementation for OSMC using ply-lite

I reinstalled osmc…2 days ago, using September’s img. I’ll try and get the tv on in a sec

tvservice -d still doesnt produce any file.

root@osmc:~# tvservice -m CEA
Group CEA has 2 modes:
  (prefer) mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
           mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive

tried with another hdmi cable and the second hdmi slot on the tv, same thing. even played with the cec option both on the tv and peripheral settings in kodi. it wont make an edid file. maybe my tv doesnt support that.

have you set any modes/groups/hdmi_safe in config.txt?

yes, so sorry, here is my config.txt


i had it like that, because when the tv is off and the pi reboots it messes up the resolution and
a) VNCing to it was sometimes impossible(black screen),
b) Kodi’s GUI was always a few inches off the screen…had to manually fix it every time.

Have you yet tried to

tvservice -d edid.dat

since turning the tv on? We need that file for further debugging.

yup, answer is Nothing written! all the time…should i disable something in my config.txt ?

Comment out the two framebuffer lines, the hdmi_group/mode/drive lines, reboot and try again. If you still get nothing written, then unplug the tv from the wall, turn off pi, restart tv and set to the appropriate input, restart pi and try again. If your TV is providing no edid data, then that is gonna be what the problem is.

Is your HDMI routed through an AVR as well, or just direct to the TV?

AVR is connected on the 2nd port on the tv. The pi2 is connected on the 1st port.
Just tried everything you said and still nothing. Nothing is written.
But I do have the impression that I was getting an edid file from my pi1 under Raspbmc. If I manage to hook it up on the tv again (has custom kernel for a 3.2 inch display) will that edid file still work? (I mean both, for you to see the info you need and me to use it on this pi2…it goes in the /boot folder right?)

Yes, though you’ll need to add hdmi_edid_file=1 as well.

well nothing worked…i cant get the p1 to work with the tv…i would have to reinstall the os on it…and i dont want that right now.
And with the pi2 i cant get the -d option to write anything…even tried:

mount -o remount,rw /boot/
tvservice -d /boot/edid.dat

just in case, but ofc nothing.

I’ll stick with the framebuffer for now since that works.

The 0 length file means we can’t read the edid. This can occur with very cheap hdmi cables that don’t wire up all the pins. Specifically it is the two DDC pins needed. See here.

If you can, try another hdmi cable and/or a different hdmi socket in TV.

I tried with the hdmi cable that my AVR has, and also tried the 2ndary port the AVR is connected atm and still no luck. One of these days i’ll backup my sd img, and reinstall osmc and try again. Maybe because i installed the whole system on a vga monitor using a vga->hdmi converter screwed everything up ? I’ll re-install osmc into the sd and start the installation on the tv directly, then ssh and see what i get.
Both of my hdmi cables are the golden ones, not the silver ones.

Unlikely, I think - most of my installs are done with just that form of connection.

This isn’t a “re-install should fix it” type problem. There is a hardware fault somewhere here that doesn’t involve the Pi.