Force resolution?


#1

Hello to you all!

I’ve replaced my ageing raspberry pi with a Vero 4k. The problem is that I’m using a HDMI matrix to connect the Vero to a monitor and a projector. Both of these have a native resolution of 1920x1080, but the matrix overrides this and reports a maximum resolution of 1280x720 when the attached devices aren’t powered up, and sometimes even when they are.
On the pi, I resorted to forcing the 1080p resolution in config.txt.
Is there a way to do this on the Vero?


Interlaced output to progressive-only display?
#2

Hi

Yes — this is quite easy to do if you are familiar with SSH.

Firstly: do you want 1080p60 or 1080p50?

Sam


#3

If I’m connecting the devices directly, they default to 1080/60, so that is what I’m going to do.


#4

Run the following via SSH:

sudo fw_setenv hdmimode 1080p60hzforce
sudo fw_setenv outputmode 1080p60hzforce
reboot

This is persistent across reinstalls.

Sam


#5

Very interesting. Is there also an undo option?

Thx, Marc


#6

The default values can be restored with:

sudo fw_setenv hdmimode 1080p60hz
sudo fw_setenv outputmode 1080p60hz

This is less aggressive: it assumes 1080p60hz unless EDID says otherwise.

Make sure you always set hdmimode and outputmode to a sane value, or you can prevent your device from booting.

Sam


#7

Hi Sam,

can I use 1080p23.976hzforce then?
Somehow my GUI doesn’t seem to stick to 23.976 and most of my ‘stuff’ to play is that framerate so there is a delay while the display changes.

I assume if I play a file with a different framerate and have the ‘sync to framerate’ option ticked it will still change?

Thanks

-Mat


#8

There is no 23.976 mode. Fractional modesetting is done on the fly.
It’s possible to use a custom EDID. This may be a better option.

You want Adjust Refresh Rate on, but Sync Playback to Display OFF.

Sam


#9

I’m in work so can’t show you it, but when I look at the list of available display rates for my LG OLED B6 TV there is a 23.976 in the list as well as a 24, 25, 30 & doubles of the above. Very strange behaviour then.

I guess that may be why the 23.976 doesn’t stick for long and defaults to 60? I’ll try 24 and see what happens.

You are (of course) right about the Adjust Refresh Rate/Sync Playback settings and that was what I was trying to say by using my poor memory.

Thanks
-Mat


#10

To be clear, I mean the rates listed in Kodi for the GUI setting.

The connection path is Vero->Denon AVRX3300W Amp->LG B6 TV so I’ve no idea what effect the Amp will have on display rates. It is set to passthrough so shouldn’t have any as far as I’m aware, but thought it was worth a mention since if I check the display rate using the AMP it says 23.976.

Thanks
-Mat


#11

Sorry, I don’t think I’ve been clear.

The amp should permit 23.976Hz without issue.

On Vero 4K, there is no explicit 23.976Hz mode. There is a 24Hz mode, which we set to. If the video is then 23.976hz, there is framerate adjustment on the HDMI PLL. This is done by the kernel and the amount of control over it from userspace is quite minimal.

So in short: if you have Adjust Refresh Rate enabled, and the TV / AVR combination give a good EDID, that’s it.

A list of OSMC Logs now shows the advertised video modes derived from the EDID.

Sam


#12

I think after re-reading your question, I understand what you’re saying.

You’re saying that 23.976Hz does work; but you don’t like the delay in adjusting refresh rate (black screen).

You could change the GUI to 24Hz, but if you play other content, you’ll still see a refresh rate change. The GUI will also be less smooth, although you may not notice this.

Sam


#13

I was purely talking about displaying the gui at a certain fps. I play mainly 23.976fps content so set my gui to the same framerate to stop a change of refresh rate. This doesn’t seem to always stick and sometimes I find the gui is set to 60fps again.

If I use your

sudo fw_setenv hdmimode 1080pXXXhzforce
sudo fw_setenv outputmode 1080pXXXhzforce
reboot

commands then my assumption was that the gui would stay at the assigned XXXhz rate properly but playing media with a different YYYhz rate would still play at YYYhz.

I hope this is correct and I’ll try it tonight.

As to the 24 vs 23.976, as long as the GUI doesn’t have to change mode to paly my 23.976 media then I’m happy

Thanks for your help

-Mat


#14

Probably happens if Vero 4K is powered before TV and AVR are on etc.

That is correct. You can change it to 1080p24hzforce

Sam