Forcing Vero 4K to 10bit has an unfortunate side-effect...?

So with my Vero 4K connected directly to my LG OLED65C7P, and the Vero 4K forced to 10bit - I’m seeing an issue that SDR material is still running in BT2020.

Here’s a comparison between non-Vero 4K output color and the Vero 4K output color on Atonement Blu-ray, 1080p SDR.

The colors etc are over-saturated on the Vero 4K, because it’s outputting the wrong color space. I did a search but couldn’t find anything specific related to this issue. I picked up the Vero 4K because it was supposed to match color space correctly for the source. Is this not the case?

Cheers. (PS Ignore the source name and dark bar at bottom - I was just testing where my Apple TV was plugged in).

Vero 4K set to 10bit:

XPlay (i.e. what the Vero 4K SHOULD look like):

That’s why we are working on automatic switching, which switches only when necessary.
You can enable it currently, but it’s not yet 100% accurate.

Sam

Sam - where does one enable it? Cheers.

Settings -> Display -> HDR autoswitch

You’re so slow at replying - that was almost 15 seconds after I posted. :smiley:

Thank you, good sir. I’ll test this. What is the issue that makes it not yet 100% accurate?

I’m forcing 10bit 4:4:4, but SDR is not running in BT2020. I also use 2017-model of LG OLED.

That’s odd. I’m definitely running in BT2020. And setting that HDR Autoswitch had no effect for me. What am I missing?

Did you remove the setting in rc.local first and reboot?
It’s not 100% accurate yet because it sometimes switches too late. It was introduced at the start of May as a test, but now we’ve got some feedback I know how to refine it.

When I tried the auto HDR rec709 sdr 4K was still coming through as BT2020

Did you have 10-bit forced via rc.local? That will cause this. The end game is to not need to tinker any files (not very appealing) and to handle it all via Kodi.

Actually yes you’re right I did have it forced.

I still have it enabled in rc.local for 10bit, or I don’t get 10bit, right?

On my JVC DLA-RS540 projector, it reports 8bit unless I force it in rc.local. HDR Auto-switching didn’t work before I modified the rc.local for 10bit.

I don’t know what the LG is outputting without modifying the rc.local since it doesn’t tell me.

If I set the Vero to output 1080p by default (with refresh switching), that’s a good workaround it seems. It will play my 1080 Blu-rays in REC709, and then switch to BT2020 on playback of 4K movies. Unless someone has a better solution…?

I’m intrigued how you’ve got that to work. What do you have your default resolution set to in System Settings on the Vero?

You should not force it to 10bit 4:4:4 when using the auto HDR setting. This will not work, if auto is not working for you - then there is another problem.

Default resolution of Vero 4K = 1080p
It outputs UHD (read: 4K) when playing of these. If I send HDR it plays it in BT2020 (don’t think I have any content with 1080p HDR). But for all my blu-ray and uhd blu-ray files; this works perfect. I’m not using the auto HDR, since it still is not perfect in the implementation.

Correct. Auto is not working for me for 10bit on my Denon AVR-4300H -> JVC DLA-RA540 projector.

I have no way to know if it’s working on my 2017 LG OLED because the LG does not report its bit depth. How do you know yours is running in 10bit color?

Sam, if it is working correctly on the 2017 LG OLEDs with that Auto toggle switched on, how do we know?

Second, is it possible to get the toggle to work on my receiver/projector setup?

It ‘looks’ normal.

You could check the attr file via command line but usually it is quite visually obvious.

Hopefully this is all resolved in the next update.

Sam

I check the content passed through my Marantz AV8802a (HDMI video-info), and I can see it on screen, 8bit BT2020 on HDR does not look very good (banding etc).

Edit:
I think you have the same option on Denon; open menu and look at general=>information=>video.

Yeah it’s not obvious to me at all. Heck, I get much better results on my projector than I do on the LG OLED in terms of banding.

My banding torture test is The Revenant UHD - 1 minute 50 seconds. On the LG OLED the banding is insane in the top left of the screen as it fades to black. On my JVC RS540 there is zero banding. Both played from the same Vero 4K.

I’m still not clear as to how I’m to proceed. If I leave the 10bit info in the rc.local, and run the Vero at 3840x2160 res, the SDR material is played back incorrectly with BT2020 color space both on the OLED and JVC projector.

If I disable that rc.local info and enable the Auto setting, I don’t get 10bit color (at least on my projector - can’t speak for the LG OLED).

So… yeah. Bit of a loss.

Try a couple of times, and it will probably work.
That’s what I’m fixing…

Not sure what you mean by a couple of times, lol.

I played a bunch of movies and the JVC only ever reported 8bit until I modified the rc.local.

I’m happy to test out betas etc to help make this work 100%.