Format ext HDD


Not sure where to begin with formatting my NTFS HDD to ext4. Could someone please provide instructions?

Thanks and happy new year

First find out the device name of your harddisk. Quick version is run fdisk -l that gives you a list of your harddisks and their partitions. Most likely it is /dev/sda1 you then can format it (you will loose all data) with mkfs.ext4 -L NICE-LABEL /dev/sda1

1 Like

@pinn73 Let us know if you still need help regarding this.

1 Like

Just got round to trying this. Problem is I have 2 drives which are identical so when I run: fdisk -l , I am unsure which of the two I need to format.

Any ideas? Ta

Unless you want to format both I would disconnect the one you don’t want to format

Got it with df command - shows drive label. ta

I get /dev/sdb1 is mounted; will not make a filesystem here! after I say yes to format
How can I unmount?

Okay. umount command! SOrted.


After format went okay I started copying files to it. A few files failed to copy but I thought no biggie. Resumed copying files this am and no files would copy. Rebooted the system and now the newly formatted HDD has disappeared completely. Have physically removed and reinserted it but it’s still missing.

upload logs grab-logs -J -K

Here we go:-


Ok, quite a few entries.
Which is the partition you have issues with?
/dev/sda1 (Read-Write, label "New Volume") looks ok, while EXT4-fs (sdb1): error loading journal seems to have failed.
Can you umount the partition and run fsck.ext4 on it


Its the ext4 one. I was poking around behind my TV and actually noticed the hub wasn’t plugged into the power. Just going to find the wire and see what effect that has.

Right. ANother issue. I found what I thought was the power supply for hub but it wasn’t and produced a burning smell. Have swapped it out for another (powered) hub and while one drive is recognised (the ntfs) it doesn’t mount. The ext4 drive is neither recognised by the hub nor mounted.

Just unplugged everything and the NTFS drive is fine now but the ext4 drive is still not seen by the system when I type ‘df’

Is it shown with fdisk -l? Did you run fschk.ext4 against it?

Yes, sorry - seen now.
How should I input the command to run it against that drive, please?

Confirm partition nmame with fdisk -l and run eg. fschk.etx4 /dev/sdb1 you might have to force repair fschk.ext4 --help will tell you how.

fsck, as fschk seems not to run?

That has worked:-

osmc@HTPC:~$ fsck.ext4 /dev/sdb1
e2fsck 1.43.4 (31-Jan-2017)
disk2: recovering journal
Journal checksum error found in disk2
disk2 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong (614896726, counted=614903484).
Fix? yes
Free inodes count wrong (183148001, counted=183148016).
Fix? yes

disk2: ***** FILE SYSTEM WAS MODIFIED *****
disk2: 528/183148544 files (0.8% non-contiguous), 117659972/732563456 blocks

Any idea how it has corrupted so easily after being formatted a day ago? I thought this is a native file system so thought it would be a bit more robust!

Well based on what you have written you might have lost power while you copy data on it. Surely that would corrupt a Filesystem

1 Like

Possibly so. Had been running as NTFS trouble free for some weeks. Let’s see how it goes now.

Thanks for all your help.