Freeze while playing video over 10gb

On my RPI3B+ with osmc, when i try to play large video file (10-15gb), image freeze every 30 seconds.
How can i solve this issue ?
RPI and NAS are connected on giga network (wired)

Here is my kodi.log

I try different parameters in advancedsettings.xml but still the same issue, my last parameter were


I touched up your post to correctly show the advancedsettings.

You only linked kodi logs. We need to see complete debug logs. And we need to know more about your setup. Where are the files hosted?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

I would assume you are impacted by the current flow control issues of the Pi3B+. The next update may bring some fix on that. In the meantime limit the port to 100Mbit might help.

I had a similar problem (although when mine would freeze it would lock the entire RPi3). I finally removed all the cache settings and everything is fine. The flow control on the RPi3 with full bandwidth is definitely still a work in progress, and while I do get some buffering when I start something (or fast forward/rewind), at least my RPi3 doesn’t hang anymore.

Thanks for those quick reply

@bmillham here is my full log

The files are hosted on my readynas

@fzinken how can i limit port in osmc ?


I’m seeing this line in both logs:

No settings file to load (special://masterprofile/advancedsettings.xml

Kodi doesn’t appear to able to see your advancedsettings,xml, so where have you placed this file? Should be:


If it is in that folder, then kodi doesn’t appear to able to read; so could you please issue the following command (and post the link here:

cat /home/osmc/.kodi/userdata/advancedsettings.xml | paste-log

So we can check it.

Setting the network speed using ethtool:

sudo apt-get update
sudo apt-get install ethtool
sudo ethtool -s eth0 speed 100 duplex full autoneg on

Please see if that makes any difference?

Thanks Tom.

advancedsettings was rename during log so this error is normal
Let me modify my network configuration with ethtool to see

Edit : same issue, here is the new log

It looks like you are using Kodi SMB mounts. I’d suggest that you use fstab instead. Also, if your NAS can handle NFS use that instead of SMB as it will perform better.

I noticed that you tried to mount it in fstab as, but when you are mounting via Kodi you are using smb://BIGNAS/NAS/Vidéos/

The fstab entry probably should be (assuming that that’s the IP of BIGNAS)

Ok let’s try fstab instead of SMB
So i change my folders into /mnt/NAS (cifs //, i need to scrap again all my library before more test but issue seems to be here also in this mode

I strongly suggest setting the Ethernet speed to 100 M like @Tom_Doyle suggested. See also Watching recordings crash after upgrade from 3 B to 3 B+ - #6 by Shieldie

not enough time today to test
Tomorrow if the issue still here, i’m going back to my pi3B (vs 3B+ actually) to see if there’s a difference

Last try today
With RPI3B+ same issue
With RPI3B same issue
OSMC work with 90% of my videos but I think there’s a bitrate limit with PI, I hope next osmc update support 1gb lan connexion

Have you tried to play them from USB?

No but I guess it works without any problem

Well I can not imagine any file that wouldn’t fit through 100MBit and still be playable on a Pi3

I confirm, my video play without freeze when i play from usb key (on rpi3B and 3B+)

Interesting, would be good to see the Mediainfo of that file.

Format version : Version 4 / Version 2
File size : 14.9 GiB
Duration : 2 h 14 min
Overall bit rate : 15.8 Mb/s
Encoded date : UTC 2018-05-27 12:20:49
Writing application : mkvmerge v23.0.0 (‘The Bride Said No’) 64-bit
Writing library : libebml v1.3.6 + libmatroska v1.4.9

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings : CABAC / 3 Ref Frames
Format settings, CABAC : Yes
Format settings, RefFrames : 3 frames
Format settings, GOP : M=3, N=24
Duration : 2 h 14 min
Bit rate : 15.5 Mb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.312
Stream size : 14.5 GiB (97%)
Writing library : x264 core 148
Encoding settings : cabac=1 / ref=3 / deblock=1:-1:-1 / analyse=0x3:0 / me=hex / subme=5 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=0 / threads=24 / lookahead_threads=6 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=2 / b_pyramid=0 / b_adapt=1 / b_bias=0 / direct=1 / weightb=0 / open_gop=0 / weightp=0 / keyint=24 / keyint_min=2 / scenecut=40 / intra_refresh=0 / rc=abr / mbtree=0 / bitrate=15500 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
Default : Yes
Forced : No
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709

ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Codec ID : A_AC3
Duration : 2 h 14 min
Bit rate mode : Constant
Bit rate : 448 kb/s
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 431 MiB (3%)
Title : AC3
Language : French
Service kind : Complete Main
Default : No
Forced : No

Text #1
ID : 3
Format : ASS
Codec ID/Info : Advanced Sub Station Alpha
Duration : 2 h 12 min
Bit rate : 7 b/s
Count of elements : 194
Compression mode : Lossless
Stream size : 7.39 KiB (0%)
Title : Forced
Language : French
Default : Yes
Forced : No

Text #2
ID : 4
Format : ASS
Codec ID/Info : Advanced Sub Station Alpha
Duration : 2 h 14 min
Bit rate : 151 b/s
Count of elements : 2946
Compression mode : Lossless
Stream size : 149 KiB (0%)
Language : French
Default : No
Forced : No

00:00:00.000 : en:(01)00:00:00:000
00:06:56.290 : en:(02)00:06:56:290
00:12:02.805 : en:(03)00:12:02:805
00:19:12.359 : en:(04)00:19:12:359
00:28:32.961 : en:(05)00:28:32:961
00:33:11.698 : en:(06)00:33:11:698
00:40:57.496 : en:(07)00:40:57:496
00:48:34.036 : en:(08)00:48:34:036
00:53:46.097 : en:(09)00:53:46:097
01:01:57.338 : en:(10)01:01:57:338
01:08:33.025 : en:(11)01:08:33:025
01:16:46.768 : en:(12)01:16:46:768
01:22:24.022 : en:(13)01:22:24:022
01:31:21.434 : en:(14)01:31:21:434
01:41:15.360 : en:(15)01:41:15:360
01:50:56.483 : en:(16)01:50:56:483
01:59:16.941 : en:(17)01:59:16:941
02:02:43.647 : en:(18)02:02:43:647
02:14:32.898 : en:(19)02:14:32:898

There shouldn’t be any reason that this would not play over the network with either a Pi3 or a Pi3 B+ limited to 100Mbit.
So my guess is there must be a different issue pop up with network or NAS.