Freezes completely... after 3 days [SOLVED]

I’ve installed OSMC (OSMC_TGT_rbp1_20150412) on my Rpi 1 B+ three times now.
Installation and setup is fine. I have a fairy large library, so I set the type for the different folders and then scan.
When the scan has completed (between 2-3 days later) OSMC works for a few hours before freezing completely. The screen wont even turn on, and ssh times out.
After pulling the plug on it I am greeted with a kernel panic on startup.
I had the power warning the first two times, but I swapped to a proper PSU the latest time. Still the same result (although no power warning).

Am I the only one with this problem?

Three days to scan the library in is ludicrous, you definitely have something wrong there. Without some more information we can only guess what the problem might be.

Is this an SD card install, USB or NFS ?

How big is “a fairly large library” exactly ? Numbers please…

Where are the media files stored and if they are across a network how is the Pi connecting to them ?

I don’t suppose you got a screen shot of the kernel panic ?

Have you tried a different SD card ?

What overclock setting are you using and have you tried reducing it to Normal ?

Unplugging the power while running whilst not recommended should not cause corruption to the point where the system fails to boot with a kernel panic - ext4 is a journalled filesystem and is fairly resistant to being corrupted.

I’ve pulled the power out on my test Pi’s loads of times during OSMC development and have not once had a problem from doing this let alone ending up with an unbootable system, so I would tend to suspect an underlying hardware cause for this, like SD card.

Half of the library is over USB, the other on a server over DAV, the pi is connected with ethernet.
The library contains 700 films and 4000 episodes.

I set it to the fist OC preset (Medium?) this time to see if it scanned faster.

I haven’t tried a different card yet. I’m currently using a 16gig hc card. The alternative I have is a 2gig card (is that large enough?).

Here is my error message:

EDIT:
Testing with the 2gig card now

The 2gig sd is mutch faster, something must be wrong with my 16gig one.
Ah well thank you anyways! :smile:

And if that doesn’t help

Thank you for the tips :slight_smile:
I’m running OSX, but I’ve followed your instructions in my dualboot. However the 2g stick is running happily atm so I’ll wait and see what happens before I test. If it works I’ll dd the osmc installation onto my large stick.

1 Like

2GB may be a bit marginal, you’ll probably run out of space once you have lots of thumbnails and artwork cached etc…Get yourself one of these:

http://swag.raspberrypi.org/products/noobs-8gb-sd-card

The official 8GB Raspberry Pi Noobs card. Very cheap but also very fast, one of the fastest SD cards around for random 4KB read/write performance, which is what matters the most for OSMC/Kodi performance, especially library scanning.

I have a bunch of these for all my testing/dev work and they are great. My second choice would be Samsung, they are also very good although not quite as fast as the Noobs card and more expensive. (But the noobs card only comes in 8GB so for larger sizes I’d use Samsung)

BTW if you dd your installation from the 2GB SD to a larger one you would have to expand the filesystem to make use of the extra space. Our installer does this automatically but I’m not sure what the procedure would be to expand an existing install.

cc @sam_nazarko