Freezes with Titan Bingie skin

#1

I have random freezes with Titan bingie skin, SSH don’t work either.

This is latest logs:
https://paste.osmc.tv/upirucanon
https://paste.osmc.tv/omitobimuv

Thanks

0 Likes

#2

Debug logs may help.
If you change skin, do the freezes go away?

0 Likes

#3

If use osmc skin it stops but I can’t use any other skins without freezing. I tried Aura, Embuary and Titan Bingle, I tried installing from scratch on both krypton and Leia but no luck.

0 Likes

#4

Do you know how to use SSH?
Would be interesting to know if you can still access the device when it appears to be frozen

Sam

0 Likes

#5

When it happens I can’t access it from SSH. Only way is to unplug power. Then it works for a while as soon I try to go to settings or browsing it happens but if I leave it in home screen it works.

0 Likes

#6

I tried to monitor cpu and memory but it looks like it all normal. OSMC skin dont use helper services I think they causing the freezing.

0 Likes

#7

Did this happen before you upgraded to a nightly build?

0 Likes

#8

Yes

0 Likes

#9

Can you upload a full set of logs with debugging on next time it happens?
Is it easy to reproduce?

Sam

0 Likes

#10

Can you please explain how to do that

0 Likes

#11

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

0 Likes

#12

It happened again
https://paste.osmc.tv/enacomoyaj

0 Likes

#13

Happened again :pensive:
https://paste.osmc.tv/ucuforonug

0 Likes

#14

I will check your log tomorrow

Sam

0 Likes

#15

Thank you for everything.

0 Likes

#16

I did some testing and I think the issue is with script.helper.service from Titan Bingie Repository if I disable it it works fast.

0 Likes

#17

Sorry for not getting a chance to look at this until now. Busy day.

If you can keep this add-on disabled, I’d recommend doing so

Cheers

Sam

0 Likes

#18

But if It’s disabled most of features are not working it’s part of skin.

0 Likes

#19

It all all good no rush, thanks😊

0 Likes

#20

I think there are a number of skins which have similar issues. I’ve noticed a similar problem with Aeon Nox Silvo when attempting to play music, which causes kswapd to go bonkers. After playing the 1st song, the memory is swapping like crazy, and subsequent attempts to fetch the rest of the playlist from nfs fail, and shortly after, the vero is barely responsive. if I’m very very patient, I can ssh in and kill -9 kodi.bin, which eventually kills it, freeing everything up (it restarts and things are back to normal). Lighter skins such as Mimic (or, now lyrebird which is replacing it) don’t have that problem. I haven’t investigated enough to pinpoint the offending plugin(s).

I’m not sure if it is truly a plugin problem, or an issue with the vero not dealing gracefully with running low on memory. Some people on the kodi forums were saying they had those problem when running on windows though, so it may just be an issue with those plugin(s) not working well with Leia.

0 Likes