Fresh install of alpha 4 on raspberry pi 2 kernal panic after every reboot


Got my first Raspberry Pi yesterday, version 2 model b. The install of osmc went smooth, and the wifi dongle (tp-link) worked like a charm.

After I mounted a external hdd from a external powered usb hub and rebooted I started getting kernal panic. It did not matter if I pulled the plug to restart, still the kernal panic. So I reinstalled it again, and the same thing happened. Works like a charm until I mount the external hdd.

Then I tried xbian and open lec and the same think happened there to. After mount of external hdd the os would not start.

Then I crossed this post, Missing device node for CPU - #6 by keith217 and did a fresh install again of osmc, and before trying to mount anything I ran the following.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

After the update and upgrades where complete and the os was rebooted everything seems to work. I can mount the external hdd without any problem and I can pull out the power plug and the os still starts.

Has anyone else experienced this?

A lot has been changed since Alpha 4 so doing a dist-upgrade will have included many more recent fixes.

By the way, the sudo apt-get upgrade line was not necessary - dist-upgrade includes everything upgrade does. (And more)

Also you can achieve the same result using the OSMC settings addon Update option. (It basically does an update then dist-upgrade)

Without seeing a screen shot of the kernel panic we can only speculate on the exact cause of the problem you were seeing however.

aha ok, thanks for that! :slight_smile:

I am very aware of that, I will be sure to fix a screenshot or error dump next time. Last night I just wanted the damn thing to work :wink:

I thought posting this would be a good idea if somebody else had the same problem, and updating it before mounting anything else at all seems to fix the problem for me.

@DBMandrake see Kernal panic after reboot, fresh install and after update it happened again.