Frustrations with vero 4k

Im getting frustrated :frowning:
As in the other thread i got problems with subtitles, but thats a kodi issue… So im stuck there as they dont seem to fix it
However, i downloaded (using other kodi machine)for 2 movies srt subtiltes and placed them wit the file.
They played fine.
I powered up the vero and tried to play both movies and both movies now dont even start up, i get the bad smiley… :frowning: it played before with vero…
And it plays fine with other mediacenter’

Thats not all.
I tried 7 movies that are 3d iso files… I know it doesnt do 3d but those files should play in 2d right? Like kodi does…
Absolutely no problem doing that with zidoo, windows kodi, rasp pi, but with vero 4k all those movies stutter like hell!

Very frustrated in this device!

I think nobody can help you without any information about your environment (network, wifi, nas, etc…) and logs…

Subtitles will work on Vero 4K
3D video will be played as 3D if it’s SBS or TB. MVC content will be played as 2D currently, but this is set to change in the next update.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

What do you mean with subtitles will work? Anything changed at kodi side?

For the problem with the movie that doesnt start anymore getting the bad emoticon check

I tried to play those 3d iso mvc movies too but strangely enough they play good now, very strange

Your logs show that you attempt to play back more than one file.

Which file fails, and can you produce a log showing this failure?
Have you tried playing it back from local storage?


More than one file? Lol it only has one file plus the subtitle srt file i downloaded.
It played it perfectly before i downloaded the srt file.
Is that the problem?
I dont need to test it local, cause other players play it fine over my network

What did you mean with subtitles will work?

If you don’t wish to try it from local storage and produce a debug log showing failed playback, then reinstalling is probably the best solution for you.

Again frustrations.

Tried nemo which is 3d iso mvc file, played in 2d…
It freezes for seconds and continues… Dunno whats wrong, dont have this with other players

Then tried the 4k movie again… I deleted the srt file.
Now it starts the file to play but freezes

Hate it

Tried again after reboot vero, black hawk down plays now good after deleting the added srt…
Mad max started good but then freeze again… Second try again freeze

Again mad max plays good with any other player

3D MVC hasn’t been merged in yet, but will be soon.
So you can expect 2D for those files currently.

Did you get a chance to try local playback yet? It looks like buffering may be causing issues here.

Its a 3d file played as 2d, it shouldnt give problems but it does.
As i said, plays fine with 5 other players why not vero?

Can you look into the provided logs pls.

Also why does mad max freeze? Again only with vero…

You said subtitles will be fine, but you dont answer my question about that.

Thx for the help

Have you tried playing the file back locally?

You are playing back 4K content using a Kodi SMB mount. This is not likely to perform well.

I haven’t been able to reproduce freezes with SRT files here. My first suggestion would be to resolve the playback issues.

What is the problem you are experiencing? For now, if you play 3D MVC content, it will be output as 2D. This is expected.

There were also some improvements to fix playback of 4K content for very high bitrate clips. You may find that the staging repository has improvements for some content; but you still shouldn’t be using the built in SMB mount if you are watching high bitrate content.

I have 0 issues with smb , not even for 4k!
Not with any other player except with vero 4k
So im sure it s really not a problem cause i use smb

The problem with the 3d movie is almost the same as the 4k one…
When i play the 3d movie in 2d with vero… It freezes for couple of seconds…
Thats not an smb issue either since it playes perfectly over smb on windows kodi, on zidoo kodi and on raspberry pi3
Then why does this give me issues with vero 4k?

I know 3d is expected to play as 2d, thats not the question’…

It’s been suggested several times to at least try playing the file locally.

The Raspberry Pi 3 cannot play 4K content, so I suspect you are not taxing Kodi’s SMB capabilities as much on that device.

Your log shows throughput issues.
To rule out a configuration issue you could install fresh from Download - OSMC.


Don t take it personal but i dont see any point in trying to play locally if its no problem with zny other device.
If you can tell why and let me see any point in it, ill copy over the movie from the server to usb disk but again, 0 issues with all other devices…
I truly dont see any point in it, cause if it will play, you will tell its the network or smb setup… But like i said, thats not the issue

About the raspberry pi , i was indeed not talking about 4k but the 3d movie

Ill try fresh install like you mention with the link, thats a small possibility…

Because that’s easier than copying and playing from a USB drive? lol


The only 4K device I have experience with is the Vero 4K, which overall I am very pleased with. For what it’s worth I have found the following over my wired network from a Synology server:

Kodi-mounted SMB is pretty hopeless with 4K mkv chapter skips, buffer recovery does not cope
Kodi-mounted NFS is generally ok but can sometimes get caught out by a chapter skip
fstab-mounted NFS is excellent but breaks network-based remote control (e.g. via an iPad), only an issue if you need that type of remote and it might be fixable with dual wired/wireless configuration.
I have not tried fstab-mounted SMB.
A cheap USB gigabit adapter provides a throughput of around 3X the built-in ethernet, pretty much all forms of mounting I tried work in this case.

I am not surprised if you are having issues with Kodi-mounted SMB, but that does not necessarily mean it’s the Vero’s fault. I would encourage you to take a breath and give other configurations a chance - I too had some teething troubles on first setting it up, and a few glitches since, but the support here is excellent and I’m glad I stuck with it.


If you’re convinced that the issue is not network related then I’m not sure what can be done unfortunately.

Smooth 4K playback using Kodi’s built in SMB mount is tricky. An fstab based mount would be better. If you are not keen on attempting to play the file locally, then I do understand, but I think we will struggle to assist further.