Frustrations with vero 4k

If you’re convinced that the issue is not network related then I’m not sure what can be done unfortunately.

Smooth 4K playback using Kodi’s built in SMB mount is tricky. An fstab based mount would be better. If you are not keen on attempting to play the file locally, then I do understand, but I think we will struggle to assist further.

The irony is that I’m 100% sure his problem is with mounting the drive using kodi instead of fstab. I saw and experienced that so many times that’s almost a no brainer.

Copying the file over should take a few minutes and is just to rule out 1 aspect. But we can’t force people to troubleshoot…

Did you try NFS-mount via Kodi? It’s much easier to setup on the Kodi side and needs just a little daemon running on windows, linux server and NAS work with integrated NFS.
I have no issues running high bitrate 4K-HDR movies with several HD audiotracks from my windows machine.

No because thats sounds more promising…
With my zidoo i play every 4k movie over smb without any issue, why does vero has problems then? Its the same network? Please answer this one.

But hey, ok, i will copy over the file and play it over usb drive
After that i do a fresh install…
Hopefully things will be fixed then

Sam i appreciate your help, hope we can fix all my stuff/frustrations

Sam,

I tried local playback first.
Tried 3d and the 4k one that gave problems
no problems at all with playback

now what?

Should i try clean install first?

This means you have a network issue as originally suspected.

Using an fstab based mount is probably the best option.

See Configuring fstab based Samba share mounts. This should cover everything in detail.

3 Likes

ok will try
so i dont need to change anything at (unraid) server side
nor do i need to change at emby side? (i use emby as frontend for kodi to populate movies data base’)

First problem i encounter is when i use puty it says “network error connection refused” lol

Are you using the correct IP address?

yes lol

Did you enabled SSH when you originally installed the device?

not sure
i bought the device from someone else
i can see it also in my windows explorer and can browse it however i dont see a map /etc/fstab
if i browse to that ip adress its not reachable
strange

Check under MyOSMC - App Store

If you bought the device from someone else the first thing I would do is reinstall OSMC as you do not know what state they left the device in.

SSH server was stopped
i enabled it
i saw samba server is stopped too
is that the issue? should it be enabled?

Yes ! i can connect now

No, not related to your issue.
But as Sam mentioned start with a clean install

1 Like

im not sure to do this fstab thing
i need to add my shares and stuff, but in my case , kodi doesnt populate the movie db, but emby does

does this have anything to do with it?
cause i dont wanna mess things up

before i try that , i should do fresh install but how
i followed the link and downloaded for windows but now it asks me where to install on sd card on usb… but nothing like on vero 4k lol

how do i do this

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

i cant select “on usb stick” during install
although there is one in

You don’t need to. Just select the USB on the next step.

ok just did a reinstall

guess what
all my problems are gone (i think, have to watch movies to be sure))

However

  • 4k movies dont stutter anymore, even on smb (even with mad max) no need to setup fstab (like i thought)
    -3d movies, no more problems so far (need to check complete movie to be sure)
  • even downloading subtitles now work !!, didnt before

so hopefully , all are gone :stuck_out_tongue:

only thing left but as i mentioned in opening post, this is not something vero can fix, cause its a kodi “bug” but kodi cant move pgs subtitles, so vero cant either

huge mistake that, since zidoo can
But at least now i can download subtitles which are moveable now :slight_smile: (hopefully always in sync)

1 Like