FSTAB CIFS mount not working after kodi update

Hi guys,

I have a Raspberry Pi with osmc kodi on it. For more than one year i am mounting a cifs share from my NAS (shares on a Windows server 2013) to the OSMC. All good.
4 Days ago i updated Kodi and since that update, the cifs share won’t mount any more; not even manually when i issue mount -a.
This is my fstab entry:
//10.2.2.249/MEDIA /mnt/MEDIA cifs rw,file_mode=0777,dir_mode=0777,noperm,credentials=/home/secret.txt,noauto,x-systemd.automount,iocharset=utf8 0 0

Can you give some hints on how to troubleshoot this?
I saw other similar posts where a solution was to add “vers=3” in my fstab entry, but in my case that does not solve it.
Besides the Kodi update, i haven’t made any other changes in my network or NAS.
Logs from grab-logs -A , here: https://paste.osmc.tv/duluxaviti

Thanks.

Hi,

Not heard of this version, 2012 then 2016 I think?

Anyway seeing this in the logs:

Mar 09 20:51:00 raspi systemd[1]: Mounting /mnt/MEDIA...
Mar 09 20:51:00 raspi kernel: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
Mar 09 20:51:00 raspi kernel: CIFS VFS: protocol revalidation - security settings mismatch
Mar 09 20:51:00 raspi kernel: CIFS VFS: cifs_mount failed w/return code = -5
Mar 09 20:51:00 raspi systemd[1]: mnt-MEDIA.mount: Mount process exited, code=exited status=32
Mar 09 20:51:00 raspi systemd[1]: Failed to mount /mnt/MEDIA.
Mar 09 20:51:00 raspi systemd[1]: mnt-MEDIA.mount: Unit entered failed state.

Try vers=3.0

If that does’t work, try vers=2.1 or vers=1

If these work its probably just a case of configuring the server to support smbv3, then you return the flag to vers=3.0

Thanks Tom.

Yes Tom, excuse me; Windows 2012.

I have tried vers 3.0 , 2.1 , 1 but still does not work.
Also, in the Windows server i disabled smbv 1 and specifically enabled vers 2 and 3.

PS C:\Users\Administrator> Get-SmbServerConfiguration | Select EnableSMB1Protocol, EnableSMB2Protocol

                                                                             EnableSMB1Protocol                                                                                  EnableSMB2Protocol
                                                                             ------------------                                                                                  ------------------
                                                                                          False                                                                                                True

Again, no result

Hi,

Which version of 2012, original or the r2 version? If r2 could try vers=3.02.

Thanks Tom.

I have windows 2012 standard version.
C:\Users\Administrator>systeminfo | findstr OS
OS Name: Microsoft Windows Server 2012 Standard
OS Version: 6.2.9200 N/A Build 9200
OS Manufacturer: Microsoft Corporation
OS Configuration: Standalone Server
OS Build Type: Multiprocessor Free
BIOS Version: Phoenix Technologies LTD 6.00, 21/9/2015

C:\Users\Administrator>

SMBV3 is enabled on the server:

PS C:\Users\Administrator> Get-SmbSession | select Dialect

Dialect

1.01
3.00

PS C:\Users\Administrator> Get-SmbServerConfiguration | Select EnableSMB1Protocol, EnableSMB2Protocol

                                                                             EnableSMB1Protocol                                                                                  EnableSMB2Protocol
                                                                             ------------------                                                                                  ------------------
                                                                                          False                                                                                                True

PS C:\Users\Administrator>

As i can see, agreed versions are 1.01 and 3.00

Tried these version and as well the ones suggested by you, in the fstab, but again, no luck

So, version vers=3.0 should be supported.

What is the output on the OSMC device doing

sudo mount -a
sudo mount -v /mnt/MEDIA

1 Like

Got the same Problem on a ZyXel NSA 310 as NAS Server. Have you got a solution. I have workarounds within my configuration by tunneling data via another nearly pure Samba-Server. This is not very satisfying. Thanks. Like to here of somthing better

Hi,

Please provide logs

Thanks Tom.

Extract from fstab

/dev/mmcblk0p1 /boot vfat defaults,noatime,noauto,x-systemd.automount 0 0

rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)#/dev/mmcblk0p2 / ext4 defaults,noatime 0 0

\winbox\getme /mnt/win cifs user,uid=500,rw,suid,username=sushi,password=yummy 0 0

//192.168.188.26/INTENSO /mnt/intenso cifs noauto,x-systemd.automount,user,user…
//192.168.188.26/music /mnt/chunmeemount cifs noauto,x-systemd.automount,user,use…
//192.168.188.26/video/2013-11-03 /mnt/chunmeevideo cifs noauto,x-systemd.auto…
//192.168.188.26/WDEXTERN-NTFS /mnt/wdextern cifs noauto,x-systemd.automount,user,u…
//192.168.188.26/eSATA-NTFS /mnt/esata cifs noauto,x-systemd.automount,user,username
//ubuntuserv/share /mnt/ubuntuserv cifs noauto,x-systemd.automount,user,username
//altesgehaeuse/share /mnt/altesgehaeuse cifs noauto,xsystemd.automount,user,usern…

The IP addressed devices are noted as “No such Device” or similar if I try to get access via mount. At the moment i activated the software without the latest update. So if you need further information it will take some time.

Thanks

Hi,

Please provide logs, either by issuing:

grab-logs -A

Or via my osmc, details can be found here:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.

Hi Tom,
I no longer can access my Time Capsule (smb1) share since last update.
Logs uploaded https://paste.osmc.tv/icugipomez
Thanks,
B.

Hi,

Whats the output of:

sudo mount -a
sudo mount -v /mnt/Data

Also have have tried adding vers flag to fstab mount? either vers=2.1 or vers=3.0

@emblaze sorry just re-read your post, missed smb1; please try adding vers=1.0 to the fstab entry

Thanks Tom.

Hi Tom, logs upload https://paste.osmc.tv/pavujaxuwa.

Thanks Hans.

Don’t remember how one of my gambling nicknames ‘keineachten’ is intruding

to osmc and pi 3 activities. Sorry for that.

Hi,

Can’t see any errors with mounting the shares in the log.

I’m assuming /mnt/intenso is a mount from the ZyXel NSA 310, please advise if this is not the case?

Please provide the output of the following:

sudo mount -a
sudo mount -v /mnt/intenso

Thanks Tom.

Hi

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Sam

1 Like

Happy to report that adding vers=1.0 in the fstab entry solved the issue.
I must have missed a recent change (kernel or smb?) because it was working fine without it/
Thanks anyway Tom.

Hi Emblase,

If you run the update posted by Sam above (post 16), the issue is fixed and should no longer need the vers=1.0 fstab flag.

Thanks Tom.

Hi Sam.
Works like a charm:
Removed vers=1 from fstab, applied your test update.
Back to stable updates channel now.
Thanks for the hard work.
B.

2 Likes

Hi Sam,

I am happy to confirm that the latest update fixed the issue for me too.

I have been mounting a Time Capsule using afp and cifs with the following workaround for a long time. It stopped working after I recently updated osmc. Now I can enjoy OSMC again.

Thank you for the hard work :slight_smile:

1 Like

Thanks for reporting back.