FSTAB mounting problems

I did everything on this (correctly I think) but it wasn’t working so I installed smbclient.
It gives me the error “protocol negotiation failed: NT_STATUS_CONNECTION_RESET”. My server is a Windows 10 OS and I read there are some samba issues with it, could that be the issue?

I moved this to a new topic as the Wiki is not the correct place to debug problems.

Please share your fstab. The error you are getting is normally caused by the wrong version being specified in fstab.

Oh, sorry.

I typed exactly what was specified in the wiki in my fstab (except I used my own IP, username, and password). I tried both the first one and the one that specifies version 1.0 just in case, both gave the same result.

Do I need to be specifying a different samba version? Does my Windows 10 server need to be configured somehow? I just right-clicked on the folders and added them as shared I think, I don’t remember seeing anything about samba.

The folders have been served to my Windows 10 PC running Kodi for a year no problem and I was able to ping the server from the Vero 4K so I don’t think it’s a network issue either.

I’m sure this would have been easier if I had gone with a Linux OS for my server but I’m kind of stuck with Windows 10 for now. :confused:

Please copy your fstab entry here. I need to see it. Or just post logs.

This is my first time using a proper Linux OS so I don’t even know how to get the logs from the Vero 4K to my PC to post them yet, but I copied and pasted the fstab entry from the wiki that I used here:

//192.168.1.2/Movies /mnt/Server_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=my_username,password=my_password,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

The only difference with mine is the IP, username, and password. I didn’t get any errors when I tested it either.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

And for logs please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Did you try the vers=1.0 option in fstab?

Yes I tried the version 1 as well, same thing. For that to work would I also need to change something on the server?

Also this probably isn’t relevant but my password begins with two “=” so the code in the fstab looks like “password===password”, could that be causing an issue? I wasn’t sure if I needed to put a character in between the password = and the other, maybe that is causing an issue?

This is the exact reason why I’ve asked you to share your fstab…

I’m not sure what that would do, so I’d recommend that you change the password (or setup a new user) without the =.

I changed my password but it still does the same thing. Here is the log if it will help. When I grabbed the log I had the fstab code in the “guest”/version 1 version but only because I try both ways every time I make a change in hopes one will work.

https://paste.osmc.tv/arovorudoy

It’s probably something on the Windows side though which I’m not sure the log will show, but this is all very new to me so who knows? :stuck_out_tongue:

Is the share really movies? (FYI linux is case sensitive in path names)

So lets get back to basics. What happens if you try:

smbclient -L 192.168.0.4  -m SMB3 -U <usernamehere>

That will force smbclient to use V3. Also for fun try SMB2 and NT1

When I did the SMB 3 one it listed my shares (progress!) but then it says the connection failed “(Error NT_STATUS_RESOURCE_NAME_NOT_FOUND), NetBIOS over TCP disabled, – no workgroup available”.

As for the name it is actually “MOVIES” on the Windows server, but it says the network path is “\Server\movies” so I dunno which one is right but I assumed the network path one.

EDIT to add: The fstab is still configured for guest/version 1, I dunno if that my be conflicting with the SMB3 force.

Also despite the fact that Windows claimed the path was “\Server\movies” the shares listed from the SMB3 command clearly show it as “MOVIES” so that may be an issue as well.

So change the fstab to use version 3, change it to MOVIES and use a user/password again.

EDIT: I just did a test and it looks like Samba is not case sensitive, so Movies, MOVIES or movies should work.

1 Like

Hey that worked! :slight_smile: Thank you very much! Do I need to do anything else or am I good to start trying to figure out how to add them to Kodi?

Good to hear, and you are good to go. Read the tutorial about adding the share to Kodi.

So my guess is that the original problem may have been to = in the password. I’ll have to test that.

Thank you for all your help! :slight_smile:

I still have problems.

Even after adding the “ver1.0” i still get the “no such device” back after trying to cd into it. If standing in /mnt/ an ls does show the folder, but I cant get into it. I can also add the folder in Kodi from browsing “Root filesystem” but it shows up empty with no files.

Im missing something here but what. The folder is already mounted and added with smb, do I need to first delete that? I did rename the new mount-name as to not confuse them, but can they co-exist?

My password is normal 8char looking almost like this: 3s89OB%y however the shares are shared with “everyone” as the smb guide says so the password used is the same password as to logging in on the server.

My Entry:

//MEDIA-PC/Demos /mnt/Demos cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=MEDIA-PC,password=3s89OB%y,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=1.0 0 0

I tried at first with IP-adress but just recently tried with servername aswell. IP is private class c. Should i try with “everyone” as the username?

“everyone” is not a user name. You would need to use a username that is a configured user on the server.
Also you have not written which Server you are using.

Its not a server OS but is a Windows 7 machine.

I am now using a username that is a configured user. It has a folder under /windows/users and has access to the share via network.

I still can see the folder under /mnt but I cannot cd into it “no such file or directory”.

So now it looks like this:
//192.168.1.9/Demos /mnt/Demos cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=Media,password=3s89OB%y,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=1.0 0 0

I doubt that you need vers=1.0 for WIndows7.

Install smbclient sudo apt-get install smbclient and then run
smbclient -L 192.168.1.9 -U <usernamehere> and let us know what happens

Hang on…im an idiot. It didnt take my password so this got me thinking…I just installed a new Meraki network at home so lol this is no longer the ip for the server.

So I changed the server IP and now I can cd into the folder and browse it with ls.

The command smbclient -L -U Media
gives me alot of stuff but about the share is this:

Domain=[MEDIA-PC] OS=[Windows 7 Enterprise 7601 Service Pack 1] Server=[Windows 7 Enterprise 6.1]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    Bilder av familie Disk
    C$              Disk      Default share
    D$              Disk      Default share
    Demos           Disk

Connection to 192.168.1.10 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available

So is this how it is supposed to look at the fstab mounted “Demos”-folder?