Fstab questions

Very very new here and also very new to putty, so please go gentle.

Ive just managed to mount my Vero 4K using fstab to my Synology NAS.
My NFS Share is called “Diskstation” located on ‘Volume 1’.

I have the following folder structure;
Diskstation\Videos\Adult\TV Shows

Ive created the above so I can use a kids profile and parents profile.
running a showmount -e command I get “/volume1/Diskstation”.

Ive edited my fstab file to read;
“ volume1/Diskstation/ nfs noauto,x-systemd.automount 0 0”

I can now ‘cd / ls’ the above directory and see the two folders Kids / Adult, so assume I have mounted correctly?

My next question is, how should this share present itself within OSMC? Should I simply add a video source, browse my NFS server and map my folder “Diskstation\Videos\Kids” and this would automatically pick it up through the fstab mount Ive just created?

many thanks

think I just found the answer, if im correct you browse root of the Vero, drill down into MNT, then the share?

Hi @Adam1V,

here some thoughts to this:

  1. typically the mount directories of the /etc/fstab should be under /mnt, so I suggest to change fstab line to /mnt/Diskstation nfs defaults,x-systemd.automount,noauto 0 0
    (the kernel creates the directory Diskstation on its own, you do not have to do it manually)

  2. as you already pointed out, in the mediacenter you add sources from that by traversing the root filesystem and follow /mnt/Diskstation and subdirectories

  3. Unfortunately there is some issue with the concept, since using the fstab-method and nfs you cannot prevent your kids to add the adult directories as new sources when logged in with their profile but of cause this depends on the age and technical capabilities

Addition: Have a look at this Media sources - Official Kodi Wiki. So, at least there is theoretic way to protect some sources … but haven’t used it before and don’t know how convenient this is.

Many thanks @JimKnopf

#3 isnt a problem, the kids are aged <8 and are not yet savvy enough to jump outside of their profile, I have something similar on previous popcorn hour media player and its not been an issue so far.

Profiles appears to be a good way to go for me as I can boot into their profile directly and lock down the menus / remove the bits I dont want.

Yes, and you see in the late addition in my post, there are ways to more protect the sources … but that would mean you have to enter a password/pin to access such adult-sources as well. Don’t underestimate the abilities of your children, it’s just a question of time. :grin:

1 Like

Another option is to create two mount points in /etc/fstab        /mnt/Videos   /mnt/Kids

The kids’ profile only sees /mnt/Kids. You see all videos. (I’ve left out the rest of the fstab details for clarity.)

1 Like

Thanks, this makes sense, I’ll give that a go.

Could you confirm what command i’d use to [safely] remove any mounted shares ive created?

sudo umount /mnt/Diskstation (or whatever you’ve called the mount point). NB it’s umount, not unmount. Make sure it’s not being used first.

I appear to have a couple of [old erroneous] mounts still lingering in the following root directories of the player;


I’ve tried the command;
sudo umount /mnt/volume1/Disksation/Videos/Kids but it tells me this directory is not mounted?

It doesn’t show in the screenshot. Anyhow, it’ll be whatever you called in in /etc/fstab, so if you’d originally mounted something to /mnt/Diskstation, that’s what you’d unmount. If it’s mounted, you’ll see it when you run df.

Thats what I thought, but it doesnt appear to want to remove that folder, see below within my mnt folder.


What is the output of sudo df?

Is there a line in your /etc/fstab mounting something to /mnt/volume1 ?

No, Ive only mounted three shares, Videos, Kids and Trailiers;

Sudo df;

Browsing the mnt folder on the device:

And the previous erroneous share I created on root;

Just reboot and any phantom “cruft” should be removed.

nope, Ive rebooted several times since last night and they’re all still there :joy:

To demystify the mistery.
After reboot provide grab-logs -A
Also provide ls -lah | paste-log
For both share the URL

1 Like



You need to run grab-logs -A (with a big A).

Please also run

sudo du -s /volume1
sudo du -s /mnt/volume1

Logs: https://paste.osmc.tv/ukusulemeb



Some observations:

  • Update your add-ons. It looks like your YouTube addon is probably in need of an update.
  • Enable “Wait for network” in My OSMC > Network.
  • Your system journal is being overwhelmed with a repeated block of messages. I’m not sure what it’s about but it’s possibly related to your settings.
  • The /volume1 and /mnt/volume1 directories seem to be part of the local file system, rather than remote shares. I think they’re just a distraction, so leave them for now.

Reboot and run grab-logs -A again.

1 Like