FTP/SSH refused/time out


I am trying to access my OSMC machine via my WIN Laptop. I tried to connect via explorer/filezila and Putty but no joy.

I have both SSH and FTP services running and remote control access through 80 is working fine.

Errors I get are either: Error: Connection timed out after 20 seconds of inactivity
Network error: Connection refused Under normal (passworded)
Connection attempt failed with “ECONNREFUSED - Connection refused by server”. under anon

Any help will be appreciated

Many Thanks,

I have also looked at similar issues on the forum BTW but none is working

Thank you for your help!

If you try, using Putty, and the connection is refused, then you might be trying the wrong IP address, or the wrong username/password, or you might have a local network impediment (firewall, improperly configured router)

Tx Derek,

None of the Above :wink:

The IP is already used by my android remote, no firewall internally and I am using my windows network throughout my house with no issues.

I can remote to anything on my SMB: Phone,tablet, PC, laptop etc. but no OSMC…

What user:pass are you attempting?

The default osmc:osmc low case. Ping is succseful BTW.

Man this forum is great, thx guys.

In filezilla use sftp://ip.of.rasp.pi osmc:osmc port 22.

Yep thats the first thing I did : Errors as on my first post

Are you sure the services are running ? Did you check in My OSMC-> Services ?

Did you double check the IP address of OSMC in My OSMC->Networking ?

Have you installed any software using apt-get that might have altered your networking setup ?

1 Like

Yep thats the 2nd thing I checked :wink:

triple checked IPs.

Services installed via OSMC app store only.

I am using the same IP that my android YATSE app is using to connect.

Obv on a diff port: tried both default ports for SFTP and FTP as long as normal and anon accesses.

I think my RPI has something top secret inside :wink: so it doesnt let me in.

I doubt it, for a first baseline test do a “telnet ‘IP address of OSMC’ 22” and post back the reply

Please use the My OSMC log uploader to upload all logs. Without some logs we’re just guessing really - SSH is enabled by default on a fresh install so if it is not running it can only be due to something you have done, or something on your network is blocking the connection.

Will do Mandrake

Answer to fz: SSH-2.0-OpenSSH_…

Had to reflash my SD due to the kernel panic fs block issue. Not sure why it happened so most likely will happen again…
Anyway this time didnt play with overclocking or anything else, I did not install the FTP server…

Success! SSH and FTP are working.

not sure why I still cant connect via windows explorer with ftp:/osmc:osmc@ip

im going to keep it plain vanila for now(too bad quite liked that metropolis skin) and do a LOTR marathon on it. Im 50/50 on whether or not my RPI will survive :wink:

Tx for your help much appreciated!

Sounds like you had a file system corruption issue possibly due to a faulty SD card, so yes you will probably have problems again.

Not sure what you mean when you say you didn’t install the FTP server and yet you can FTP to the device - that’s not possible.

Are you sure you don’t mean SFTP, which actually connects over the SSH port ?

Correct, I am connecting via SFTP and I guess if I run the FTP server on the RPI it will enable me to connect via win exp…

With regards to the SD: Is it best practice toI place the OSMC img on my ext hd and boot from there? not sure thats possible.

I think that the SD corruption is me again: I plaayed with overclocking and naturally the gui froze so a lot of hard power on and offs… I guess if I try to do it again I can ssh it and reboot

It isn’t - you can only boot from the SD card.

If you did a lot of overclocking experimentation which resulted in many system freezes then yes, that would easily cause file system corruption that would lead to later problems.

So once you settle on a stable overclock setting and do a fresh install you will probably be OK.

mmm. the test was shorter then expected.

OSMC froze for no reason (everything is default and no apt-gets or anything) when I tried to SSH I got Bash-3.4$ instead of osmc@osmc and every command is error inc reboot

unfortunately did not enable the logs.

Also the SD used is a different one then previous install.