Geniatech HDStar v3 DVB-S2 Not Working?


#41

It worked for me on the April build, IIRC


#42

@marklam: Thanks for the info !

@sam_nazarko: Can you help recovering the missing patch for Geniatech HDStar v3 DVB-S2 compatibility ?

thank you very much


#43

I’ve installed the april build but still the same error.~
Basically: “not a ds3000” which may point for lacking you patch.

does anyone has a working hdstar ?
can he share
/lib/firmware/dvb-fe-ds3000.fw
/lib/firmware/dvb-usb-dw2102.fw
/lib/firmware/dvb-demod-m88ds3103.fw
from a working installation ?

or could @marklam patch be updated for compatibility with last kernel versions ?

i’ve compiled last osmc kernel, but if I try to do it with the patch, it fails in chunk 12

https://github.com/osmc/osmc/commit/0bebf24072e3296798fa77a594b1fded952c98e8#diff-9834e56c9bc32f4d11025242be0e856c


#44

forget this request.
The module that is not being capable of detecting geniatech hdstar are ds3000.ko and dvb-usb-dw2102.ko
Obviously if I took a little more attention into @marklam’s patch I would understand that :slight_smile:


#45

So… how can make it work :slight_smile:


#46

i’ve already compiled the kernel by adjusting the patches.
But it still fails in attaching the front end to the device.

Now compiling a new version which (for testing) ignores the attaching errors (wait for 2 hours).

(If compiling the kernel did not took so long … )


#47

Thanks a lot


#48

i’ve seen several posts made by your used id, here at osmc and at other foruns: Did you ever got the device working with the raspberry pi ?
even with another distribution ? (I could try to understand the diferences to make them usable in osmc).


#49

Not at all, I have tested another dvb devices working properly and know I have this one, that I thought there has been patched (because the post of the_bo) and i have tried to test again I have tested it doesn’t work either.


#50

I will continue to try this one.
I have some more possibilites. if neither work, and nobody else helps, we will probably be stuck with a windows only device :sob:

What other dvb-s devices have you sucessfully tested with osmc + raspberry pi ?


#51

This was working with the April update. Haven’t tested the device since as I’m using a different dvb usb an tevii s660 which works out of the box.


#52

Thanks for the info.

I’ve tried the april update, but it s not working. (Installed from scratch in a new sd-card).
I’ve also adapt the patch to be compatible with the current sources and compiled the kernel for the current version … still no luck.


#53

just plug and play in a raspberry pi with osmc ???


#54

Yeah as far as I know I didn’t need to change anything when I plugged it in. This wiki page lists which devices are supported by Linux which means it should work ok out of the box.

https://www.linuxtv.org/wiki/index.php/DVB-S2_USB_Devices

Still pity the patch was removed for this device as it’s useful to have working as a backup incase my tevii s660 packs up. Not sure what the reason was for removing it.


#55

yeah. the geniatech was in the listing. That’s why i’ve bought it. it cost just 30 eur !
I’m currently using a wintv hd-solo for dvb-c and wanted to try geniatech for dvb-s.


#56

Yeah the geniatech is supported but there are 3 versions of this device with only v1 & v2 supported hence we need to patch v3.


#57

[UPDATE]

I have just compiled and instaled the osmc kernel again.

This time, adapted the latest patches from v4l (january 2019) for the needed modules for geniatech (ds3000.c , dw2102.c, m88ds3103.c).

rebooted.

Again the same dmesg error:
dvb-usb: no frontend was attached by 'SU3000HD DVB-S USB2.0'

it does not even go into the firmware loading phase.

Suggestions ???


#58

Sorry I’m a noob at kernel compiling so not much can help you with unfortunately :neutral_face:


#59

Looking good ? :sunglasses::sunglasses::sunglasses:

image

Geniatech HDSTar DVB-S2 Version 3.0 (DS3000/TS2020 chipset)
and
Hauppauge WinTV Solo HD DVB-C

Running with OSMC in a Raspberry Pi !

:sunglasses:

Failed in:
Compiling OSMC with the april patches.
Remade the patches;
LinuxTV V4L media_build
V4l_updatelee

And the solution came from …
Crazycat’s VL4 media_build branch from linutx v4l !
I don’t know exactly why, but it (seems) to be working (and I wil try to know why).

I will keep posting the results here
And I promisse I will find a way of easy sharing the fixed modules and a description on how to make your own compilation environment.


#60

That’s great!
Unfortunately, I’ve got hardly any time to work on this, but I’ve been trying to merge the Raspberry Pi Linux kernel tree with the v4l-updatelee (which seems to include the Crazycat changes).
I’ll try to post updates if I get anywhere with it.