Geniatech T230C2 Support

Hi,

I installed OSMC today as LibreElec stopped working - I think it received an update with a bug. I have a DVB-T2 tuner, the August T210v2, which I believe has the same electronics as the Geniatech T230C2:

dmesg:

[ 3.305080] usb 1-1.4.2: New USB device found, idVendor=0572, idProduct=c68a
[ 3.305090] usb 1-1.4.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3.305094] usb 1-1.4.2: Product: EyeTV Stick
[ 3.305099] usb 1-1.4.2: Manufacturer: Geniatech
[ 3.305103] usb 1-1.4.2: SerialNumber: 161206

With LibreElec I never got this to work, but I did get to the stage of running two modules (from crazycat):

dvb-demod-si2168-b40-01.fw
dvb-tuner-si2158-a20-01.fw

However I think these are for the T230 (and maybe the T230C). The device mostly didn’t work, although I was briefly able to get a few frames from Channel 4 HD (I’m in the UK).

I’d like to ask if anyone has the T230C2 and has been able to get it to work, or knows if there is support for this device.

There seems to be some mention of support for it here:

https://github.com/crazycat69/linux_media/commit/773958eb1c3853590d6f726e6a7d8df87d16639c

But even though I’m using the crazycat firmwares, I am not getting anywhere.

Cheers!

Try the fw files here Dropbox - OSMC - Simplify your life They work for me with a T210v2.

Although for mine, dmesg reports 0572:c688. The TVheadend forum has pages and pages on August T210.

Hello,

I’m also very interested to making this device work.

The product id is the same: “c68a”, and I have also tried with the build from Crazycat, as well as with the files provided by Grahamh, but it is not working :frowning: (copied the files into /lib/firmware and then rebooted).

Interesting, the dmesg reports this:

[ 2.846171] usb 1-1.4: New USB device found, idVendor=0572, idProduct=c68a
[ 2.846184] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.846190] usb 1-1.4: Product: EyeTV Stick
[ 2.846195] usb 1-1.4: Manufacturer: Geniatech
[ 2.846203] usb 1-1.4: SerialNumber: 161206

but after that nothing, it is like the driver is not even trying to turn the device up.

Is there something I can do for troubleshooting this issue?

Thank you

Hi,

Sorry I didn’t respond earlier, I’ve been busy and it slipped my mind…

I am in the same situation as Jon - I have the firmware on the device but it’s not loading. I tried the files that grahamh shared but these did not work for my device.

Alex

Perhaps there is no kernel driver available.

Do you know what the solution to that could be?

Post logs, so we can see what’s happening.

OK, I’m not with the Pi or tuner at the moment but I’ll share them when I get them.

Here there are mine:

https://paste.osmc.tv/inoxiqosiw

I have not made any progress since then.

Thank you

It could be, if I am not mistaken first the driver recognize the device, and then it look for the firmware.

If the firmware in /lib/firmware/ was missing or was wrong, but the driver kernel module was correct, I believe I would have seen something with “dmesg | grep dvb”

Please post full logs (grab-logs -A).

Here it is:

https://paste.osmc.tv/ogadubekol

Thank you

The log doesn’t show any driver being loaded.

According to this post, the correct driver for the T230C is dvb_usb_cxusb. That’s not to say that it also applies to the C2 version.

A quick check reveals that the VID:PID of 0572:c68a isn’t in dvb_usb_cxusb, though 0572:c688 is.

osmc@osmc:~$ modinfo dvb_usb_cxusb
filename:       /lib/modules/4.9.29-13-osmc/kernel/drivers/media/usb/dvb-usb/dvb-usb-cxusb.ko
license:        GPL
version:        1.0-alpha
description:    Driver for Conexant USB2.0 hybrid reference design
author:         Chris Pascoe <c.pascoe@itee.uq.edu.au>
author:         Michael Krufky <mkrufky@linuxtv.org>
author:         Patrick Boettcher <patrick.boettcher@posteo.de>
srcversion:     87068A0EA9DBB627171120A
alias:          usb:v0572pC688d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0572pD811d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0572p86D6d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB98d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v07CApA868d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB71d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB70d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB78d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB59d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB58d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB55d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB54d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB11d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB10d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB01d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB00d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB51d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pDB50d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pD501d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0FE9pD500d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1660p0932d*dc*dsc*dp*ic*isc*ip*in*
depends:        dvb-usb,dib0070
intree:         Y
vermagic:       4.9.29-13-osmc SMP preempt mod_unload modversions ARMv7 p2v8 
parm:           debug:set debugging level (1=rc (or-able)). (debugging is not enabled) (int)
parm:           adapter_nr:DVB adapter numbers (array of short)

To see if the driver works with the C2 version, unplug the device, run:

sudo modprobe dvb_usb_cxusb
echo "0572 c68a" | sudo tee /sys/bus/usb/drivers/dvb_usb_cxusb/new_id

then plug in the device. (This will not survive a reboot.)

It seems that it is not working:

(modprobe)
[ 83.817365] usbcore: registered new interface driver dvb_usb_cxusb
(device plugged in)
[ 166.028130] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[ 166.159001] usb 1-1.4: New USB device found, idVendor=0572, idProduct=c68a
[ 166.159017] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 166.159026] usb 1-1.4: Product: EyeTV Stick
[ 166.159033] usb 1-1.4: Manufacturer: Geniatech
[ 166.159041] usb 1-1.4: SerialNumber: 161206
[ 166.160158] dvb_usb_cxusb: probe of 1-1.4:1.0 failed with error -22

Either it’s not the correct driver for the C2 or it’s the correct driver but something else has gone wrong

Perhaps you can do some research and find out what the correct driver is for the C2.

Has any of you actually compiled CrazyCat’s media-build? It’s not just the fw you need.

That’s exactly what I wanted to ask you. :slight_smile:

Maybe I got the wrong idea, but I believe the firmware is uploaded on the device when it is connected (otherwise I would have needed to flash it if it had a rom for the full firmware), and it is in charge to run the device, while the driver is meant to handle the the device from the OS.

No, I have not compiled the code, I used the built that CrazyCat has uploaded, but apparently there are only firmware.

I did it,

the support for this device has been included in LibreElec, for which a new built has been made also for testing purposes:

It seems that it has not been a long task, according to the diff:

although another fix has been reported later.

You have to compile media-build with CrazyCat’s patches ( and maybe those others mentioned in the comments). It’s a while since I did one - instructions on the V4L site IIRC.

Firmware is OS independent and just loaded into the stick. Palossari is the expert in sniffing USB traffic in Windows and creating firmware files it seems.

I managed to make it work.

I choose to compile the modules using the current OSMC kernel version (4.9.29-13-osmc) which I believe it is better rather than using modules coming from a different kernel, thus I had to manually apply the patches.

This task took me a bit of time, since the code for c689 was missing, and the c68a device support has been implemented on top of the first.
In addition, I had to update and build the drivers for both the demodulator and the tuner, for this operation I simply replaced the code files (luckily, no additional dependencies had to be fixed).
Maybe I could have replaced also the cxusb.c file instead of applying all the new changes, but I was worried that new files could have also contained references to other modules that would have been out-of-dated.

I am not familiar with kernel stuff, do you think I could have done it differently? Feedback appreciated, thanks

Btw, I can share the binaries if anybody interested.