Glitchy Vero 4k Remote

Hi all,

I’ve had a Vero 4k for 3 years now and for the last couple of months have been experiencing a weird glitch with the remote where occasionally I need to click a button 2-3 times before the Vero recognizes it. Primarily I notice this when using the arrow keys and the “ok” button. At first I thought it was a battery issue, so I replaced the battery in the remote but the issue still persisted. Then I re-paired the remote following this guide (Pairing the Original Black OSMC RF Remote Control with a Pi/Vero2/4k/4k+) but unfortunately I’m still having the same issues.

Has anyone else run into this problem and found a resolution? Wondering if I need to replace the remote altogether.


Can you post some logs via My OSMC when the remote is misbehaving?
Do you see a blue light on the remote when the remote buttons aren’t working? Are the blue flashes short or long?



Hi Sam,

Thanks for the quick reply. I just played around with the remote a bit and can confirm that the blue light on the remote still appears (short flashes) when I press a button even if it doesn’t do what it’s supposed to. It seems that it never takes more than 3 tries of pressing the same button to get it to work properly (if that’s helpful.)

Here’s a recent log:


Hi Brian

Thanks for the logs.

The logs don’t show the USB receiver disconnecting and reconnecting, which is what I’d expect to see if there was a faulty receiver.

I hate to ask, but did you replace with a new battery? The symptoms you describe usually occur when the battery is low.

Unfortunately due to the age of the remote (I suspect you don’t have volume buttons but FF/RW buttons); we don’t produce replacement parts for this model anymore


Hi Sam,

I actually replaced the battery twice, and the 2nd time I literally went to the store and bought a brand new pack of 2032 batteries just to make sure the last pack of batteries wasn’t just a bad batch.

Here’s a photo of my remote if that helps.


I suspect you haven’t had the Vero for three years then and it’s a bit newer than you think.
When the issue occurs, does removing and re-plugging the OSMC dongle solve the problem? Have you tried the OSMC dongle in another port? Is there anything else connected to the Vero via USB


Believe it or not, it has been 3 years! My receipt from the OSMC store is dated December 5th, 2017.

I’ve tried removing and re-plugging the remote receiver but it doesn’t improve things. I have a gigabit ethernet USB adapter in the other USB port and I’ve tried swapping these USB ports to see if that improves anything but unfortunately it doesn’t.

Any other ideas?


December 2017 is the edge of when we first introduced the volume enabled remote (although it has been refreshed since) before announcing it a little late.

See The new OSMC Remote - OSMC.

Can you try it with the Ethernet adapter disconnected temporarily?

Have you confirmed there’s no obstruction (i.e. debris) around that part of the remote?


Hi Sam,

I gave it a shot with the ethernet adapter disconnected in both USB ports and it didn’t seem to make any difference. There’s also no debris anywhere around the remote. Wish one of these options would solve it but doesn’t seem to be the case.

Hi Brian

That’s fair enough. Thanks for trying the instructions. Can you shoot over order details to with a link to this thread?



Done. Thanks again for the help!

This is just an observation as my remote still works perfectly when I am in the same room as the Vero 4K. The remote is 21 months old and since new, I have been controlling the Vero 4K perfectly from my bedroom. The Vero 4K is in the lounge at one end of the house and I can view its output via an under-house amplified HDMI cable. I also view it in the lounge. My bedroom is 15 metres distance from the lounge and there are 3 gib-board walls between the lounge/bedroom. I was most impressed that the remote worked perfectly over that distance, through the 3 walls.

Over the last month, the remote started to need a button to be pressed many times to have the command activated. I used a brand new battery, cleaned the battery terminals, swapped the dongle to the other port, all to no avail. I wonder if the remote is starting to get a bit “tired”?

Is that a possibility?
As I say, it works perfectly in the lounge.

As I always intended to buy a second Vero, I have ordered a 4K+ from the NZ supplier.
With one in the bedroom and one in the lounge, the remote won’t be a problem anymore.
I can retire the under-house HDMI cable now as it is seven years old.

Usually, this means a customer has done some travelling or had the remote and receiver disconnected for some time and they need to initiate a re-pair.

Did you try re-pairing your remote?

Shucks, the most obvious thing to do first, and I forgot to do so… lol.
I will try a re-pair.

Carried out the re-pair. I will have to wait until this evening to try it out as I had forgotten to say, that the missed button presses are much worst at night, sometimes it just won’t work at all.

I wondered if something in my residential suburb was being “switched on” at night and interfering with the remote signal.

During the day, some button presses have to be done more than once but nothing like at night.

After the repair, it works fine in the bedroom during the day, will post in about 7 hours about how it goes in the night.

If you have the issues “at night” I suggest to make the re-pairing in this time window so the remote and RF dongle uses a free/low utilized channel from that time on.

I’ve recently noticed that pressing ‘ok’ too quickly gets missed. I can zip around with right/left/up/down as fast as usual but it seems to like me to wait a second before pressing ok. I’ve only noticed this happen in the last couple of months.

I did not know that. I thought that the remote and its dongle were locked together, to a specific frequency. It worked perfectly last night.

This is exactly what happened to me with the first generation of the OSMC remote (the one that came with the Vero 4K). The OK button wasn’t working properly, I didn’t report it at the time because I decided to buy a new iteration of the remote (when the forward and backward buttons were replaced by the volume buttons) but also because I also bought a Vero 4K+. I also didn’t think it could be a somewhat common issue with the remote but maybe it was something that was happening to mine.
Since I saw this post I decided to share my experience as well so maybe Sam can investigate this problem considering there are several people experiencing it.

Edit: I tried re-pairing the remote and changing the battery several times at the time

Thanks to everyone who jumped in and contributed to this thread. It’s good to know that I wasn’t the only one who had a similar issue. Hoping that replacing the remote will solve these issues.