Gopro Hero 6, Stuttering Video

I’m recently bougth a gopro6 black and I’ve just shooted a short 4K 50FPS (PAL) video.
It took few seconds to Vero4K to handle the file and played it really weird. I’m on latest (May.2018) version.

Here is the codec info:

[off] my LG OLED 55 B7V played the file smoothly bytheway [/off]

What does weird mean? Colour issues?

Ohh, sorry my last comment haven’t been posted. So vero4k pre-loads the video - I can see the progressbar-, but the video just doesn’t even start. After a few seconds it starts playing but not on normal speed but a bit quicker…

If I upload the raw video, can you guys try to play with vero and tell me what’s wrong with it?

Yes — that would be ideal

Here are some samples, directly form my gp6 hero black:

Zip fIles inculudes:

  • 4K_50FPS_GX010002.MP4
  • 1440p_50FPS_GH010004.MP4
  • 1080p_50FPS_GH010005.MP4
  • 1080p_100FPS_GH010007.MP4
  • 1080p_200FPS_GX010008.MP4

Vero4k stuttering and pre-buffering for all of the files. For 4K video, when playback finally starts, the video speed is a bit quicker than it should be.

With ‘Adjust Refresh Rate - always’: Gopro6 4K content playback doesn’t even start.

All fine on PC (MPC-HC, VLC), or LG 55B7V.

Pls test and share your findings.

@esox: I downloaded your examples and did some tests with my Vero4k connected to a FULL HD plasma.

  • the both examples with 100/200 frames per second are out of the specification for the used AMLogic S905X within the Vero4k, the maximum is H.265 4K with 60 fps

  • all 50 fps videos play fine and fluent in my environment therefore I have the suspicion that the video HW acceleration in your Vero4k is not activated or wrong configured.
    Could you check at

Settings → Player → Videos

that the following settings are made (in expert view mode):

  • Adjust display refresh rate = Always
  • Sync playback to display = disabled
  • Enable HW scalers for scaling above = 20%
  • Allow hardware acceleration -amcodec = Enabled
  • Accelerate MPEG2 = Always
  • Accelerate MPEG4 = HD and up
  • Accelerate h264 = Always

If this does not improve the display of the 50 frames-per-second samples, we need logs from your system:
To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thanks for testing. I’ll double-check my vero4k config when I get home and re-play my samples.

Hi there,

I set all the suggested settings, but 4K 50 FPS video won’t start. I hear chunk of noises but no picture at all. 1080P, 1440P 50fps videos are buffering 2-3 seconds but than vero4k plays them well.

I saw lot’s of error in the log, when 4K sample video comes…
19:19:34.066 T:2605966080 ERROR: Unable to load, reason: cannot open shared object file: No such file or directory
19:19:35.075 T:4082479696 ERROR: EGL error in CreateSurface: 3003
19:19:42.227 T:2597577472 ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
19:19:43.112 T:2981290752 ERROR: EXCEPTION: XBMC is not playing any media file

Here is the full log, start to investigate from 19.10 o’clock.

@esox Ok, see that you try to start the videos from a NAS via Kodis’s nfs implementation.
Please, just for tests put the video on a fast USB stick or hdd and try playing them without network involved just to eliminate network/NAS as the potential bandwidth bottleneck.

There are a lot of stream stalled messages in the Kodi’s log which point to a crucial bandwidth issue with your NAS.

I have lots of other 4K media on my NAS and vero4k plays them flawlessly, but I put the gopro videos on an usb3 pendrive and played them from it. Unfortunatelly it’s the same result :frowning:

Check the log from: 22:56:19.118
22:56:19.118 T:4082479696 NOTICE: VideoPlayer: Opening: /media/C8943D4E943D3FEC/gpro/4K_50FPS_GX010001.MP4

2nd video:
22:56:41.554 T:3862917888 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: HEVC (High Efficiency Video Coding)
22:56:47.823 T:4082479696 NOTICE: VideoPlayer: Opening: /media/C8943D4E943D3FEC/gpro/4K_50FPS_GX010002.MP4

What’s wrong with these videos? How come that your device can play them? Why my device can not?
Should I factory reset my vero4K? Would it help? I’m clueless.

I enabled debug logging on my system as well and compared the log with your try to play the 4K Gopro file, differences:

  • you played the file 4K_50FPS_GX010002.MP4, mine was 4K_50FPS_GX010001.MP4
  • your TV is a 4K TV, mine is a FULL HD with 1920x1080 resolution
  • at Settings->System->Video you’ve set the HDMI flag Force RGB
  • the desktop resolution is DESKTOP on your Vero4k, mine is 1920x1080

I copy @sam_nazarko since I fear that I cannot help from here with my FULL HD TV. I would like you to ask to try two further things:

  1. Reduce the desktop resolution to 1920x1080 at Settings->System->Video. It does not reduce the resolution of video playbacks but there could be some issue when switching the resolution.

  2. Just as test you can try the current development stage but be warned that IR remote controls do not work then anymore; the original remote control is a RF one:
    2.a Add line deb stretch-devel mainto file /etc/apt/sources.list
    2.b sudo apt-get update
    2.c sudo apt-get dist-upgrade
    2.d sudo reboot
    2.e remove the added line from /etc/apt/sources.list

From here Sam or one of the developers has to take over.

I did all you suggested above. Vero4k rebooted.

Here is my console log:

Hurray! Vero can play both of my 4K 50FPS sample video from gopro6. There are still some pre-buffering (I guess it’s because network bandwith), but after than all fine now.
I tried playback from an usb3 pendrive. It’s also fine now.

Thanks a lot. So on my sytem there is a dev version of osmc installed, right?

It’s the actual development stage. If you remove the line from /etc/apt/sources.list (you should do since the development versions can also be unstable), you’re on the main release again when the next official OSMC update will be published.

Just curious: You tried first to change the desktop resolution but this did not help? The solution came for you with the current development OSMC?

Hi Jim,

My desktop resolution on vero is 1920x1080 already, I don’t know why was different in the log.
And yes, I think the problem solved because of dev version installed onto my system, because nothing else changed.


1 Like

My vero4k has still some problem with gopro6 videos. It takes 20-30 seconds to load a 1080p 50fps file. When the playback finally starts, the sound plays on normal speed, but the video is much quicker.
So I have to pause the video, wait… and than play.

Here is the mediainfo:

@esox This behavior is the same for playing from your NAS and playing from a fast USB stick/device?

Yes, it’s almost the same. Nothing wrong with massive 4K movies like BBC Planet Earth II, Despicable Me 3, Ghost in the Shell…etc. The very long pre-buffering happens only with GoPRO AVC videos.
I’ll attach system log later on.

Ok I did the test from USB3 external hdd (Transcend StoreJet3).
Kodi log (playback started in 10-20 seconds:

Same file from NAS
nfs:// Judo Kupa 2018/GH010019.MP4
(playback did not started in 2 minutes, so I stopped waiting, i closed the player):


I think you would see improvement for playing from the nas if you changed to nfs fstab mounts:

fstab kernel mounts have better throughput, than the kodi soft mounts.

Thanks Tom.