Gpu_mem in config-user.txt not taken into account

Just upgraded my My pi (1B with 512MB RAM) and suddenly it would not play vvideos (just sound)… googled a little and found that usually than mean the gpu needs more RAM.

hfree -s returned 421 MB available so less than 91MB for GPU… (I remembered that 144MB are normaly given when 512MB RAM is available…)

So I went to config.txt to check and noticed *

  • the new format
  • my old “gpu_mem_512=144” was not there

So I added back gpu_mem_512=144 to config-user.txt and rebooted…
hfree -s still returned 421 MB… Strange…

For the sake of a test I removed gpu_mem_512=144 from config-user.txt and added it directly config.txt and rebooted
This time hfree -s returned 351 MB (so 161 Max attributed to GPU - coherent with my 144)

→ It therefore seems like the settings that should be set via the “include config-user.txt” are not getting set at all !!!
I don’t think I havve avy permission errors that would explain the config-user.txt not being included…

-rwxr-xr-x 1 root root    1568 août  24 15:36 config-user.txt
-rwxr-xr-x 1 root root     510 août  24 18:58 config.txt

I also upgraded my pi2 and pi3… and they are seeing the exact same issue concerning gpu_mem_1024 parameter not getting taken into account (but the default amount of gpu_mem seems sufficient for video playback)…

Are there any other tests I can do to figure this out ??? Would like to get vieo back on my pi.


Raspberry Pi 0/1 are no longer supported devices.

vcgencmd get_config gpu_mem_512
gpu_mem_512 is unknown

this definitely confirms that whatever is in config-user.txt is not getting taken into account…

Googling around lead to which states that :

include Causes the content of the specified file to be inserted into the current file.

For example, adding the line include extraconfig.txt to config.txt will include the content of extraconfig.txt file in the config.txt file.

Include directives are not supported by bootcode.bin or the EEPROM bootloader

This was discussed a couple of weeks while ago.

Thanks for the feedback… I did a quick search - too quick - it seems in the forums…

Well guess I’ll hack cating config-user.txt to config.txt if it isn’t in there yet… as a work around so no future update blocks me again…

There’s no need to adjust gpu_mem, we will remove this option from Pi config shortly.