Green screen after fast forwarding several times

I get a green screen (audio remains fine) after pressing the fast forward button several times in a row. It doesn’t happen every time but enough to where I can reproduce it at will. Rebooting my Vero 4K+ is the only thing that fixes it. Happens when subsampling is set to RGB, 444 or 422 and happens with all the content I’ve tried since updating to Debian 11 (so far 1080p SDR avc, 4k SDR hevc and 4k HDR10 hevc). Never had this issue prior to Debian 11.

1 Like


It would help to see some logs to know more about this problem, as well as knowing which version you were on before. There were green screen issues with older versions of OSMC when playing HEVC, but these were largely addressed.

It just happened to me again and I’ve rebooted. Do I send you the logs again or wait/make it happen again and then send the logs before rebooting?

You would need to send debug logs after reproducing the problem.

A sample video file would also be useful.

Rewinding also causes it. I’ll get you that sample next.

vid sample:

Any luck reproducing/identifying this issue?

This has already been fixed in the staging repository.

To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.


Even better thanks.

Just tried it. Looks like the fix is working.

Had this same issue the other night, reboot fixed it, came to the forum to make sure I’m not crazy.
I rarely seek when watching videos so not a huge issue for me but glad there’s a fix already.

@sam_nazarko , when will this fix likely roll out in a regular update without having to go through the staging repository? If likely sooner than later then I’ll probably just wait.

It will be a while yet

Thank you very much.

Also fixed the same problem for me perfectly.

1 Like

Had the same green screen problem described in the latest September release of OSMC. Tried @sam_nazarko suggestion above to update to fixes in the staging repo and can confirm it has fixed the problem too.

here’s hoping it makes its way into the stable release soon.

I also had this issue with my Vero 4K+ and the above update fixed it. Thank you for the quick response!

Fixed issue for me too, Many Thanks.

Fix works but I do wish this would be rolled out to stable soon, those who aren’t confident with command line and ssh will not be able to do this and will think their device is broken.

1 Like

It will be rolled out when the next update is stable and ready for release.

1 Like

worked for me too !