GUI reset to 720p after reboot


I have to reboot the Vero 4K+ regularly because of another issue:
Vero 4K+ messes with ARC Apart from that, I leave the Vero on permanently.

I have set the Vero to use 1080p60 for the GUI.
However every few times the Vero will start up with a GUI in 720p.

In the logging I see in guisettings.xml: <screenmode>00192001080060.00000pstd</screenmode>

However in the kodi log:
21:28:53.676 T:4078010960 NOTICE: Desktop setting is 00128000720060.00000pstd

How is this possible. Do you have any suggestions for me to fix this?


@grahamh is this related to the plans to remove desktop resolution?

If you exit Kodi (not shut down) it will restart. Does it restart at 1080p?

I just tried it and it starts in 720p. See

Then I fixed the setting and tried Exit again. This time it stared in 1080p :

I used Exit three times after that, but every time it started in 1080p. This looks random to me.

Are you turning on Vero before you turn on your TV or AVR?

In the cases above (for which I have given logs), The AVR and TV are both on and set to the Vero.
But I have similar results when the AVR and TV are set to another input. Sometimes the Vero boots to 1080 and sometimes to 720p.

The Vero is connected via AVR Onkyo TX-NR646 to LG OLED55C8.

Okay. I added some hotplugging in the last update so users could turn on their equipment after Vero had booted. It may need some more work.


No, it’s not the hpd code, it’s just Kodi is not saving the GUI resolution in guisettings.xml as we discussed in Slack. It saves ‘DESKTOP’.

Yes — but on that note we should probably rip DESKTOP to make HPD complete

Are there any news on this topic? I Have the same issue. It also seems random to me. Every 4th or 5th time my Vero 4K+ sets the resolution back to 720p.

Should be fixed with: [TESTING] Vero 4K / 4K + video improvements which will be made part of a new update shortly.


Having just bought the vero I too have this issue, I am so glad everyone is helpful on this forum and that you are on top of it and will be fixing it in a upcoming update and that this time it’s not just me being a idiot.

1 Like

Mine has done this too recently.
I didn’t pay much mind to it because I thought it was a fluke, but I guess it’s a thing.
I hardly ever turn my Vero off so it’s pretty much a non-issue to me.
Just thought I’d pop in and let you know that your not the only one mellon.