Hard Drive Install ATV1

Could anyone help me with a hard drive install on atv1 , I have atv1 with iTunes still on it and I have atv1 with crystalbuntu on them , Is this the same as before I just use usb flash drive to do install with Ethernet cable to connect to sever . I have always preferred hard drive install , Does crystal hd card still play a role in new OS .
A lot of add–ons lately aren’t working anymore on crystalbuntu so I guess its time to update

Should be able to just download the installer now from osmc.tv and install to hdd. I just tried but only got this though:

https://discourse.osmc.tv/t/osmc-for-apple-tv-not-working/12208/5?u=actiona

Will try again when I get home :slight_smile: was in a hurry on my way out, and didnt pay attention it would seem. Thanks.

Hi I’ve gotten past the point where bo1e was and everything seemed to install, but all I get is a black screen. I’ve tried multiple times with 2 different USB sticks and same result everytime. The installer tells me it formatted and installed files successfully. Then it seems to reboot and the OSMC splash screen appears and then nothing. Sorry, don’t mean to hijack

Worked fine for me when attention was paid. Looks like the settings restore worked as well. Neat stuff. Will be looking closer tomorrow.

How long did you wait after the splash screen ?
How is the ATV connected to the TV ?

I’ve run in to trouble on another of my atvs. Install seems to go fine, but nearing the end when osmc is supposed to start, I get the splash screen, and then solid pink screen, and then I get a few blinking sad faces, and then it seems to loop there. Sad face and pink screen.

Was wondering if it could be due to this one using component video out. I’ve tried installing with hdmi connected too though.

Never mind. Started correctly after a couple of reboots, for some reason. Had both component and hdmi connected at install, maybe that caused it?

Having ONLY component connected will cause a black screen, since it needs to be manually configured.
HDMI should just work. Composite should just work, but I haven’t personally tested it.

The problem you experienced is likely a bug we occasionally have now seen due to recent optimizations.

The bug: Sometimes Kodi tries to starts BEFORE the tasks that need to run when the system boots for the first time, are completed.
Temporary Solution: Wait a few minutes, then reboot the system so the tasks can complete.That usually works.

Spinner,
After the splash screen, the screen went black and I let it sit for a good 15-20 min. (I got frustrated, so I watched some TV and then checked on it later- still black). I have it connected via HDMI

Spinner one more thing,
After letting it sit a few minutes, I did reboot - twice (just to try) and it still goes to black screen. Thanks for any help you or anyone can offer.

If the you get the message “OSMC installed successfully” and the system reboots, and gives you a splash screen, then goes blank… that is when First time Startup walkthrough should appear. Kodi may be running and you can’t see it.

Try a different tv if you can ?
I wonder if the TV is not being detected correctly

Try ssh into the ATV1. It may actually be running but can’t figure out the required TV mode.

good evening spinner! top news on the new hd installer

downloaded the installer and running it now. after I pick apple tv, its asking me to select which version, and gives me 3 opions in a drop down list. I cant make out which is the right one to pick? can you help? thanks man

That’s what I thought, but got to wondering when things didn’t go as expected :slight_smile: Everything seems fine now, using component video. Thanks!

Currently there are 3 versions listed:

2015.12-4 USB (Dec 2015 version 4, for running OSMC on external USB stick)
2015.12-4 HDD (Dec 2015, version 4, for running OSMC on internal HDD)

2015.10-2 USB (Oct 2015 version 2, for running OSMC on external USB stick) Old version.

If you want to do an HDD install. then 2015.12-4 HDD is the one you want.

absolute legend man. and sam too. big time

hi spinner. ok did the usb, hooked it up to apple, switched off and on, it did a few things then asked me to remove usb, switch off for ten secs, then back on. OSMC installation starts, gets all way to end then just stops, very much like what the lst installer was like. am I doing something wrong?

You mean you did the HDD install version ?

End of what ? Which screen ? What was the last thing you see ?
Need more details than that.

yes I did the hdd versio onto the usb key.

the last thing I see is the OSMC splash screen, with the installer bar fully blue

What does the bar say ?
Formatting device, Installing Files, OSMC Installed successfully ?