Hard Drive Install ATV1

I’ve had that issue with other skins simply due to familiarity.
I switch to confluence, do my initial configuration, and switch back to whichever skin I prefer.

I have had much correspondence with the infamous Sam so I know 1st hand he means what he says my issues was with me I couldn’t locate the link I needed to accomplish what I wanted to do. I have been a fan and follower of Sams for many years so I was in no way insinuating that he was being disingenuous.

Thanks Sam for all your hard work !

Oh yeah I installe the update on my atv1 running from USB stick yesterday and now all it does is flash on and of from black screen to OSMC screen with a rather disturbing sad face? Haha

Brian

1 Like

Sounds like the read only boot partition issue again. That update tries to update the kernel and modules, and will fail if the boot partition is read only.

Fortunately the January 2016 version has code that will help prevent this in the future, once it’s installed fully.

Here’s a thread that explains how to fix it, but for some less “Linux Skilled” people, the best option IMO is to wait until the new Jarvis installer image is available, and reinstall.

8 posts were split to a new topic: Kodi crashing with Sad Face after updating to Jarvis

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Specifically you need to SSH into your ATV1 and post logs.

FWIW: Your system would have updated to Kodi “Jarvis”, which is a completely new version of Kodi.
A LOT has changed with Kodi since the previous version.
That means many of the add-ons won’t work, at least until add-ons developers fix them.
We’ve seen complete kodi startup failures when unofficial addons were installed, before updating to Jarvis.

I suspect, it’s because some of those add-ons run in the background, and when you upgrade to completely different version of Kodi, and the addon hasn’t been able to update to a compatible version yet, Kodi crashes.

Since XMBC 13, when updating to a new major version of Kodi I always do a clean install and then reinstall the addons and library.

A post was merged into an existing topic: Kodi crashing with Sad Face after updating to Jarvis

2 posts were split to a new topic: ATV Issues

Okay I did away with the usb install and I did the hdd install on a 40gb hdd in my ATV1 and then I updated and everything is running good except one thing which I’ve seen on multiple devices and after a few days it seems to resolve it self. I don’t know why and I thought I’d ask just in case anybody else has seen this. When I go into an add-on and click on most popular it spins “working” half a turn and then nothing, other than that OSMC HDD install running Jarvis seems to be really nice. I also wanted to say I appreciate everything you guys do for us and apologies for the “DUH” comment. I wasn’t trying to be an arse but I forget how text sometimes comes off when there is no inflection to the words. I also wanted to admit that I didn’t understand how the installer worked. I kept looking for the ATV1 installer under downloads. Maybe you guys can add a note in the downloads section that gives a brief but informative explanation on how the installer works. I looked everywhere and finally found it written in the forums. I just saying if in the downloads area it said the USB stick is created on your computer so download the OSMC installer for your OS and then create the USB installer for your device. I may just think to much inside the box but I kept thinking the downloads area was directing me to download OSMC for either Windows or for OSX or for Linux meaning download the OSMC install for you OS not download the installer for your OS. Just a thought. I would click on the installer and stop it b/c I thought it was going to try and install OSMC on my Windows 10 machine. I know I’m an idiot but it had been a while since I’d installed CB so I got a bit confused. After I figured it out I felt like a complete jackleg but all is well now.

Cheers!

Great to hear ! :smiley:

As for some install docs, That’s something I plan to do (in addition to a Putty tutorial).

I suspected that some people may make the wrong assumptions and overlook how simple the install actually is.
The fact that the installer is the same for all platforms can make it confusing when you are installing on the ATV, especially when you see that menu. which is ghosted out/disabled for the ATV, part way through.

Unfortunately real life has got a hold of me right now, so it may be short while.

It’ll happen though. :slightly_smiling:

11 posts were split to a new topic: Icons disappear after reboot

FYI: Putty tutorial is now posted in the wiki.

Hi Sam,
Can some one help me out please. .
i tried doing hdd install on USB after plugging usb to apple tv
Used this file visa image to load to the installer
OSMC_TGT_appletv_20160130-HDD.img
AFter installing connected usb to apple tv
and got same error messager


Please help any help would be highly appreciated

@felsandric so what happen if you "remove USB stick unplug the Apple TV. Wait 10 seconds and plug the Apple TV in again?

how to set the original image 1 Apple TV?

Im assuming you have already thoroughly gone through all the tricks / hints with USB sticks compatible ones and if you have tried other versions of the image as well. I can tell you all the steps that I took for mine was the ONLY way it could work. Im not sure I have ever agreed with the 10sec part. I have issues with Kodi where if its freezes and I don’t unplug it for more than 30sec to a min. it will give me a AppleTV ? icon.

  1. i would try a different USB stick possibly.
  2. or use the USB image to get it to load / boot then copy the HDD image onto that I mentioned earlier in the post.
  3. I know Sam said what I did is overly complicated, but I could NOT get it to work otherwise with the hardware / tools that I had available. Sorry if this is not helpful, but maybe it gives you some ideas.

I’m pretty sure the USB version is for installing OSMC on a hard drive, with a flash drive being the OS installation disk.

USB is for installing on USB
HDD is for installing on HDD

So, the HDD option makes the flash drive the install media for the hard drive?

Update: I just noticed the qt_host_installer no longer has USB and HDD options.

Yes

The installer does have HDD and USB options here, just select the correct image with either HDD or USB extension

Hi, just for memoriez.
I spent 2 days of trying to reinstall OSMC on ATV1 HDD.
Everytime installation have been performed onto USB (although OSMC image was for HDD), but not on HDD.
Changing USB flashcard to 2Gb (earlier was 32Gb) installation finally done in 5 min.

So, good to have ATV1 live again (well not for media purposes, for tests and file store).
Thanks, Sam, et all.