HBO Max does not work

I installed HBO Max on my OSMC but the videos will not play on my Raspberry PI 3.
(How ever other apps for streaming works.)

I followed this guide:

I have restarted my PI and managed to log in to HBO
But when I try to play a show I get a list that looks like different download speeds or something.
-3.80 Mb/s…

But it seems like I can not select anything.

At some moment I think I saw some warning that my OS was to old, but I can not get that message again.

I think my OSMC is from November 2020 so it might be to old. Do I need to reinstall with a later OSMC version and add all my Video-add-ons from scratch?

Best regards

You should be seeking support from the developer of the addon. Not sure how this can be an OSMC issue.

Thanks for your reply!
You may be right.
But could you tell me how do I see my present version of OSMC?
I have installed some add-ons, and if my OSMC is outdated, do you think that the only way is to get a later version of OSMC and reinstall all add-ons? Or will a regular update manage the OS to be up to date?
Best regards Fredrik

Thanks alot
It looks like I then have:

Starting Kodi (18.9). Platform: Linux ARM (Thumb) 32-bit
Using Release Kodi x32 build (version for Raspberry Pi)
Kodi compiled 2020-11-26 by GCC 8.3.0 for Linux ARM (Thumb) 32-bit version 4.19.152 (267160)

Operating System: Open Source Media Center
Kernel: Linux 4.19.122-2-osmc
Architecture: arm

osmc@osmc:~$ grep VERSION_ID /etc/os-release

Is this versions of Kodi and OSMC too old perhaps?
If I recall the warning message I got was something about a too old OS for Widevine, but I might be mistaken on that.
Best regards

osmc@osmc:~$ grep Kodi .kodi/temp/kodi.log | head -3
2021-12-31 17:44:53.419 T:2556     INFO <general>: Starting Kodi (19.3). Platform: Linux ARM 32-bit
2021-12-31 17:44:53.419 T:2556     INFO <general>: Using Release Kodi x32 build (version for Vero)
2021-12-31 17:44:53.419 T:2556     INFO <general>: Kodi compiled 2021-12-20 by GCC 8.3.0 for Linux ARM 32-bit version 4.19.152 (267160)
osmc@osmc:~$ grep VERSION_ID /etc/os-release

Seems you should update then.

You are saying that other streaming addoins work, are they also libwidvine based?

I got a little script I made that made sure the latest libwidvine worked on Kodi v.18.x, check it out:

Hello Joakim_s,

Your script worked like a charm!

Btw I first also updated my OSMC version for my RPI 3B+ to
After that I installed Disney plus and HBO Max.
After that I run your script!

Best regards!