HD audio passthrough not working


#1

Should I maybe start a new thread with this latest questoin as it’s a bit missleading from the title now?


DTS-HD MA 7.1 100% processors and jerky picture
#2

Good idea. Your problem may be related to something similar that’s been reported on some Denons and Marantzes but we haven’t seen it on Pioneers. What’s the model number?

I see you have channels set to 5.1. It’s better to set it to 7.1 and let your AVR deal with the downmix to 5.1. If you have only 5.1 speakers, a workaround for now is to disable HD passthrough.

Can you also update your system to the December release?


#3

Hi Grahamh,

The model number I’m using is Pioneer LX-SC82. So this has something to do with one of the latest firmware updates? Are they happening automatically? It used to work fine just few months or maybe weeks ago. I didn’t do manual firmware update neither so unless they happen on it’s own that seems strange.


#4

Your system was last updated on 3 November. You opened this thread on 15 December but it seems you had ‘sync to display’ on which was disabling all passthrough. So it’s difficult to match any firmware upgrade to the issue unless you can be more precise about dates.

You can check in MyOSMC if automatic updates are turned on. I suspect not, as your previous update was in April.


#5

But just to clarify it’s an issue with Vero and communication with certain recievers right? It’s not something I can fix on my reciever? I’m waiting for more developments in this issue from Vero community right?

Thank you again for all the help.


#6

There is an issue but I can’t say whether it’s the same issue that you have. Could you try this for us? Get a commandline via ssh.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Type

echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

Make sure HD passthrough is on then try to play the vid with DTS-HD-MA. It’s a longshot, but the only thing we changed since April which may affect this.

I also recommend you set your screen resolution to 1080p60 instead of 1080i60


#7

Will do all of the above hopefully later today. Should I try to update to the latest firmwhare as well?


DTS-HD MA 7.1 100% processors and jerky picture
#8

Yes – please do that.


#9

If you haven’t done so already try enabling “keep audio device alive” within system settings/audio.
I used to have problems with DTS HD files on my Denon amp but have had no issues at all since enabling that setting.


#10

That’s interesting news, thanks.


#11

OK, it’s weird. After running that command line (and updating osmc, I know I shouldn’t have done it all at once), it’s better but still something is wrong. It started working do tried another file and no sound in the second file. Went back to the first one - not working neither now. It’s really odd.

Now I can see that when I start the file (with HD sound of course) - there is no sound but after I fast forward quite a bit, the HD sound kicks in. Rewinding back - no sound. FF quite a bit again - sound back again!!!

No idea what’s going on.


#12

We don’t either. You should provide debug enabled logs demonstrating the issue.


#18

Ok sorry for the delay. Here it is… played a movie with HD sound with no sound conning out of the speakers. Fast forwarded few times to like half of the movie so on the 3rd or 4th FF HD sound comes in and logo on the receiver. RW back a bit no sound again. Did that I think 2 or 3 times before uploading log.

Https://paste.osmc.tv/alogoturud

Thanks.

Radek


#19

I’m wondering if there’s something funny with that file. There are a few unexpected messages in the log. Can you clip a minute or two off the beginning of it and upload it somewhere?


#20

file shouldn’t be a problem… All files with HD sound work the same… and I have several with True HD and DTS-MA HD. All behive exactly the same way.

Also as per my previous post most of last year (so since I bought the Vero 4K) they were all working fine.

Radek


#21

OK so please help us by disabling your weather add-on that’s spamming the log, re-booting and just starting to play one of these files once, from the beginning, then upload the log.


#22

Still keeping an eye on this.

Cheers

Sam


#23

Damn!!! What is that!? No worries. Will do that and post back.

Radek


#24

Ok sorry for the long silance… here you go… weather off, system reboot, playong DTS-HD file with no sound.

Https://paste.osmc.tv/tuvubisoti

Radek