HD HEVC videos not playing on OSMC August 2021 update

I’ve just noticed that my HD HEVC videos (720p amd 1080p) are not playing on OSMC. I’m getting sound only with no video output. Before the August update I was able to play HEVC videos up to 1080p woth no problems.

If I change the player settings and disable Allow using DRM PRIME decoder I can play 720p HEVC videos but there’s some stutter or lag in the videos and audio and video will be out of sync at first.

If I try to play 1080p HEVC content, OSMC struggles to play ( audio and video will be out of sync). As the video playback progresses the player will automatically randomly skips the video to a certain point.

Does this mean there will no longer be support for Raspberry Pi 3 or the issue will be fixed in future updates.

It’s a pain since most of my TV Shows and movies are in HEVC

Without logs, it’s hard to tell what your issue is.

Here is the log:



I’ve recently discovered that OSMC stutters on Full HD x264 files as well though 720p x264 files seem to play fine.

We recommend people to set their user interface (UI) to 1080p. Kodi’s UI is not optimized for anything above 1080 yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

I tried everything but nothing worked. I think it’s high time I upgrade to the Raspberry Pi 4 , downgrade to the Kodi Leia November Version or wait for Kodi 19.2 or so to fix the issue.

I know there was “partial” hardware acceleration available for HEVC on the Pi3 under Leia, and there isn’t under Matrix (for reasons outside the OSMC guys’ control); so it might be that.

1 Like