HDD format Vero 4K vs. Vero 4K+

Over the last 3 years I have been setting up 4 its Vero 4K, attached to HDD formate on a Mac (HFS+). Just received three more Vero 4K+ and have attached other Mac formatted HDD (APFS) and HDD is not recognized by Vero 4K+ ???

We need more information to help.
Are the drives externally powered?

Can you paste a log with a drive attached?


Yes, externally powered LaCie 4Tb HDD.
I am not familiar nor with Kodi neither Linux, but I’ll try to get this log.


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I’ve just re-read this in more detail.
I thought the drives were HFS+; but they’re AFS (Apple’s new filesystem). There is a driver available for it (FUSE based); but it’s read-only. I’m not sure how good the performance will be.

The point in detail is: several years ago I looked for a media server able to read from my Mac formatted HDD (I am exclusively working in a Mac environment and don’t want to go to FAT formatting because of files size limitation) and I decided for Vero (before Vero4K showed up). Everything OK. Then came Vero 4K I switched (and purchased 4 or 5 units) and everything worked fine. Then came Vero 4K+ -> issues with HDD reading, but not only with APFS formatting. HDD previously attached to a Vero 4K and working fine (HFS+) once attached to Vero 4K+ are not recognized …?? If I need a driver I don’t care not being able to write: I just want to read from HDD.

OK - that needs looking into. Can you re-boot with your HFS+ drives attached and debug logging enabled and post the logs, please?

Just tried again (after 5 attempts) and Vero 4k+ is reading my HFS+ HDD. After, have tried with APFS formatted HDD and no way.
I have uploaded logs :

We don’t support APFS out of the box yet in OSMC.

In the interim I could give you some command line instructions to try it.

It’s already 8 Vero units I have purchased, and I think this is enough important as to have stated somewhere:formats supported and not supported. If I purchased three more 4K+ is because of the easy use for all my previous Mac formatted HDD.
What am I supposed to do with these three units ?

APFS is a new format. I wasn’t aware that it was used for external drives. I thought it was limited to internal storage of devices like iPhone.

We can work on adding support in the future. For now I can help you get this running but it needs some manual steps

Have you used the command line before?

I never used it before, but I have some friends helping me: Linux software experts.

No problem doing it manually. If you give me detail on what to do, I’ll do it, right away.

By the way, new Mac format APFS already comes in all new Mac’s. I had a new iMac few weeks ago, and no more HFS+ formatting available.

Looking in to this.


Of course its still available.
They’re not going to drop support for HFS any time soon, if ever.
Im using the latest MacBook Pro running MacOS 10.14.5 and its very much supported and available.

1 Like

You are right. Only one point: is Mac OS Extended the same as HFS+? Thanks

Yes. Do you have data on the drive or can you reformat?

I have three 4Tb HDD full (3,6 Tb) to connect to each of the three new Vero 4k+ I purchased. I could reformat and again copy to them, but it’s long time. If possible would prefer trying to make my 4k+ run, but if there is no solution …

I finally decided to reformat and again copy the three 4Tb units under Mac OS HFS format. Everything works. Please, for future bear in mind to state, somewhere, in your specifications which formats are and which not supported.
I am a regular Vero consumer: my typical gift for my friends is a complete media installation, based on Vero, and since I started with the Vero 2, I have already consumed 8 or 9 …

From a little googling, it seems the default for any devices not running an Apple OS is that APFS is not supported. It should not really come as a surprise.

It’s a pity no-one got back to you on this as there does seems to be a read-only solution available.

Glad you got it sorted out.