HDMI/ARC Dropouts

So i’ve been getting these HDMI/Arc dropouts at irregular intervals for some time now and I have learned to live with it by restarting the Vero 4k whenever it happens. Still I feel somewhat irritated because I do not know why this happens. I will provide the logs here: https://paste.osmc.tv/zasayoraza and explain my setup and problem. Maybe someone can give me an insight of what is going on.

I have an LG Oled65E9PLA with the following connections:

HDMI 1- Vero 4K Plus
HDMI 2 (E-ARC) - Denon AVR-X3600H
HDMI 3 - Playstation 5
HDMI 4 - Mediabox Next (TV providers settop-box)

Here is what happens:

As mentioned before, on irregular intervals while watching tv or playing the PS5, the television will suddenly revert to the internal speakers from the LG, going from Sound out HDMI ARC to Internal TV-speakers. I need to manually set the Sound Out on the LG back to HDMI-ARC to get the sound back through the Denon Receiver.

So not a real big problem but I noticed some other changes as well as soon as this happens. After this occurs when switching between HDMI’s channels the screen stays black for about 10 seconds or so before you have picture. Meanwhile you can here the sound of the chosen channel. Normally when you switch between HDMI inputs it will show picture immediately.

Also the Vero will not respond anymore to the Magic remote through CEC/Simplink. After repowering the Vero everything will be working ok until it happens again.

To get a better insight I turned on the debugging yesterday to see if I could time precisely when it occurs. I was lucky to have it happen this morning around 07:30.

I can see a lot of: Vero4K kernel: cectx c810023c.aocec: bus confilct too long in the log. And then at Dec 29 07:31:19 it looks like a sudden change is been made in the sound signal?

then also this happens:

Dec 29 07:31:19 Vero4K kernel: hdmitx: sysfs set hdmi_ch to 0

I have a feeling this could be the source of the problem I’m experiencing but it is beyond my knowledge to identify it or let alone, solve it.

I think it is probably HDMI-CEC related and therefore hard to solve or maybe impossible due to the lack of standard in HDMI-CEC but I thought i could give it another try anyhow.

Thanks in advance if someone takes the time to figure this out,


Is there a reason why ARC is necessary? Modern TVs and AVRs are designed so that the AVR should be the hub of all HDMI devices. Your Denon seems to havve plenty of inputs to accomodate all of your devices. Have you tested in such a configuration?

I disagree that the Denon should be the hub of HDMI. What is E-Arc developed for? With everything connected to the Denon I constantly need to change the picture settings on the LG. For example if I would switch from the Vero to the Playstation I also need to change the HDMI settings on the LG to Game mode. I now have every HDMI Channel configured to picture settings I like. Every device needs a different configuration in sound and picture. I believe the configuration for the picture is better left to the LG television then through the Denon.

On my LG TV and Denon there does not seem to be much distinction between using inputs on the AVR or on the TV. The TV views each input as having certain settings regardless of where it is plugged in when your using CEC. As for the “what was eARC developed for” the answer to that is apps. Having the eARC allows for smart TV’s to get full quality sound out to an AVR for streaming services and the like. Being able to plug an external source into a TV instead of an AVR would be a rather weak selling point.

The Vero may behave a bit nicer on the CEC bus connected to your AVR vs plugged into your TV. I would recommend trying it.

Ok I will connect the Vero directly to the Denon tomorrow and see how that works out. I will leave the rest of the devices connected to my LG, but I have the feeling of being misunderstood. I do not mind losing CEC or that the connection is lost with my Denon. I just want to know why. What I am getting now is an answer of how to bypass that error instead of getting an understanding why the error occurs. Besides, it sounds a bit like: Well if the front door of your house wont open use the door on the back, forget about that front door.

Why is that?

CEC is a stupidly designed system based off some stuff from the SCART connection from decades before it. Because of the way the serial signal is transmitted and shared between devices there can be situations where the electrical protection mechanisms on the line or the length and/or quality of cabling is such that the voltage on the line goes either higher or lower than expected and this can confuse other devices on this CEC bus as it is a shared data line. As such sometimes plugging a device into an AVR vs a TV, or vice versa depending on the situation, can mitigate issues that arise. Some devices are a bit more prone to these types of issues such as early model Raspberry Pi’s and cable television tuners. The Vero is not immune from these issues either. The second hand Vero I own has issues with CEC to the point that I physically disconnected it with a customized cable. This is not the norm though as the posts for these types of issues are relatively rare. They are probably most common though with Vero’s plugged directly into a LG brand TV with ARC enabled.

If you loose CEC, you loose ARC, as it is a dependency.

That’s the best explanation I had on this subject so far Thanks for that. As said I will connect the Vero straight to the Denon tomorrow.

1 Like


So I connected the Vero directly to the Denon and everything looks fine except for when you start a video the picture takes quite some time to start. For example when starting a 4k Movie the screen goes black for 4 seconds than the sound will start but the screen stays black for a second more and the you will get the lost signal message from LG for a second followed by a black screen with the HDR message in the top right corner and than the picture starts. So all in all it takes about 6 to 8 seconds before the movie is up and running.
When you stop the video the screen goes black for a few seconds then again the lost signal message from LG and then it returns to the OSMC gui. About 5 seconds total.

Is this normal when connected through the AVR? I did not have any delay when connected straight to the LG although I can understand some different behaviour. Am I missing a crucial setting maybe? You’ve mentioned you have a similar setup.

Well actually you are missing a setting that would have caused the black screen even when directly connected to the TV.

Settings>Player>Videos>Adjust display refresh rate> On start/stop

Well actually I always have that setting to start/stop so that’s not it. Or do you mean that setting is responsible for the black screen?

Well from the logs in your first post.
Adjust display refresh rate: Off

Surely that setting will cause a short black screen when your TV switches resolution/refresh rate, but video wouldn’t start before that happens

Strange because I never change that setting. Here are my new logs


I made some changes after I connected the Vero directly to my Denon like whitelist but not really much more.

Yes it is normal connected through the AVR or directly connected to the TV. The black screen for a few seconds is the TV switching resolutions and frame rates. This is annoying to some but it is the only way to get maximum picture quality. If you weren’t seeing that behavior directly connected to your TV then you weren’t switching resolutions and frame rates. The switch to HDR mode is automatic so what your seeing is a black screen while the resolution switch happens and then it starts processing the signal coming in, detects HDR content, then blacks out the screen again as it switches to HDR mode. On mine the total time is between 3-4 seconds. My LG TV is only LED so it might be normal for an OLED to take longer (I don’t know). If there really is a difference in time from being connected to the AVR vs. the TV you might dig through the settings of your AVR to make sure it doesn’t have any kind of video processing enabled.

Thanks for your help and information. I guess I will have to get used to the black screen delays whilst starting a video. I did try to change some settings on my AVR to see if anything might shorten that process but did not find any so far that made a change. I will mark your answer as the solution to my question. Once again thank you and of course, for everyone reading this,

Happy New Year!

1 Like

Has this only started happening since you moved to the 4.9 kernel?

No, I installed the 4.9 kernel to see if it would change anything to the Earc/CEC problem but it didn’t.

I’m having the same issue. It’s so bad that sometimes I need to physically disconnect the Vero 4K+ from my AVR (Denon AVR-X3500H) because anything CEC/ARC related simply doesn’t work. For example, when switching the TV (LG C8 OLED) to cable TV, the AVR should switch automatically to TV Audio. But nothing happens and manually changing it results to no sound, so ARC is totally broken. When turning off the TV in this state, the AVR often doesn’t turn off at the same time as it should. I’ve had the Vero disconnected for two weeks or so and CEC/ARC has worked like a charm during that time.

It’s extremely annoying. I might have to get a Shield for my Kodi purposes. Which is a real shame because otherwise Vero is a superb box that plays everything I throw at it. And I have no other use for the Shield than Kodi, so it’s kinda wasted on my use case. Hopefully you can do something about this issue.

If a Vero (or any other device) starts being a bad actor on the CEC bus there is the option to physically disable it by disconnecting pin 13. You loose CEC on the one device, but it allows it to continue working on all other devices.

Thanks for the suggestion but seriously, the CEC capabilities were a selling point of the Vero for me so disabling it defeats the purpose of having a Vero instead of like a Windows HTPC for me. This needs to be fixed, not worked around.

Some logs when this occurs would be helpful.
Has this been an issue since receiving the device or only recently?

Have you tried the usual CEC fix – which is to disconnect everything from mains power for a few minutes, and tried powering again?