HDMI-CEC remote sensitivity issue

Hi, I’ve just recently started having an issue with HDMI-CEC on my Vero 4k. The remote now appears to double-press all the time, skipping extra lines when attempting to select eg. menu items (similar maybe to [SOLVED] Raspberry CEC - repeated inputs). I have tried changing settings in System>Input>Peripherals but this has made no difference. I have tried changing batteries, and another remote (both Samsung) from another TV but the same problem persists. Strangely, it had been working fine the whole time I’ve had the Vero (~3 months) until now.


We haven’t changed anything re. CEC in this update.
Are you using the stable version of OSMC or have you installed a nightly build?

You may find turning everything off (Vero and TV) at the mains for a few minutes resolves the issues.

Did the TV recently receive a software update?


Hi Sam, thank you for your reply and sorry for my very delayed response. I was, and am currently, using the current stable release build of OSMC. I have checked the log, and the Vero is apparently receiving input triggers that have not been pressed when holding down navigation buttons. For example, holding the “down” button to scroll through a selection of items might also (seemingly randomly) select “enter”, or “left” etc. Also, it will sometimes skip menu items even though only a single press of eg. “down” may have been made. Again, these are coming up as additional presses in the log that have not been made. This does not happen on a raspberry pi 3 running OSMC on the same TV. The TV has not had any updates recently, nor had it back when I first posted about this issue. I cannot seem to find any settings in the CEC input menu that mitigate this issue at all.

Are they both coming via CEC or could it be you receive one via CEC and one via IR?
Could try to block the IR sensor to see if that makes a difference.

Thank you for the suggestion. I do not use the IR receiver and have never attached it; I would prefer to just have one remote to control the TV and attached devices. I could try attaching it and see if the problem also occurs with the OSMC remote.

You miss understood me. The Vero4k has a built in IR receiver (under the cross on the front).
If you may have activated a remote profile it could be that it receives wrong/double codes. So just hide the Vero and try

Thanks for clarifying. The Vero is hidden, and I have put some insulation tape over the receiver just to make sure. unfortunately it still receives the false inputs. This does predominantly appear to happen when holding down a navigation button on the remote; the Vero will occasionally receive a different direction to the one being held, or an “enter” command. This results in erratic navigation, and unintentional selection of media items.

Are there any other settings I could try playing with?

Are you using WiFi or Wired Ethernet?


WiFi, connected on the 5 GHz ac band on a dual band router. Could this be interfering?

Can you try Ethernet as a quick test and report back?
WiFi CPU load might be causing some events to be dropped

Will give it a go - thanks Sam.

I tried disabling the WiFi but the issue persisted. I then decided to see if I could try the Vero with another TV, and have managed to get another to try - connected to a different TV, the issue is gone. It is therefore some issue with my Samsung UE40JU6000KXXU TV. It is still on the same 1530 firmware that had been working fine a while back, but I have had nothing but issues with this TV so assume the fault lies there. Samsung support have also been terrible (sorry for the rant), so it’s something I’ll have to live with for the life of this TV.

Thanks for your help, it’s much appreciated.