HDMI-CEC seems to stop working after a couple of hours

Hi, I’ve installed the update. The effect for me is that the problem than I had before (no audio from TV through AVR when Vero is connected to de AVR) now appears immediatly. Before I can have several ours of normal behavour until de TV audio stopped working. Now, the TV stops working as soon as the Vero is connected to de AVR.
Even more, before I can “solve” the issue rebooting the Vero. Doing so I get few additional hours of normal behaviour. Now, even rebooting the Vero the TV has no audio.

Thanks for keep working to solve it.


Still ok today (Sunday), last power cycle was on Tuesday, so 5-days so far.

The update fixed CEC for me. Sometimes it takes a few seconds to turn off the other devices. But turning ON and volume up/down works immediately. Thanks for your awesome work.

Thanks for the positive feedback. Sorry about issues with other devices, I have done what I can. What I can say is that AMLogic did not really care for any chip other than the latest and greatest with their newer kernels.

1 Like

I went on holiday so didn’t get chance to try. Is the 14d limit from installation or from when you posted?

This update also solved the CEC issue for me : a week without issue, I didn’t need to unplug anything.

Mine was ok until Monday this week. So it took about 2-weeks to show an issue.
Reboot got everything back to normal again.

Mine is also affected. Running a vero 4k through a Marantz receiver or through a samsung sound bar, towards a LG oled tv. It worked stable for months earlier while using harmony without cec.

The old 2022-image seemed to give some weeks or a month between crashing. Using a new installation gave only days, while using the dev-update above gave a week or so before crashing.

I’m troubleshooting a bit now, but I also ordered the vero V. Apart from this issue, I’m really happy with the product and the continuous support.

CEC stopped again today, only did a reboot last time, not a power off restart, which I’ve now done today.

Point of interest though. The first sign I get of things going bad is I get the attached message from the TV.
The AVR is connected to HDMI2 on the TV and ARC works even when that message has been displayed.
The Vero 4K is connected to the AVR’s HDMI 2
An Apple TV 4K is connected to the AVR’s HDMI 1

Log from today before restart: https://paste.osmc.tv/ufepajejid

Unfortunately, CEC is still not working for me.

I updated to the April 2024 release from March 2022 today as I’d seen good reports and as usual all fine to begin with but within a few hours of uptime the input had disappeared from the inputs menu on my TV and upon manually selecting the Vero from the AVR input list it switched OK but CEC control was not working. A restart of the mediacenter service over SSH resolved it again for now.

I can provide logs later if you tell me what to look for.

Unfortunately I don’t have any further suggestions.

Get a Vero V? :sweat_smile:

Well – people don’t seem to be reporting issues there. But I have genuinely done what I can to improve CEC as much as possible.


being the original author of this thread… my problems disappeared a LONG time ago…i don’t think i’ve ever been the author of a thread on any forum that carried on for so long lol.

The only time i ever see issues , i just switch to another HDMI input and back again and it’s all good… and it’s very very rare i have to (so i blame the TV itself)

1 Like

My Vero 4K is back to causing CEC issues after a few hours. :frowning_face:

New Vero V ordered. :sunglasses: :+1:

Now to think of something to repurpose the old Vero4K+ to :thinking:

CEC issues largely stopped for me after the March 2024 release too. Previously the Vero 4k would randomly lose CEC requiring a restart of Kodi to get it back after being left idle. Since March, this doesn’t happen anymore, which has been a great improvement on the experience.

However, I am now able to (after much trial and error) recreate the CEC issue at will.

To refresh, the Vero and a soundbar are connected via HDMI ARC to HDMI 1&2 on the TV. A PS5 is on HDMI 3.

Turning on the tv with the tv remote should also turn on the soundbar through CEC. The soundbar takes about 10s to startup fully. If any button on the remote is pressed before the soundbar starts up fully, the Vero loses CEC.

This is easily fixed by switching to another hdmi source (even the soundbar’s) and then switching back to the Vero.

Wondering if there’s some race condition at play here with CEC commands on the HDMI ports.

In any case, CEC isn’t a showstopper anymore.

The problem is that this issue takes time to develop; we have a number of users with different models of displays (no fault of our customers) and AMLogic have abandoned CEC on older model devices. Usually by the time an issue has presented we can’t get a full history of what’s happened because too much time has elapsed and a high uptime of logs would be required.

I’m glad some users such as yourself have reported improvements.
Unfortunately I can’t raise this to AMLogic given the Vero 4K/4K+'s SoC age and its end of life status, otherwise I would be nagging them on the phone daily until fixed.



1 Like

As a point of interest and to show you are not alone, the 2017 Apple TV 4K now have a CEC bug with the current tvOS 17.4 …!!

The ATV still controls the AVR & TV ok, but TV & AVR remotes no longer control the ATV.

Only the 2017 generation of ATV 4K are effected.

On the Vero front, my new Vero V should arrive on Tuesday (maybe Wednesday) :sunglasses::+1:

1 Like

CEC is a pain in the arse. It’s a standard but it’s not implemented a standard


1 Like

Honestly… the vero remote works so much better… but that would mean having 2 remotes per TV and getting the kids to accept that is an issue.

Maybe i could sellotape the vero remote to the back of of the TV remote :slight_smile:

2 of my TV’s are used exclusively for Kodi… so all i really would need is an ir blaster in the vero remote that could learn the very basics… power on / off and input switch.