HDMI - Pink screen sometimes

Hi team!
Hope all keeping safe and well. So my Vero4k works very well, with recent updates as from today, on my LG tv. However, now winter is approaching I bring my Vero 4k into our smaller snug room, with log burner etc, and attach it to my Sony KDL 32EX402.

Now, here’s the thing, all things start well however after about 20 mins the TV screen goes pink…sometimes it reverts back to normal viewing, other times it gets stuck on pink mode. I have tried at least 5 new HDMI cables and they all produce the same result. This Sony TV also has my ATV1 with the OSMC 16.1 build but it struggles with mkv content hence why I just bring my Vero4k in. and the fact that it is lightening fast and much easier to control. However, on normal content, like mp4’s, the ATV1 never produces a pink screen. I have the Broadcom card installed in the ATV1 160gb.
Any kind soul have any suggestions please? Is there a setting I am missing out?




To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks Tom for speedy reply.

Something to look at over the weekend then! I’ll digest all info and revert back if I may.


1 Like

This sounds like what happens when a fluorescent backlight is on its way out. If this is the case it would do it with the Apple TV as well though. Maybe one of the inputs is on its way out? Have you tried swapping the input on the TV between the two devices?

I have 4 HDMI inputs on the Sony Tv and have tried all of them and they all produce the same random pink screen flicker with the Vero4k but not with the Apple TV1. Thats why I thought it may be a simple output setting on the Vero4k…

Try unplugging the aTV temporarily.

The ATV is unplugged when I tested the Vero4k in the Sony…I only have one power plug for the Vero4k or ATV1…so I can only do one at a time…the HDMI cable is also removed from the ATV1…beginning to think it is the tv itself…but strange it has never done the pink screen with the ATV1…

Can you post some logs after the pink screen appears? We had some issues years ago (Phillips 2009 series were primarily effected) where they advertised support for a colour space that they did not support. We then sent the wrong colourspace, and as a result, things looked pink.

It could be the same issue with your TV, and if this is the case, it should be fixable.

Thanks Sam. I’ll try and have a go tomorrow.


Hi Sam, here you go https://paste.osmc.tv/uvotayoxib
The pink screen happened within 30 seconds of playing an 1080p file this morning.
To confirm this is with the Vero4k plugged into my Sony TV with HDMI cable. My ATV1 is unplugged from the Sony TV so it is just the Vero4k attached. I have tried all HDMI combinations/inputs as well as many other HDMI cables and they all eventually produce this pink screen.

Hope you can help.



Here is a picture of my screen situation. Looks more bluey than pink in the photo. Hope someone can help soon!



1 Like

I’m sure @sam_nazarko will be able to help you

That does look like a colour space issue.

@grahamh - do we have a way of adjusting this via a sysfs poke?

Thanks Sam for keeping on it. Hopefully it will be resolved soon!

When the screen goes pink, does running this command help:

echo rgblimitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr


Hi Sam. Thanks for reply.

Sounds like a plan! I’ll hook it up and report back.



Well…this time it took 2 hrs to go pink…however, once it did, I ran the script as you advised and screen returned back to normal. Voila!

So, question is, what does this mean and what do I have to do in the future to stop this from happening permanently?



Okay, I believe that confirms what I suspected.

Your TV is advertising support for YUV but doesn’t support it. So when we send this signal, you see the pink screen.

Going to Settings -> System -> Display -> Force RGB Output and enabling this option and rebooting should suffice.

Please let me know how this goes.

OK thanks Sam. I’ll have to do it later and report back. Does that mean that until I reboot, the Vero4k will play properly, since I have sent this command?


There’s no guarantee – as we will re-parse that EDID on a mode change.
The proper solution should be to make that change in Kodi.