HDMI Video dropout Vero4k

Hi Sam,
For few weeks now I encounter some problems with hdmi (video only). During a movie ( randomly), my projector indicates that hdmi connection is lost. During 3-4 seconds Olga is black than projector shows hdmi image and than the imagine come back.
If I push on pause button of the Vero remote control, the imagine come back directly. Only the video part is drop, the audio continue to work.

I’ve tried the same movies with my oppo 203 and never had any problem. Also tried to switch hdmi cables, but it doesn’t help.
For the moment, considering the tests I did, I suspect the problem is coming from Vero but I can’t confirm it. That’s why I would like to ask you some help.

My setup: Vero 4K - NAD t758 - Sony projector vpl260 es.

I’ve enabled the debug in the Vero 4K then ran a movie until the problem occurs
and uploaded logs here:

Do you see something that can help me?

Thanks a lot

How long is this HDMI cable?

From Vero to NAD: cable from Vero.
From NAD to Sony projector: Real cable 4m HDE evolution.
My oppo which is connected to the NAD too doesn’t seem to have that problem.

Best regards

Do you mean the cable we shipped?

Your log doesn’t show any loss of signal or HPD events beyond the standard ones when you play a file and Vero 4K adjusts refresh rate and resolution to match the source content.

It does not look like Vero 4K is losing the handshake.
Has something changed in your environment?

Yes the cable shipped.

Nothing changes except some updates from NAD to add DolbyVision.
Actually as the audio part was working, I was suspecting more a problem between the NAD and Projector. Even if I didn’t get this error with the Oppo which is also connected to the NAD, your check confirms me to search on the NAD side.

Thanks a lot for your check.

After doing a lot of tests today, I was able to « reproduce » it on my Vero 4K. Vero 4K was playing a movie and I got the problem. I set pause, and I notice that the problem continues to happen every 1-2 minutes (black screen than hdmi display on my projector than video come back). So I switch the Vero hdmi input on my NAD to the next hdmi entry… unplugged all other devices, disable all hdmi arc and cec, unplug the NAD power, … nothing changes. Than replug my oppo and no problem with video.
The next test I will perform, as soon as I’ve 5 minutes, is to switch the HDMI cable of the Vero 4K.

Just one remark: l’ve installed the hot fix for the banding issues (but not enabled the hdr auto switch). Vero power cable is plugged on a APC back ups.


Ok maybe I found something… it seems to be related to the movie.
Just watch Hostil (more than 2 hours) movie without any problem… than I’ve tested the ReadyPlayerOne again and after 2 minutes I got the problem. So I’ve put the movie on pause and every 80 seconds I’ve got the problem… Almost same behavior after swapping the hdmi cable of Vero except that after, I got a black screen and handshake 70sec than 10 sec than 60, 20, 70, 28, 57,…
So I switch to Oppo and the movie was read without any problems.
I reuploaded the logs, if you can check again


Thanks a lot… hope you won’t waste your precious time


18:59:13.138 T:4080640592 NOTICE: Disabled debug logging due to GUI setting. Level 0.

Could you please try and reproduce with debug logs enabled,

Thanks Tom.

Just retested and was able to reproduce it still with ReadyPlayerOne.
Had 2 times the video de sync than set pause during few minutes (still desync happened) than upload the log:

Never had this problem in the menu of osmc.
Thanks for your time,


Does ready.player playback locally either from usb or sdcard?

Thanks Tom.

From the network (a syno nas). Using usb to gigabit Ethernet connector.

I mean can you please try a local play back. I try determining if its a bandwidth issue or if the vero4k doesn’t like the encode. Either way there should be fix.

Thanks Tom.

Ok NP Tom,
I will try to find a ssd to connect to the Vero 4K in order to try to reproduce the problem with a local playback.


1 Like

Ok problem occurred also with local playback using ssd. And as I said the problem occurs also when the movie is in pause (no bandwidth during pause I suppose). So I really don’t know what happens here.
Logs with local Playback :



Are you only seeing this issue only with ready.player or with other videos aswell?

Thanks Tom.

Hi Tom,
Yesterday Hostile and no problem. Just saw bug life and no problem.
But not the only one… tried Kingsman after the test I did and had the same problem after few minutes. . Now switch to Oppo, no problem after 65 minutes.
This problem is not really “new” but I can now more easily reproduce it.



Have you tried a different HDMI cable?


Yes I tried yesterday but it didn’t make any improvements.


Please provide mediainfo for the problematic videos.

Thanks Tom.

We had another issue with a guy using a NAD AVR. I will ask for his model but he reported that with a direct connection to the TV the issue is resolved and it only happened after an update. He has contacted his dealer for downgrade instructions.

If you still hear audio, just don’t see video, then it’s not a drop on the Vero 4K side.