HDR Autoswitch causing issues on my LG OLED65C8


#88

I applied the update, but I don’t see any improvment. With UHD color mode enabled, the demo file still does not play. With UHD color mode disabled, the demo file plays, but with very visible banding.

Log 1 (UHD color mode enabled, black screen): https://paste.osmc.tv/igolebuyef
Log 2 (UHD color mode disabled, banding): https://paste.osmc.tv/izexoforec

/edit: I’m using the HDMI cable I got with the Vero4k. It’s directly connected to my TV (Samsung KS8090).


#89

Consider to change that cable with a premium certified one. Everything runs well now with new kernel on my LG65C8.


#90

Yes, that’s worth a try. Another thing you (@stinger5) could try is:

echo 422now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

while playing that demo vid.


#91

I tried…

echo 422now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

… but the screen remained black. I will buy a new HDMI cable just to make sure we are not hunting a ghost here.

I’ll report back once I have it.


#92

That’s a surprise. It should be 420,10bit unless you have set any values manually. Can you post a log for that, and cat /sys/class/amhdmitx/amhdmitx0/config while the vid is playing, please?


#93

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 97
VIC: 97 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV422
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

Log: https://paste.osmc.tv/agiqiveyeh


#94

Useful, thanks. You are getting 422,10-bits because you are running Leia and there is no option in Leia to whitelist a 4:2:0 mode.


#95

But Hdfury Vertex report that, it could be right…


#96

Can you remind me how that 4k60Hz clip plays with Leia if you downgrade your HDMI input (non-Ultra HD on LG?). It should come out as 420,8-bit as it does on Krypton.


#97

420 8bit says Vertex, but no image on my TV.


#98

cat /sys/class/amhdmitx/amhdmitx0/config while blankscreened, please.


#99

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 0
VIC: 0 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
EOTF: SDR
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off


#100

OK. More work to do to deal with Leia’s whitelisting. Can you post a debug log for that scenario, please?

And confirm whether it’s different if you restart Kodi or reboot after turning off the Ultra HD mode. ie start vero with Ultra HD mode -> turn off Ultra HD -> play clip may be different from
start vero with non-Ultra HD mode -> play clip.

Thanks for your help.


#101

I have similar issue since october update:
Each time i try to read 4K hdr streams, blackouts are occurring randomly and repeatedly on my display (Panasonic oled CZ950).
And, even worse, i have some white points flashing randomly on the screen.
Tried to switch hdmi cables and it is still happening.
GUI is set at 1980p and adjust refresh rate at “always” (same occurs if set at “stop/start”).

Reading 1080p streams is fine so far.


#102

Not enough information. Running Krypton(17) or Leia(18)? Is your HDMI input set to Mode 1 or Mode 2? What framerate are the problem vids?

It’s best if you can post a debug log.

I read somewhere that white points flashing randomly can indicate a flakey cable. Are you sure you have tried a ‘premium’ cable?


#103

My hdmi input is set at auto.
Problem is occurring with 4k/HDR/24p mainly, though i could see it happen (blackouts), but at less rate, with 1980p content.
Yes, i switched with quality hdmi cable and same anomaly is seen.
And i don’t know what are “Krypton(17) or Leia(18)” ?

I just tried the hotfix linked a few posts before and playback is back to normal for 4K streams, which is great.

Anyway, i would be interested in a step by step guide on how to provide logs (im no technical expert):
Is there a post on this ?


#104

Yes, in that very occasion Vero started to play correctly after a complete reboot (TV and Vero itself). I’ve also forgot to report that the TV, with HDR files, turn ultra option on automatically, giving an advice before


#105

Have you tried settings other than auto?


#106

No, i didn’t try to switch modes but as i dived a bit more in the hdmi set up, it seems it is on “Mode 2” (auto mode seems a misleading menu name…).


#107

What is the difference between mode 1 and mode 2?