HDR Autoswitch causing issues on my LG OLED65C8


#108
  • Mode1: 4:4:4 / 4:2:2 (30p, 25p, 24p), 4:2:0 (60p, 50p).
  • Mode2: 4:4:4 / 4:2:2 (30p, 25p, 24p), 4:4:4 / 4:2:2 / 4:2:0 (60p, 50p)

#109

Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Indeed. It’s not ‘auto’ at all if it’s like my Panasonic.

If you need to ask, you are on Krypton. Leia is the next version of Kodi which is in beta testing atm.


#110

Thanks for that clarification. We do love a moving target. :unamused: Does it turn off the ultra option as the video finishes?

Is there any way to turn off that automatic switching?


#111

No it doesn’t, the ultra option remains active after that.
I don’t think so: there is only one switch dedicated to ultra hd deep color, so…


#112

TLDR (I did skim though)
I was considering purchasing the LG OLED55C8 since Costco has a good price on it right now.
My OSMC works perfectly with HDR Auto Switching enabled and Adjust Display refresh Rate on “Always” with my TCL TV.
I had to change a setting in my TV to tell it to use HDMI 2.0 mode, that was it.
My Vero 4K+ is on OSMC 2018.10-1 (kernel): Linux 3.14.29-126-osmc / Kodi 17.6

Should I expect any issues if I get this TV or is everything resolved now?

EDIT: I just checked my settings and I don’t see the HDR Auto Switch option anymore.


#113

It’s a top priority at the moment.


#114

Hi Graham. I have tested the new kernel but it’s only made a slight improvement - still most of the vids don’t play. Here is the log: https://paste.osmc.tv/ezilavivux

Here is the output for the ‘Samsung travel with my pet’ file with no signal on the TV (at 21:43:23 in the log):
cur_VIC: 353
VIC: 353 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV420
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

I have no specific file that will ‘never’ play - they all play sometimes. I tried the echo 422now command but it didn’t make any difference.

Just for info I have the Vero going direct to LG C8, then sound out via ARC.


#115

We’ve had some success forcing 10-bit at startup with echo 10bit > /sys/class/amhdmitx/amhdmitx0/attr in rc.local. Can you give that a try?


#116

No difference I’m afraid…


#117

Okay, so I tried this cable:

http://www.oehlbach.com/en/detail/index/sArticle/321
(horribly expensive, for a damn cable…)

But: No dice. Screen stays black if UHD color mode is enabled. Not really suprised, to be honest.

UHD color mode off:
cur_VIC: 353
VIC: 353 3840x2160p60hz
Colour depth: 8-bit
Colourspace: YUV420
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off
(works, but looks shitty)

UHD color mode on:
cur_VIC: 353
VIC: 353 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV420
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off
(doesn’t work)

Is there anything else I can try?


#118

I don’t know what to say man, I have the same model 65" variant, same box (vero 4K+) and the latest kernel works very good in my case. I’ve also run flawlessly WORLD IN HDR IN 4K that gave me blank screen with the previous one.


#119

Hi folks, just to add my experience. I found also one 4k stream turning into no signal when refresh rate is set to always (or on start/stop). If video stream was 2.40:1, 3840x1600, it resulted in signal lost (~7GB 4k Movie). With 1.78:1, 3840x2160 it was ok (40GB 4k Movie). Also Vero 4k+ and LG OLED C8. Hope it helps…


#120

Thanks, all for the feedback. Still tearing my hair out with this one.


#121

@grahamh Let me know whatever you need. Glad to help you…
Edit1:Btw. is it possible to whitelist/blacklist resolutions? So it would upscale to 3840x2160 from 3840x1600? Maybe LG C8 cannot display it.
Edit2: 3840x1608 works well :joy:
Edit3: there has to be something with custom picture settings in LG. I played with settings and HDR that worked well stopped working. I did reset settings in LG TV and it played! Well well well, something weird is going on with LG…
Edit4: the one that played, then not, then reset display settings in LG and worked was the one with 3840x1608. 3840x1600 never worked with auto refresh rate.


#122

So should I assume my Vero 4K (not +) is broken? :confused:


#123

It’s unlikely to be a hardware issue; unless you’re experiencing problems that you believe support this.

Can you post a log so we can see more details?
Have you tried downgrading using the hotfix? This isn’t ideal — but should fix things for you in the interim


#124

Hi Sam,

I posted logs here: HDR Autoswitch causing issues on my LG OLED65C8.

Do you need any other logs? I’ll gladly provide them.

I tried downgrading (not using the Hotfix, I re-installed an older version). While more files play in UHD color mode, they still look bad (banding). I would guess that Oct. update with UHD color mode disabled == Aug. update with UHD color mode enabled/disabled.


#125

Anyone with an LG C8, can you try playing some of the vids from this page: https://4kmedia.org/ ? Specifically ‘Samsung: Travel With My Pet’, ‘Sony: Swordsmith’ and ‘Life Untouched’. Try playing them a few times even if it works the first time.


#126

I’ll download it and let you know…


#127

It was cable. The one shipped with Vero works. Other (high speed) were causing issues with all 3 videos… Thx, really good tshooting step.

Edit: walking dog has 50% success rate. I just played another and went back to walking dog and it was OK…

Edit2: we need proper cable… https://www.spacehifi.com.au/hdmi-cable-guide
Edit3: I ordered HDMI 2.1 cable to definitely rule TV and Vero out. will update this thread once I get it.
Edit4: I got hdmi 2.1 https://www.secomp-international.com/en_US/roline-hdmi-8k-7680-x-4320-ultra-hd-cable-ethernet-m-m-red-2/i/11.04.5902-10/catalog+1?source=L3NlYXJjaC9pdGVtcz9xPUhkbWkrY2FibGUmaGlkZT1maWx0ZXJfNiZmaWx0ZXJfMjk9cmVk and it still sometimes happen that tv switches to no signal with the sample videos. I guess it’s bit less chance to not to work than with bundled HDMI. But it looks ridiculous - like Kensington behind TV :grin:


My journey to Vero 4k+