HDR Autoswitch causing issues on my LG OLED65C8


#128

I have tried it with 4 different cables, one of which is premium certified. Makes no difference.

Strangely now I cannot get any 4K file to play at all. So I have had to use Sam’s hotfix to roll back the October changes and now all the files play straight away.

Sam - is there a way to get back to the ‘vanilla’ Oct update (before Graham’s latest update) or do I have to completely re-install and then load a backup?


#129

You can run sudo apt-get install --reinstall vero364-image-3.14.29-126-osmc and it should downgrade you.

Sam


#130

I finally managed to take some time to test vero364-image-3.14.29-128-osmc on my LG 65C8.
Note that I am on krypton (not leia) and the Vero 4k is plugged into a soundbar (LG SK10Y) plugged into the TV.

No forcing to /sys/class/amhdmitx/amhdmitx0/attr --> works fine (HDR OK, no banding, …) except sometimes the TV shows the “no signal” screen and I need to relaunch the video.

Forcing 10bit --> basically the same
Forcing 422now --> basically the same


#131

Thanks for testing

Can you remember what was attr at that point and what video you were trying to play?


#132

Well several videos and different attr…

I just made another few tests. Ran the “Planet Earth II” sample (Test-2160p.HEVC.HDR.DTS-HD.MA.mkv, 15mn long, that I got from the kodi “Samples” wiki IIRC).
I get the “No signal” randomly, 1 out of 7-8 launches. Nothing forced to attr.


#133

OK. I enabled logging, rebooted the device and ran the same sample video (“Planet Earth II”) roughly 10 times.
The first few runs were fine. When I stopped the video after run #5 (or #6 maybe), the TV showed "No signal instead of KODI’s main menu for a couple of seconds, then the main menu showed up.
I kept on going for another few runs (I’d say +/- 5) until the TV showed the “No signal” instead of the video. Then I captured the logs (grab-logs -A -C), and uploaded them: https://paste.osmc.tv/okelaxosob

Hope that helps.

NB: Nothing forced in attr


#134

Thanks. We’ll have a look. Do you see any difference if you connect vero direct to the TV and/or swap the cables around?

I’m slightly worried that your EDID through the soundbar is reported as MaxTMDSClock2 450 MHz but a C8 should report a 600 MHz clock.


#135

So I have done some more playing around with the latest kernel and have discovered that the length of the cable seems to be causing the problem. All the cables I tested with previously were 3m long, as I need to use this length due to having the TV mounted and trunking in the wall. But I just tried it with the short cable that comes with the Vero and (almost) every 4K file plays first time. I then tried an older 2m cable and the success rate went down but still better than the 3m.

It’s like the Vero isn’t sending a strong enough signal for the length of cable. Which is strange as when I used Sam’s hotfix to roll back the October changes the files played fine with the 3m cable.


#136

FWIW I can play 4k videos at 444,422 or 420 and 8 and 10 bits on my Panasonic through a 6m long cable I bought for £12 in Sainsbury’s. Branded Blaupunkt.

AFAIK, nothing about the HDMI PHY has changed since August but we’ll check again. Thanks for the feedback.


#137

No changes in this regard.


#138

Still no improvement with latest kernel. Once I switch to 10 bit, all I get is a black screen.

Should I just return my Vero4k and buy a Fire TV stick? :/.


#139

Not yet, but this is proving a puzzle. With latest kernel (129) I do believe everyone else’s issues come down to bandwidth limitations of cables and/or some way in which their AVR is mangling the EDID from the TV.

Please post logs again with the latest kernel. Start with UHD color off, play a 4k60Hz vid, then turn on UHD color and play the vid again. Also post the output of cat /sys/class/amhdmitx/amhdmitx0/config while playing the video.

If you get a blankscreen, does echo now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr (issued while it’s blank) restore it?

As a reality check, can you confirm that 4k60Hz vid plays at 1080p, 10bit, by turning off adjust refresh rate.


#140

Logs: https://paste.osmc.tv/yahoqicowo
(in the order you described)

Started with UHD color off, 4k60fps file played:

cur_VIC: 353
VIC: 353 3840x2160p60hz
Colour depth: 8-bit
Colourspace: YUV420
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

Turned UHD color on, same 4k60fps file only showed a blank screen:

cur_VIC: 353
VIC: 353 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV420
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

Issuing the command “echo now | …” didn’t fix it. The same movie plays with adjust refresh rate turned off:

cur_VIC: 16
VIC: 16 1920x1080p60hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

I’m somewhat postive the same file didn’t play in 1080p with the previous kernel, if that is of any help.

No AVR, tried the cable that came with the Vero4K and that Oehlbach cable (Premium UHD certified).


#141

All of that tells me vero is doing exactly what it’s supposed to do.

I would be very surprised at that. It might have played with 8 bits.

Now we have to ask if you are able to get a 4k10bit picture on that TV with any other device attached through HDMI. (Playing a file through USB doesn’t count, but if that doesn’t work, you really are in trouble!)

Your TV seems to have an obscure setting called ‘HDR+’. Presumably you have tried that both ways.


#142

Yes, it did play with 8bit in 1080p with the previous kernel. It now plays with 10bit in 1080p.

I will try to hook up my GTX1060 to my TV and see if it plays the 4k60fps file in 10bit. Gotta carry my desktop around, it seems :sweat_smile:.

Playing from USB/from NAS through DLNA works fine. Enabling HDR+ makes no difference.


#143

Not sure if you wanted this from me Graham but I’ll do it anyway.

UHD colour off (video plays):

osmc@Vero4k:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 353
VIC: 353 3840x2160p60hz
Colour depth: 8-bit
Colourspace: YUV420
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

UHD colour on (black screen / no signal):

osmc@Vero4k:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 353
VIC: 353 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV420
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

The echo now command didn’t do anything.

This is playing with adjust refresh rate off:

osmc@Vero4k:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 16
VIC: 16 1920x1080p60hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

Here is the log: https://paste.osmc.tv/ihalebuwuj

Out of interest, is there a way to force the GUI to 420 10bit?


#144

echo 42010bitnow | sudo tee /sys/amhhdmitx/amhdmitx0/attr

but only if you have set the resolution to 2160p60Hz first. You will probably find just trying to set that resolution gives you a blank screen, since 420,10bit is the default.


#145

Okay, hauled my TV to another room, connected it to my PC and this the result:

So while 420 10 bit is somewhat (:joy:) pink, it works. 422,10/12 bit @ 60Hz works perfect. No visible banding in my usual demo. RGB 12 bit @ 24Hz works perfect, too.

This is with the most recent MadVR using mostly default settings. Forced the display modes in NVIDIA control panel.

For some reason though, Vero4k can’t seem to do this. OliC seems to have the exact same problem so I’m confident that the problem is not on my side but some strange interaction between Samsung and Vero4k.


#146

Thanks for that! It’s difficult to read, but I wonder whether the clock deviation of (?) 0.1% in the 420,10bit (pink) case is significant. The others are at least an order of magnitude better.

Is that information printed by the TV or the graphics card?

Olic’s is a LG.

We haven’t managed to test 422 at 2160p60Hz on LGs or Samsungs yet. I’m hoping @obstler42 will do it, but you could try the same instructions I gave him. On Nvidia at least 422 seems to be working better than 420.


#147

madVR prints that.

I tried the commands, here are the results:
echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr
-> Switched to 8 bit. Works.

echo 2160p60hz | sudo tee /sys/class/display/mode
-> Switched to 8 bit, 420. Still works.

echo 2160p60hz420 | sudo tee /sys/class/display/mode
-> Already was there, so no change. Still works.

echo 42210bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr
-> Switches to 10 bit, 420. Black screen.

I can’t seem to force 422. It doesn’t seem to stick, even if I try…
echo 422 | sudo tee /sys/class/amhdmitx/amhdmitx0/attr
… config always stays at:

cur_VIC: 353
VIC: 353 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV420
Colour range: limited
EOTF: SDR
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

I bought a Fire TV Stick 4K (hurray Cyber Monday). But I still like my Vero4k and really want it to work.

Oh and one more thing:
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

A 4k24fps movie… guess what? Black screen. Same movie as the last screen, where it played in 12 bit, full RGB.