HDR Autoswitch causing issues on my LG OLED65C8


#175

My UHD 4K TCL TV works just fine with all files, but of course is not as nice looking as the LG.


#176

@Kontrarian Are you using hdmi that shipped with Vero? That worked fine for me.


#177

I turned off Adjust Display Refresh Rate and everything UHD HDR 4K works now.

My cables are fine.

If you have an LG C8 try disabling “Adjust Display Refresh Rate” in SETTINGS > PLAYER > PLAYBACK.


#178

Keep it auto and try hdmi cable shipped with Vero. Trust me…


#179

Tried Auto with HDMI that came with Vero and it didn’t work.
Turning off “Adjust Display Refresh Rate” is not a real solution though.
I just discovered that with it off the player outputs it at whatever you have the OSMC interface at.
So it was outputting it at 1080p but still with HDR, so it tricked me there for a second.
I saw the HDR badge pop up and the video play so I got all excited… SMH.
But still, it’s a work around until this issue gets resolved.
Better to have 1080p HDR than not be able to play 4K files at all.
Oh, and I tried setting the interface to 4K and leaving “Adjust Display Refresh Right” off and I lost signal right within OSMC.


#180

To narrow down the problem, can you try videos reffered here? HDR Autoswitch causing issues on my LG OLED65C8

My hdr disconnected problems were reduced when 2.1 cable was used (~20$)


No signal with UHD/HDR (LG C8 & Marantz SR6010)
#181

I’m sorry, I don’t see any videos in the link you provided.


#182

Ups. Here you go. HDR Autoswitch causing issues on my LG OLED65C8


#183

Yeah, I already have all those files in a Demo folder along with the Jellyfish.
None of them play “Adjust Display Refresh Rate” on.
I tried the HDMI cable that came with the Vero too.
Nothing works.


#184

Are you under the impression that the HDMI that came with the Vero is 2.1?


#185

BTW, If I put any of these demos on a USB stick and plug them in to the TV they play just fine.


#186

There will a fix for this in a few days. Sticking with 1080p GUI and adjust refresh rate off will give you a picture in the meantime.


#187

@Kontrarian The cable that ships with Vero is 18Gbit HDMI (2.0). I bought 2.1 just to rule out cable issues. It helped for me (a bit) :).


#188

To add to the feedback (and confusion) here. I just setup my new LG OLED65C8 last night, and every HDR video I tried last night worked great. Probably played 10 different videos (some multiple times).

I am on the latest dev release. I did ensure I used a Premium Certified cable. I am going Vero 4K -> Onkyo 676 -> LG C8

I can provide some logs with specific tests tonight if needed.


#189

One thing we may have to gather is firmware version.

Thanks, but if you are able to play 4k24Hz and 4k50/60Hz videos at 10 bits (no banding) that’s enough for me!


#190

I am on 04.10.06 (the latest).

Wasn’t any banding that I noticed… everything looked great.


#191

The latest is 4.10.10


#192

I want to test this again tonight. Can anyone suggest a video/timestamp that shows banding if 10-bit is not being received?


#193

The World in HDR - a few seconds in - sky over the skateboarder.

or there’s a clip from Revenant floating around. I think it’s at the start (never seen the whole film)


#194

Okay, more news:
So my 2nd cable to try arrived today. My FireTV Stick 4k did, too. But luckly (after spending around 10mins with it), I won’t have to use it.

FireTV Stick 4k plays the Demo perfectly fine, no banding (with Kodi). After that, I plugged in the cheap Amazon Basics HDMI cable and tried again with Vero4k… and guess what? It worked!

Not sure why the Oehlbach failed me, or why the cable included with the Vero4k failed me… but that cheap fucker from Amazon seems to work :).

I will continue a few tests. From my initial testing I can tell that it blackscreen’d with 422, 10bit @ 4k/60fps. But it seems to run fine with 420, 10 bit @ 4k/60fps.

cur_VIC: 353
VIC: 353 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV420
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

Very happy. But a bit confused, nonetheless. I will do some more testing this weekend.