HDR Banding issue

If I find it necessary, I will do just that.

@sam_nazarko… is the Banding Issue now fixed in the latest march build ? For the first time i see also Banding in “Despicable Me” with the first march build!

Not yet.

We know how to resolve this now but there is a timing issue which is preventing us from fixing this without manual intervention. Rest assured – this is being worked on promptly and once I have some progress I will make it available here.

Sam

So what is the best manual intervention at this time? Start the movie and type

echo round1 >/sys/class/amhdmitx/amhdmitx0/debug in the shell

doesn´t work for me, the banding at blue sky in “Despicable Me” isn´t gone…

  • Are you in 10-bit mode?
  • Is the film HDR?
  • Did you run this as root?
  • Is your device up to date?

Does dmesg show feedback after you run this command?

Are you in 10-bit mode? --> the 2018.02-1 update has the “echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/attr” command build in?! i have this also in the rc.local!

Is the film HDR? --> yes!

Did you run this as root? --> yes!

Is your device up to date? --> i have installed the 2018.02-1 (not the 2018.03-2 update) - does the command " sudo echo round1 >/sys/class/amhdmitx/amhdmitx0/debug" also work with this build?

Does dmesg show feedback after you run this command? --> what feedback? After type in this command the only feedback is a new line in the shell…

You need to update. Then you should see some effects

Ok… will do that… is there any way to automate the command via startscript or something? To start a movie in the homecinema, put on the pc, logon to the vero and type in the command every movie again isn´t very usefull!

And is the 10-bit command in the rc.local also necessary after install the february or march update?

Well I assume this is exactly doing that.

I have to type in this exactly in the shell and this made the necessary script?:

#!/bin/bash
sleep 5
echo round1 >/sys/class/amhdmitx/amhdmitx0/debug

Sorry for the question, i´m not a shell or linux speci…

I guess it is best to wait for @Martorias to give you some help. But from what I understand is you copy that 3 lines into a script and you call that script via kodi callbacks

Ok… i think for most vero users with the banding problem is it very usefull when someone tell us what we have to do to write such a kodi callback script…

Hi. Yes I put those lines in a file “round.sh”
Make it executable “sudo chmod +x round.sh”
Create a task in kodi callbacks to execute said script (browse it)
Create event on playback start to run that task.

I can make a better guide when I get home if you’d like as I think you can just execute the oneliner straight from callbacks without the need of a file

2 Likes

This will be great, thank you! :slight_smile:

Just received my vero 4k, using it with my Lg C7 oled. I’m also having problems with HDR color banding with HDR material. I did set the 444, 10bit mode as below, but did not help with this problem. The problem seems to with all HDR material with similar specs as described below.

Media info:
ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L5.1@High
Codec ID : V_MPEGH/ISO/HEVC
Duration : 2 h 19 min
Bit rate : 66.6 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0 (Type 2)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.335
Stream size : 64.8 GiB (87%)
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : SMPTE ST 2084
Matrix coefficients : BT.2020 non-constant
Mastering display color primaries : R: x=0.680000 y=0.320000, G: x=0.265000 y=0.690000, B: x=0.150000 y=0.060000, White point: x=0.312700 y=0.329000
Mastering display luminance : min: 0.0000 cd/m2, max: 1000.0000 cd/m2
Maximum Content Light Level : 1000 cd/m2
Maximum Frame-Average Light Level : 321 cd/m2

I did run these using SSH:
osmc@vero4k:~$ echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/attr
444,10bit

osmc@vero4k:~$ cat /sys/class/amhdmitx/amhdmitx0/hdr_cap
Supported EOTF:
Traditional SDR: 1
Traditional HDR: 0
SMPTE ST 2084: 1
Future EOTF: 1
Supported SMD type1: 1
Luminance Data
Max: 0
Avg: 0
Min: 0

Why does the EOTF traditional HDR have value 0? Is this what causes the problems?
Still the TV does recognize the signal to be HDR and having BT.2020 color space.

I’m using 2.0a certified hdmi cable and having ultra deep color mode enabled on tv. With this HW I have previously played these same clips on Xiaomi mibox Kodi successfully without any color banding.

Are you in 10-bit mode? -->Should be as noted above.
Is the film HDR? -->Yes.
Did you run this as root?–> I did run this after SSH login: “sudo passwd root”, told me to change pw and after that that pw changed. So I guess so?
Is your device up to date? Everything installed, says no new updates ATM.

Any suggestions what to try next?

Banding will be fixed shortly. There is currently a workaround but we would prefer to resolve this properly

1 Like

Just a heads up Martorias, I was getting inconsistent results using the one line command in callbacks. Ended up using the script above with sleep 1 instead of sleep 5. Placed script in /home/osmc as I wanted it local as opposed to somewhere on the network. Working solidly now.

Right good to know - were you using the sleep inside the one linser or just the echo?

Just the echo line. I found it didn’t work consistently so I did as you suggested and made the script. There may be a need for the sleep variable so it would appear the script method is the best workaround.

Ok thanks, Ill do some tests after dinner and see if I can make a beginner friendly guide until Sam figures it out :slight_smile: