HDR-issue with 2017 LG OLEDs or with the Vero?

Kodi has no knowledge of HDR, beyond some early support for Intel in v19. HDR is handled by IP in the display pipeline.

I’m on the latest official OSMC, and my firmware for the TV is 05.80.35 (USA). Happy to help figure this out, - something is clearly going on here.

Sam, is there any difference between the way the Vero 4K and Vero 4K+ behave in this regard?

No. I just checked both tests on a Vero4k (non-plus) running 3.14 kernel and got the same result on my Panny (both flashing to 2000nits although the metadata being sent is 1000nits for both.

The Vero 4K and 4K + are both GXL based chipsets, so will behave identically in terms of video playback.

@WilliamG Just to confirm, can you try the 2000nits file (should flash to around 81%) and the 4000nits file (should flash to somewhere past 84% depending on your individual display and settings). And if it’s not too much hastle, maybe connect the Vero directly to the TV. Maybe the soundbar is doing something, which I doubt but I’m out of ideas on what else it could be that’s causing this.

My friend with the Vero 4K+ and a C7 55" has the same issue as me.

@HDRpotato could you post debug logs for interest?

Here you go:

Unfortunately, I’ve already restored my backup so it’s not from the clean install I tried yesterday. So it’s a little cluttered.

1 Like

sorry, can you make it full logs - want to see the raw edid (from kernel messages)

Also, we do print the metadata being sent.

My mistake, sorry.
Here you go: http://paste.osmc.tv/utulojaser

1 Like

Remind me whether you have tested this with Vero plugged in direct to the TV.

I have. Also tried different cables (just in case). Also connected it directly to the TV when I completely wiped it yesterday and changed nothing in the fresh install except for “Adjust display refresh rate” so that it actually changes resolution etc.

Ok so sh*t got weird.

Peculiarly, my C7 didn’t switch to HDR when loading that 2,000 nit file. I had to reboot the Vero (2,000 nit was showing everything flashing up to 100).

After a reboot, 1,000 nit is still behaving and displaying flashing up to about 75.

2,000 nit file is ALSO showing flashing up to around 75.

4,000 nit file is ALSO showing flashing up to around 75.

So all three files are behaving the same for me on my C7.

So, uh… wtf?

1 Like

@grahamh Can you check line 4088 in my log? It says Luminance max is 0 when it tried to start the video or am I reading it wrong?

My first suspicion was that your soundbar somehow maybe “falls back” to 1000nits, for whatever reason. That’s why I wanted you to double check with the Vero directly connected to the TV to make sure this is not the case.

yeah just found that. Investigating.

1 Like

The min luminance is also incorrect in the logs (0.050cd/m²) but the file is actually 0.0005cd/m². It actually says “codec: No master display info” above. But you probably already saw that.

Yes, I don’t know why that print is wrong. It’s the same here. But vertex is saying 1000 and 0.005 on a random HDR clip. The codec message is ‘correct’. That’s the issue we’ve had with 3.14 - codec not always reading seis.

That wasn’t the issue. What was the issue was I was using HDR Cinema Home (User) instead of my calibrated HDR Cinema (User). With HDR Cinema Home (User) all three files show till about 76, as stated above. With my calibrated HDR Cinema (User), which is how I watch movies, all three files show till about 86-87.

I went directly to the TV just now, and results were the same. Is that what you’re expecting?

1 Like

Cinema Home has Dynamic Tone Mapping, Dynamic Contrast and Dynamic Colors enabled by default. But you said you had all of that disabled. I’m guessing you had it disabled for Cinema, not Cinema Home? That would make sense then as Dynamic Tone Mapping (aka “Active HDR”) alone just completely ignores all of the HDR metadata in favor of its own frame-by-frame analysis AFAIK.

Yep, it’s not working on your TV either and it just tonemaps everything to 4000nits (the fallback on LG OLEDs). Guess you’re one of us after all :smiley:

Yes to all the above.

Interestingly, I tested just using the TV’s own video player, and got some whacky results. 1,000 is showing till ~86, 2,000 is showing till about 82 (with a weird double flashing thing going on once the scrubber bar disappears) and 4,000 is 88-89 with the same double flashing thing going on.

I don’t even know what to think now.

Weird. For me the internal player plays all four of them correctly. Are you sure you switched to the Cinema/technicolor preset on the internal player? It has its own presets, just like every HDMI input source.