Help Playing 5.1 audio file

Hi, I’ve been trying to get 5.1 audio file to play in 5.1.
I’ve tested Ogg, Mka, and Flac but they all seem to play in stereo.

I have RPI2 and hifiberry digi. Passthrough enabled (although passthrough device says HDMI and greyed out so can’t change it)
Movies play fine in 5.1 though so must be using hifiberry.

I read that they needed to be played by the video player to get 5.1 so followed the instructions here: Kodi: Adding support for Atmos, TrueHD and DTS:X, DTS-HDMA audio only files | QuadraphonicQuad

Add a new text file to Kodi’s userdata folder:

File named: playercorefactory.xml

-deleted code-

I added the file but now all the test files play with no audio and osmc crashes when I stop playback.
I deleted the playercorefactory.xml file but still get no audio and crash when I stop playback. :frowning:

Did you remember to restart Kodi after deleting playercorefactory? A log may be helpful in assisting you.

Yeah restarted, mp3’s play fine but two 5.1 audio files (ogg,mka) which I added to the playercorefactory.xml file are silent and (sometimes) crash osmc.

I forgot I was using a clean install of osmc, movies do not play with sound, hifiberry isn’t setup right for passthrough which is why passthrough device only shows hdmi and I can’t choose hifiberry.

I found this thread which seems as though there’s a bug in the kernel.

Soundcard overlay is set to hifiberry-digi-overlay
Audio output device only has snd_rpi_hifiberry_digi analog

There’s no snd_rpi_hifiberry_digi SPDIF option.

Just tried my old SDCard with 2019.07-1 (kernel: Linux 4.14.78-4 ) and it plays the 5.1 files in 5.1 with no code edit needed so will wait for update.