Help please connecting to nas mediaserver

I am trying to connect to and play media which are served either by a media server, minimserver or Twonky, running on a NAS on a different subnet from the subnet on which the Vero5k is connected by copper.

I have no idea what obstacles such as firewalls lie between these devices and am controlling the Vero4k with a remote. The NAS also has UPnP enabled for Twonky but also has nfs server and samba available.

Where do I start with getting this connection to work please?


Can the vero4k ping the nas?

If you can’t, I suggesting find this out. As you may need to add firewall rules or static routes to make this work.

Regards Tom.

Hi Tom, Sorry to be dense but I had been hoping I could work just using the remote.

My computer and the NAS are on my “private” subnet and the Vero4k is on a different subnet but I can ping all relevant devices from my console and having ssh into the Vero I can ping the NAS from the Vero and have ssh control.

My next question is can I set up the connection to the NAS and what tools should I use. Is there any documentation to which I can refer? I need to read up a bit and then I should be able to manage.

Hi fzinken, many thanks for the reading material. I may have gone down a few rabbit holes and still need help.
In the end and having followed some of the threads I thought I would try and enable autofs. Having installed autofs I made a mess of things following the instructions and have not been successful so far.

I then tried using configuring fstab based NFS share mounts and had more success. I just hope my nugatory efforts with autofs have not messed up my system. I was able to follow the directions but when I tried to open inside the mounted directory I couldn’t open it and received a Permission denied.

What should I do now to try and get this working please.

You wrote fstab is working so what is the issue?

I have found my error in autofs so am getting part of this working so I have all my attempts visible:-

/mnt$ ls  alastair  Multimedia  QnapNAS2_Videos

I do not know why alastair is there but the other three are my attempts. If I drill down I get the following:-

mnt$ ls  alastair  Multimedia  QnapNAS2_Videos
osmc@osmc:/mnt$ cd
osmc@osmc:/mnt/$ ls
osmc@osmc:/mnt/$ cd Multimedia/
osmc@osmc:/mnt/$ ls
Music  Photos  Videos
osmc@osmc:/mnt/$ cd Videos/
-bash: cd: Videos/: Permission denied

So I have two problems, the Permission denied and then getting the mount to be visible and accessible on the screen. BTW should I have the mounted directory ending with a / or not?

OK I now have been able to browse and find my Multimedia directory and the three subdirectories, Music. Photos and Videos but cannot access them. Clearly a permissions setting somewhere but not found the problem on the NAS yet.

Looking at the situation on the client machine in /etc/ I have:-

-rw-r--r-- 1 root root      65 Mar 18 13:25 auto.nfs.shares

I had set NO_ROOT_SQUASH but this might be wrong. I have tried all options but cannot access any of the nfs shares on the client. How do I correct this please?

Ok, I think we have to check quite a few topics. Please post here the output of the following:

  1. showmount -e
  2. cat /etc/fstab
  3. cat /etc/ /etc/auto.master
  4. cat /etc/auto.nfs.shares

Many thanks. Here is what I have from the Vero 4K:-

alastair@HP-Z640-1:~> ssh osmc@
osmc@'s password: 
Linux osmc 4.9.269-24-osmc #1 SMP PREEMPT Sat Feb 18 00:49:11 UTC 2023 aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Mar 18 19:15:21 2023 from
osmc@osmc:~$ sudo showmount -e
Export list for
/Network Recycle Bin 1  
osmc@osmc:~$ cat /etc/fstab
# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0
# UUID=64A5-F009 /mnt/alastair exfat rw,users,uid=1000,dmask=000,fmask=000,nofail 0 0

osmc@osmc:~$ cat /etc/ /etc/auto.master
cat: /etc/: Is a directory
# Sample auto.master file
# This is a 'master' automounter map and it has the following format:
# mount-point [map-type[,format]:]map [options]
# For details of the format look at auto.master(5).
#/misc  /etc/auto.misc
# NOTE: mounts done from a hosts map will be mounted with the
#       "nosuid" and "nodev" options unless the "suid" and "dev"
#       options are explicitly given.
#/net   -hosts
# Include /etc/auto.master.d/*.autofs
# To add an extra map using this mechanism you will need to add
# two configuration items - one /etc/auto.master.d/extra.autofs file
# (using the same line format as the auto.master file)
# and a separate mount map (e.g. /etc/auto.extra or an auto.extra NIS map)
# that is referred to by the extra.autofs file.
# If you have fedfs set up and the related binaries, either
# built as part of autofs or installed from another package,
# uncomment this line to use the fedfs program map to access
# your fedfs mounts.
#/nfs4  /usr/sbin/fedfs-map-nfs4 nobind
# Include central master map if it can be found using
# nsswitch sources.
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
/- /etc/auto.nfs.shares --timeout 20 browse

osmc@osmc:~$ cat /etc/auto.nfs.shares


This looks all good. What is the NAS you are using?
Have you tried without NO_ROOT_SQUASH?

I am using a Qnap NAS, quite an old model a TS 559 Pro II which only has nfs v2/v3.

The options I have on the system are ALL_SQUASH, NO_ROOT_SQUASH and ROOT_SQUASH. I believe the correct setting should be ROOT_SQUASH to prevent the client trying to edit the shared files but this only refers to scripts and I have tried all three options; so far no joy although I didn’t reboot so perhaps that is needed.

What about the last / on each setting? Does it make a difference and what should it be?

BTW many thanks for the original link. Excellent help and just sorry I couldn’t make it work. I chose autofs because although the NAS runs all the time, that is not true for all the clients. I have returned to working with the Vero after a couple of years out of use and had forgotten much, (an age thing possibly!) However as I recall using the remote and trying to find the audio from minimserver and video from Twonky had been OK but alas no longer seems to work of I have forgotten how, hence my going back to basics.

Did you check the QNap section here ?

There are no allowed IPs or domain names on the right side of the share folders, means the QNAP is not configured to allow NFS access to any of these paths.
Look in the QNAP device GUI where you can configure the NFS access of a share folder by entering an allowed IP address or an DNS name of the client.

I’ve a Synology NAS and configured there to allow ALL clients in my home intranet to have access to some shares. As an example the showmount -eoutput shows here

~# showmount -e
Export list for

The value on the right side of the shares means all IPs - are allowed to have access.

Again thanks. I hadn’t seen that before and quite a bit to do but am still trying to follow. Meanwhile I note that the Vero 4K id is unremarkable:-

osmc@osmc:~$ id
uid=1000(osmc) gid=1000(osmc) groups=1000(osmc),4(adm),6(disk),7(lp),20(dialout),24(cdrom),29(audio),44(video)

And the configuration of the NAS also seems reasonable for a start:-

[/etc] # cat exports
"/share/MD0_DATA/Public" *(rw,async,no_subtree_check,insecure,no_root_squash)
[/etc] #

I am not familiar with the no_subtree_check and am still looking for my “deliberate mistake”.

What is the IP of your Vero? Earlier you wrote it is in a different subnet?!

Thanks for the reply and I can see the difference but do not yet know why. It is possible that Synology differs from Qnap and I have been using the Qnap GUI until I saw the fzinken link. Still studying it now but will use ssh and cli for the details given in fzinken’s link.

Hi, the subject vero is on lan on my private subnet with dhcp and the present address is as in:-

type or paosmc@osmc:~$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether c4:4e:ac:14:e7:44 brd ff:ff:ff:ff:ff:ff
    inet brd scope global eth0
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether cc:b8:a8:ba:c7:d8 brd ff:ff:ff:ff:ff:ff
    inet brd scope global wlan0
       valid_lft forever preferred_lft forever

The wireless connection has been disabled on Vero GUI so not sure why it is still there and UP but device had been used with wifi connection not long ago and might have picked up the old SSID. What is command to turn off wifi in vero please? ifconfig wlan0 down was not permitted.

I have been through the Qnap info you sent but have not yet saved the backup configuration as it still doesn’t work.

Still trying to get my mind around NO_ROOT_SQUASH which as I understand it means that the nfs client connects as root. Is that what is happening when I use the remote control?

Interesting but the id of the NAS is:-

[/] # id
uid=0(admin) gid=0(administrators) groups=0(administrators),100(everyone),101(errichel_group)
[/] # 

Not what I expected.