Help please - install issue

Hello!

Noob here so I apologise in advance for the daft questions but I’ve been trying for a few days and haven’t been getting anywhere with this yet :frowning:

Long story short - I can’t seem to install OSMC for my Raspberry Pi (1st gen). I’ve used the installer as well as trying by writing the disk image to SD card with Win32 Disk Imager…

The process of putting the image on the SD card seems to go perfectly well; however, when I put the SD card in my pi and plug in the power… no signal, at all!

I’ve tried two different SD cards and two different first gen pi but sadly I get the same results no matter which way I try to combine them.

Not sure what else you would need to know but, if it makes a different, it is micro SD cards in SD card adapters - one of them is 8gb and the other is 32gb

Previously had RaspBMC running on the 8gb card and, as a test, have successfully had Raspbian running on it. I have also had OpenELEC running on the 32gb one so it just seems to be OSMC that is stumping me?? :confused:

I had hoped that OSMC would be available via NOOBS (where I got raspBMC from originally) but unfortunately it looks as though NOOBS only has raspbian on it now?

Thank you in advance for any help you can offer me!

PS: by no signal I mean that nothing seems to boot at all; so it is just the black TV screen saying no signal with the countdown timer for it putting itself to standby mode.

Here’s what is on the SD card that I have put OSMC on:

See if your micro-sd is in this list: http://elinux.org/RPi_SD_cards
It is a list of known/not known to work cards on Pi

Also, when you say no signal at all I’m assuming the PI does turn on right?

You can also try to see if the problem doesn’t lie in your HDMI cable

1 Like

Hi and thanks for your reply.

My cards are listed on the link as known to work and as mentioned I have successfully had other OS running on them - seeing as I wiped raspBMC from the card to put OSMC on it but haven’t been able to I am now running open elec on the card without any issues (although I would prefer OSMC).

I have disconnected all cables and reconnected ensuring all are seated properly and firmly but still there is nothing on the tv screen when I put the OSMC card into the pi. Everything works fine with the open elec card.

By no signal I mean the power goes to the pi (as in lights come on although I am unsure for how long the working light is on as my case blocks view of it) but nothing appears on screen at all. I have tested the cards in two pi in two different locations so different TVs, HDMIs, power cables etc and OSMC does not come up on either of them… As in I have never seen the “formatting device” screen or anything yet.

Thank you again for your reply; I know it has to be something that I’m doing wrong but I just can’t seem to figure out what that is :frowning:

What steps do you take to install OSMC on the card?

Can you try on another computer?

Are you sure you are installing the RPI 1 image ?

OSMC is available via NOOBS.

For your non booting issue. Change HDMI cable, power down the PI and the TV for one minute.
If still not successful tell us what the LED’s on the Pi show while powering on.

I have followed these steps…

  1. put card into sd card slot on laptop and formatted it using SDFormatter (settings were full erase as format type and size adjustment on).

  2. Once the SD card had been formatted I then took it out of the laptop and inserted it again (not really sure what made me do this tbh) and then used the OSMC installer (which I downloaded from Download - OSMC) on a windows laptop.

I selected English as the language and Raspberry Pi 1 / Zero as the OS to install.

  1. Once the installer said that the install was complete I safely removed the SD card, put it in the pi and then connected the power and although the Rpi lights come on, nothing appeared on screen.

When trying to mount the image file myself to the pi I followed step 1 again to format the card. Rather than use the installer I unzipped the image file I downloaded with 7zip and used Win32DiskImager to write the image to the SD card.

In both instances I could see files had been added to the SD card but nothing happened when plugged in to the pi and it was powered up.

I have tried used another laptop but again it didn’t make a difference. I have not tried with my desktop yet though so there’s potential there I guess?

I am 100% certain that I am selecting the Raspberry Pi 1 option on the installer and from the disk image section; I contemplated trying a Pi2 image but as I know I definitely have a Pi1 there isn’t any point… right? lol

Do the leds on the Pi flash a code when it fails to boot? Count the flashes. Have you tried a different SD card? Inspect the sd card carefully for cracks or warping, try pushing down on the card or squeeze it with a clothespin/spring clip to make better contact See attached picture of crack

When I downloaded NOOBS from Download NOOBS for Raspberry Pi the only option that came up was Raspbian (which installed and works fine) but no other options showed at all… I’m presuming it’s because I was not connected to the internet that no other options were listed?

I have a dongle connected to my Pi but NOOBS didn’t allow me to click on any settings option etc to connect to wifi before selecting the OS hence only Raspbian was available as a selection… not sure if that’s normal or whether I should have been able to configure wifi through the NOOBS installer to access more builds online?

I will have a go at swapping the HDMI lead out for another one in a bit… thank you

Hi and thank you for your reply!

I have tried two different SD cards (both are micro SDs with adapters) and have tried each of the micro SDs in the other adapter. I’ve also used the adapter from another pi which I still have raspBMC running on and unfortunately still no input signal seems to reach the TV.

I haven’t actually recorded the light sequence once power is getting to the pi but I will take my case off and count the number of flashes that come up tonight!

Thank you for suggesting using a clothespin / spring clip to make better contact; I am willing to try anything and everything to get it working lol

So… There is an issue somewhere with the card, the image I put on it or how I put it on I’m guessing. The only light to come on is the power light when I have the OSMC card in. Whereas the act and lnk lights come on with the openelec card…

What should I do next? Baring in mind I have put OSMC on both of these cards and couldn’t get it to work with either whereas openelec worked fine??

My guess would be wipe the card and try again…? But what would I do differently, any ideas?

Ps the HDMI cable didn’t make a difference (naturally seeing as there’s something wrong with the card, image or technique I used as mentioned)

Using the OSMC installer select the previous months image and see if that works

Which cards?

Which version of OE did you use? OE’s stable release is quite old. Do one of their beta releases still work?

I tried this with mounting the image to the SD but using the installer is something I should have thought of - doing this as I type now! Thank you for the suggestion :beers:

Do you have any other Computer to try? Maybe one with a different OS, because the problem may lie in your laptop card reader.

Also, just a question: Why do you wipe yourself the card before installing OSMC? The installer doesn’t do it by itself?

Yes, the installer is a block level write off the image to the card so formatting is just a waste of time.

Hey, thanks for getting involved!

The card I got with the pi from cpc (farnell) is a San-Disk SDSDQU-008G-U46, class 10 and having checked the adapter for signs of cracks etc it looks to be fine externally… of course I am lead to believe it is fine internally also as it ran raspBMC and openElec as well so I believe the connection is being made between micro sd and the adapter.

It was the stable OE that I installed first, I will try a beta though and let you know… do you think it could be the card that can’t handle it maybe??

I have access to 2 laptops and a desktop, one laptop is windows 10 (this one) and the other is windows 7. The desktop is vista I think but I haven’t used it in relation to this yet. Would the laptop card reader be at fault for one OS? eg if it installed noobs and open elec (stable), would there be a reason for it not to work for OSMC?

I presumed (I will learn not to) that it would be advisable to wipe the card just to be starting with a clean slate so to speak :blush:

I guess that teaches me for assuming lol

As a side note, I just want to say thank you again for everyone’s contributions on this; genuinely very appreciate of the help, suggestions and questions!

Are you saying a NOOBS install, selecting OSMC still doesn’t work?

Most odd…

I don’t even get an option for OSMC on NOOBS… the only option I had was Raspbian when the pi booted up which is not how I rememver noobs back when raspBMC was on there

ps I downloaded noobs_v1_9_1

pps and yes, I have truly stumped myself! :sob: lol