Help with Vero 4k remote control


There is something wrong with my Vero 4k remote control.

My Vero 4k remote is blinking. I even purchased a new battery.

But it simply doesn’t work anymore. The only thing I did was a shutdown via the Kodi menu, to clean where my Vero 4 is placed.

When I put back on, stopped working altogether.

Can someone help me to debug this?

I would appreciate any help.


Well, I have just tested the USB RF Receiver and it is apparently dead.

This is the output of lsusb on Vero 4K:

osmc@Vero_4K:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

on the RPI3 that I own, also running OSMC the USB RF Receiver isn’t being listed.

I do also own one UUGEAR USB Hub.

When you connect a USB device and everything is ok a white led, right beside the USB port being used lights up.

That is not happening with the RF USB dongle receiver that came with my Vero 4k.

This UUGear USB Hub is connected on a Pi Zero running Raspbian and there is nothing new being listed when I run lsusb on it.

I have also plugged the USB dongle to a laptop running WIndows. Nothing happens.

Until now, I have never connected this USB RF dongle to any other device. It has been plugged all the time on the Vero 4k.

How can I replace this faulty usb dongle?

Have you tried re pairing the remote?

Don’t plug the receiver in to a powered hub or you will likely damage the dongle

Is this a new order or have you had the Vero 4K for some time? Have you relocated the receiver at all?


I had this remote/dongle working for some time. Although it was very unstable. As you probably already noticed, I am the one user that has the issue with the monitor with the wrong resolution (1920x1200).

So in order to use it properly, sometimes I take my Vero 4k to the living room. Today it was one of this days. But this time a couple of reboots didn’t sort this “not responding remote issue”.

The USB Hub it was the last one I plugged it. I had already tested on my Rpi3 and It didn’t work as well.

How was the remote unstable before?
Do you have another OSMC remote? (Makes testing easier)

Otherwise please email with your order # and we can get it replaced

It went like this. Every time I moved my vero 4k to my living room because of my monitor resolution issue (Monitor resolution wrongly recognised - #48 by sam_nazarko) the remote didn’t work at first. It only worked after a couple of reboots.This happened all the time I moved my Vero 4k to my living room.

I do not own another OSMC Remote. I have a small keyboard remote, also with a USB RF Dongle connected to my RPis since 2014.

I’ve replied to your email. The incidence of a failed remote dongle is very low (about 1 in 5000).

We will get this swapped out for you. I’ll see what can be done regarding the resolution changes as well


Hi Sam.

Thanks for replying it.

I’ve looked into my email inbox. There are only two automatic email responses entitled “you’ve almost made it” asking me to complete purchase of a Vero 4K.

Indeed. It never crossed my mind when this issue started today that it could be the USB RF dongle. I even went out to purchase a new battery for the remote. :slight_smile:

Never before a USB dongle failed on me.

Hi – there was a bug which caused some abandon cart emails to resend randomly. Sorry about that! Shouldn’t happen again.

I’ve resent yesterday’s email.

Hi Sam.

Thanks for the big effort with VERO. My USB dongle is also dead, so will it be possible to buy a new USB dongle, without buy a new remote control? The VERO 4K is only a few month old, but I got my VERO 4K “second hand”, so have no Order#. Thanks in advance.



Have you tried pairing the remote with the usb:

Also the remote may just need a new battery.

Thanks Tom.

Tried with a new battery, no luck. But will try to try pairing late.
Thank you for the quick answer.

The pairing goes well. Tried to power off and restart, but no funktion. The blue indicator works fine, but no reaction. The HDMI CEC remote works fine, but I miss the “MENU” button… ;o)

Any other good ideas for the remote?

It sounds potentially faulty.
Can you get the original receipt off the person you bought it from?

Otherwise ping and we can offer a discounted replacement.


Hi Sam.

Sorry for the delay, lots of traveling.
Tried a new USB dongle and it seems like the remote is pairing goes OK.
Will try a clean install of KODI 18, before I do anything else.