Helping installing sab & radarr

I got it working. I think it just needed a reboot and then worked fine.

Joakim’s script

So defintely no way I could use Clonezilla etc to move existing system on 4k to V?


1 Like

Can you tell me how to start the script?
Do you have a dummies guide.
I assume I use terminal (I’m using a MacBook).
Do I have to have your folder locally on the vero or on the MacBook?
sorry for the questions, i have used terminal to configure the osmc on the vero but not to do something like this.

Yes, use a terminal app. Script needs to be on your Vero. Execute with:
sudo ./

Another one from me! I have everything set up and working now but my apps can’t see external usb drives. I guess this is a docker thing. How can I give them access to the drives in /media ?

If I add to yml file: is the syntax going to be something like this (for sab)

-v /media/INTENSO/temp:/incomplete-downloads
-v /media/OneTouch/completed:/downloads

Am getting command not found when I try that command.
have changed dir to the one which have the files and same result.
This is my input and result

osmc@osmc:/media/16 GB MICRO$ sudo ./
sudo: ./ command not found

looks like you have a colon after sudo

@Wavy_Davy how did you out the .sh file onto the OSMC device? I’m guessing some widows/mac application, that isn’t always the best way. I usually click on the script file on github, right click on Raw button and copy link.

Then ssh to OSMC and run wget [paste] && chmod +x filename && /filename, now this might not be optimal. But since I can at least understand 60% of common script and basics in multiple languages, I can often browse the file on github before downloading and running it n one go.

Sorry for delay, had to go and get a covid jab.
Thanks Joakim, have managed to get the file into a folder ok
but still getting the same message.

here is the output showing it’s in a folder and the result of using the command you suggested.
The colon after the sudo command is the output after trying to run it, not in the command.

osmc@osmc:/docker$ dir
osmc@osmc:/docker$ sudo ./
sudo: ./ command not found

sudo bash

Thanks, tried your command and got line 1: payload:allShortcutsEnabled:false: command not found

Also found online to type "sh "and drop file into terminal. and got
$ sh /Users/Dave/Downloads/OSMC-dockerinstall-main/
sh: 0: cannot open /Users/Dave/Downloads/OSMC-dockerinstall-main/ No such file

File is there. will have to leave for an hour as I have a zoom meeting to attend. Will maybe try using a windows machine to install it.

I’m not seeing an issue. Here is start to finish from my PC (using @joakim_s prefered method)…

C:\Windows\System32>ssh osmc@verov
osmc@VeroV:~$ wget && chmod +x && sudo ./
--2023-09-20 12:04:24--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: [following]
--2023-09-20 12:04:24--
Resolving (,,, ...
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5778 (5.6K) [text/plain]
Saving to: ''

docker_arm64_installer_for_OS 100%[=================================================>]   5.64K  --.-KB/s    in 0.001s

2023-09-20 12:04:25 (7.90 MB/s) - '' saved [5778/5778]

+ sh -c 'apt-get update -qq >/dev/null'
+ sh -c 'DEBIAN_FRONTEND=noninteractive apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null'
+ sh -c 'install -m 0755 -d /etc/apt/keyrings'
+ sh -c 'curl -fsSL "" | gpg --dearmor --yes -o /etc/apt/keyrings/docker.gpg'
+ sh -c 'chmod a+r /etc/apt/keyrings/docker.gpg'
+ sh -c 'echo "deb [arch=arm64 signed-by=/etc/apt/keyrings/docker.gpg] bullseye stable" > /etc/apt/sources.list.d/docker.list'
+ sh -c 'apt-get update -qq >/dev/null'
+ sh -c 'DEBIAN_FRONTEND=noninteractive apt-get install -y -qq docker-ce docker-ce-cli docker-compose-plugin docker-ce-rootless-extras docker-buildx-plugin >/dev/null'
Thank you for using this installer, remember it can uninstall for you too.

Think I might have done it using darwindesigns’s text from above.
Now to figure out how to get Home Assistant running, but not tonight.
Thanks darwindesign and all who helped, and especially joakim_s for the script

1 Like